***The MSI GS60 Ghost Pro 970M Owner's Lounge***

Discussion in 'MSI Reviews & Owners' Lounges' started by charliex3, Oct 7, 2014.

Thread Status:
Not open for further replies.
  1. atom003

    atom003 Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    3
    Trophy Points:
    6
    That would be great if I can talk to both XoticPC and MSI rep. Last time I had an issue with this laptop, I emailed XoticPC to ask how I should proceed to get my laptop fixed. They said that North America MSI headquarters is only an hour away from where I live so I should contact MSI and sent it there for a quicker fix. After getting my laptop back from MSI, I tried calling MSI to ask what the issue was. Unfortunately they didn't call me back to answer my question, and is still a mystery to what actually happened to my laptop. If you can point me to the right direction so I can talk to both reps it would be great. Thanks for the help.
     
    mason2smart likes this.
  2. nachtluce

    nachtluce Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Esulin, from your post it sounds like you may have installed linux on your MSI ghost pro. I have an MSI GS60 ghost pro 4k-053 and haven't been able to get Ubuntu to install properly on it, it either hangs at the login screen or goes to a black screen at boot. I have installed the nvidia drivers using `ubuntu-drivers autoinstall` from a recovery shell. If you have any ideas on this help would be much appreciated. Thanks.
     
  3. Yippee38

    Yippee38 Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    16
    Mine is going back to Microcenter. It's got really bad backlight bleed in the lower-left corner.
     
  4. Infernoz

    Infernoz Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hello guys,

    I'm going to buy either a GS60 or GE62 in the next couple of weeks.
    I heard many complaining about the space bar issue on the GE62, so i was wondering if the same issue exists on the GS60.
     
  5. Yippee38

    Yippee38 Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    16
    <sigh> #2 going back for back light bleed. I hope one of the other two they have are better.

    I suspect they will not be better though. The two laptop I've tried are 47 numbers apart (serial numbers). They both have really bad bleed in the lower-left corner and along the top from the middle of the screen to about 1.5" from the upper-left corner. The first had a couple of other spots. I fired this one up in the store, but the store is so damn bright, it's almost impossible to see if there is bleed. I'm gonna have to use my coat like a tent to check them when I go back. ;D
     
    mason2smart likes this.
  6. Yippee38

    Yippee38 Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    16
    Got a 3rd laptop. It's still got backlight bleed, but it's not nearly as bad as the other two. Just a bit along the top of the screen.

    BTW, I talked to MSI tech support two days ago. They said that some backlight bleed is normal for that type of display, but it should be fairly uniform around the entire monitor. This one is, the prior two were not at all.

    Now I'm trying to get Win 7 installed and it's a PITA.
     
  7. Yippee38

    Yippee38 Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    16
    Has anybody successfully installed Windows 7 on this laptop? I've gotten to the point where I can start the install, but I cannot find a working NVMe driver for Windows 7. Can anybody point me to the correct driver, or a guide on how to get the NVMe drive recognized?
     
  8. mason2smart

    mason2smart Notebook Virtuoso

    Reputations:
    232
    Messages:
    2,440
    Likes Received:
    1,353
    Trophy Points:
    181
    If MSI okays it I would try unplugging and replugging the battery
     
  9. vfive

    vfive Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    bro I have the same issue. buzzing sound thing.. you solved the problem?
     
  10. GreaseMonkey90

    GreaseMonkey90 Notebook Evangelist

    Reputations:
    170
    Messages:
    454
    Likes Received:
    69
    Trophy Points:
    41
    I can't solve it. It has something to do with the GPU. Which model are you using?
     
Thread Status:
Not open for further replies.

Share This Page