T61/X61 SATA II 1.5 Gb/s cap - willing to pay for a solution

Discussion in 'Lenovo' started by dubak, Feb 14, 2010.

?

Would you be willing to spend some money for a solution enabling SATA II on your T61/X61

  1. YES

    228 vote(s)
    71.3%
  2. NO

    92 vote(s)
    28.8%
Thread Status:
Not open for further replies.
  1. DigiDoc

    DigiDoc Notebook Consultant

    Reputations:
    197
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    30
    OK, here's the results of some early tests I did.

    Hardware: T61, T7300CPU, 8GB DDR2 RAM, 60GB OCZ Solid2 SSD (main boot drive - firmware 1.5), 64GB Kingston SSDNow (in ultrabay, but not tested), 1440x900 LCD, Vista x64 Professional.

    Going to the 2.27 patched bios didn't affect the screen being detected correctly. It didn't neuter my 8GB of RAM either. :D

    Here's the benchmark tests in text format. There's an enormous increase in sequential read/write speed now. Vista definitely booted a few seconds faster after doing the BIOS update. Unfortunately I didn't use a stopwatch, but running the numbers below it's undeniable that it's loading data from the SSD faster now. Random 512k reads got a nice shot in the arm too. :)

    with 2.26 unpatched BIOS

    -----------------------------------------------------------------------
    CrystalDiskMark 3.0 x64 (C) 2007-2010 hiyohiyo
    Crystal Dew World : Crystal Dew World
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

    Sequential Read : 132.196 MB/s
    Sequential Write : 107.140 MB/s
    Random Read 512KB : 114.941 MB/s
    Random Write 512KB : 40.069 MB/s
    Random Read 4KB (QD=1) : 16.701 MB/s [ 4077.4 IOPS]
    Random Write 4KB (QD=1) : 5.717 MB/s [ 1395.7 IOPS]
    Random Read 4KB (QD=32) : 67.191 MB/s [ 16404.0 IOPS]
    Random Write 4KB (QD=32) : 4.910 MB/s [ 1198.7 IOPS]

    Test : 1000 MB [C: 71.6% (42.7/59.6 GB)] (x5)
    Date : 2010/07/22 23:23:29
    OS : Windows Vista Business Edition SP2 [6.0 Build 6002] (x64)



    with 2.27 patched BIOS


    -----------------------------------------------------------------------
    CrystalDiskMark 3.0 x64 (C) 2007-2010 hiyohiyo
    Crystal Dew World : Crystal Dew World
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

    Sequential Read : 196.842 MB/s
    Sequential Write : 106.368 MB/s
    Random Read 512KB : 155.151 MB/s
    Random Write 512KB : 52.319 MB/s
    Random Read 4KB (QD=1) : 15.889 MB/s [ 3879.1 IOPS]
    Random Write 4KB (QD=1) : 5.260 MB/s [ 1284.2 IOPS]
    Random Read 4KB (QD=32) : 69.936 MB/s [ 17074.2 IOPS]
    Random Write 4KB (QD=32) : 4.813 MB/s [ 1175.2 IOPS]

    Test : 1000 MB [C: 71.4% (42.6/59.6 GB)] (x5)
    Date : 2010/07/22 23:36:20
    OS : Windows Vista Business Edition SP2 [6.0 Build 6002] (x64)



    I'll be doing some tests with large data files to make sure there's no data corruption issues. So far it looks VERY promising!



    So Middleton... where do I send the check? :)
     
  2. Karhu

    Karhu Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I flashed my T61P with this bios. Now the ultrabay hd is in PIO mode and I cannot enable dma.
     
  3. DigiDoc

    DigiDoc Notebook Consultant

    Reputations:
    197
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    30
    What OS? Also, did you install the latest Intel Rapid Storage Tech driver?

    For testing purposes, I swapped in my 320GB WD Blue HD into my ultrabay adapter (cheap generic ebay adapter from China). It shows up as UDMA being enabled in device mangler.

    If you can't get it to enable, after you install the latest Intel RST driver, boot into safe mode and remove the device entries in device manager and then reboot. See if that resolves the issue.
     
  4. Karhu

    Karhu Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I have Winxp Pro SP3. Now it works. First I installed Intel Rapid Storage Tech driver. It didn't help.
    I tried a quick solution from this site, and it works!
    DMA reverts to PIO | Windows Problem Solver

    Thanks!
     
  5. jason930

    jason930 Notebook Enthusiast

    Reputations:
    2
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    5
    i have flashed this bios successfully, but found that it does not contain slic2.1

    do this bios enable sata2 only? no whitelist and slic2.1?:)
     
  6. middleton

    middleton Notebook Consultant

    Reputations:
    212
    Messages:
    284
    Likes Received:
    2
    Trophy Points:
    31
    You need separate BIOS patch for X61 tablet. Do you want me to make it?

    See my previous post with links to BIOS.

    I'm planning to wait a month to be sure that SATA II BIOS patch works stable and without issues. Then I'll add whitelist and slic.
     
  7. XStoneX

    XStoneX Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    15
    Sounds good, could be the "Ultimate BIOS" for our T61 & X61 ;), optional with your CTRL+FN swap mod it would be unbeatable!

    My last problem is the "Thermal Sensing Error" which I have because I pimped my T61 with a T9500 Penryn CPU. But my mainboard doesn't support the Penryns officially - see this post. A lot of T61 users have this problem, if we will get a solution to deactivate this error (we have to press "ESC" before starting Windows, otherwise the T61 turns off), it would be a dream which comes true... :biggrin:

    BTW: I've done the donation as promised.

    Greetz,

    XStoneX
     
  8. zephir

    zephir Notebook Deity

    Reputations:
    495
    Messages:
    1,144
    Likes Received:
    1
    Trophy Points:
    56
    If it's not too much trouble to you, that would make my life complete. :)
     
  9. crashnburn

    crashnburn Notebook Consultant

    Reputations:
    17
    Messages:
    269
    Likes Received:
    3
    Trophy Points:
    31
    - X61T
    please :)

    - Waiting for the..
    SLIC 2.1
    Whitelist

    for both.. X61T and T61

    I'd love to test it out.

    PS: People please post the T61, X61 & X61T models for which you have this working. With HDDs / Docking stations etc??
     
  10. erik

    erik modifier

    Reputations:
    3,647
    Messages:
    1,610
    Likes Received:
    0
    Trophy Points:
    55
    just don't use that BIOS on your X61s.   even though it works in general, it's not compatible with bluetooth, ultrabase, and the thinklight status icon (among other things).
     
Loading...
Thread Status:
Not open for further replies.

Share This Page