[T450s] Display Driver Stops Responding - Reinstalled OS, Still Happens

Discussion in 'Lenovo' started by whizzo, Sep 14, 2017.

  1. whizzo

    whizzo Notebook Prophet

    Reputations:
    769
    Messages:
    5,851
    Likes Received:
    2
    Trophy Points:
    206
    I bought my Lenovo T450s in September 2015 and installed Win7 64 Pro at that time. For a few months now, I would sometimes get an error when using it unplugged (on battery power) where the screen will go black for a moment, and then an error message will come up along the lines of "Display Driver for Windows 7 has stopped responding and has successfully recovered". This was a bit annoying, especially since it often led to browser windows crashing and then requiring restart.

    Yesterday I installed a fresh copy of Win10 64 Pro. However, the error message still occurs! This makes me wonder whether it's a hardware issue. Is this a known problem with my model of laptop? Should I contact warranty services? Would love some feedback on this.
     
  2. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    800
    Messages:
    3,322
    Likes Received:
    1,589
    Trophy Points:
    231
    Try updating to latest Intel driver and if there is any dGPU install their drivers from official site of AMD or Nvidia.
     
  3. ZaZ

    ZaZ Super Model Super Moderator

    Reputations:
    4,643
    Messages:
    33,262
    Likes Received:
    766
    Trophy Points:
    531
    huntnyc and Vasudev like this.
  4. whizzo

    whizzo Notebook Prophet

    Reputations:
    769
    Messages:
    5,851
    Likes Received:
    2
    Trophy Points:
    206
    To the next poor schmuck struck by this issue and searching online for answers - the Lenovo service technician swung by and replaced the LCD and the LCD ribbon cable. The issue seems to be fixed now (no more blackouts for over two weeks).
     
    huntnyc and Vasudev like this.
  5. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    800
    Messages:
    3,322
    Likes Received:
    1,589
    Trophy Points:
    231
    Some kind of weird GPU switch issue. My aunt said its fixed and hasn't occurred for last 2 days.
     
Loading...

Share This Page