Stuck at 50hz with Origin games!

Discussion in 'Gaming (Software and Graphics Cards)' started by tiner, Jun 18, 2017.

  1. tiner

    tiner Notebook Evangelist

    Reputations:
    100
    Messages:
    405
    Likes Received:
    16
    Trophy Points:
    31
    Hi!

    When I play any game from Origin (i.e. battlefield 1 or FIFA 17) when it comes fullscreen the Framerate drops to 50 locked FPS. If I play windowed mode I have no issues.

    I wanna go 60 FPS fullscreen and I don't manage to find out how to get them. Tried disabling shadow play and Xbox DVR with no success.

    Any suggestion?

    It only happens with origin games and with HDMI!

    Enviado desde mi Aquaris M5 mediante Tapatalk
     
    Last edited: Jun 18, 2017
  2. Knight666

    Knight666 Notebook Consultant

    Reputations:
    21
    Messages:
    237
    Likes Received:
    163
    Trophy Points:
    56
    Depends on TV. With my old Samsung TV I was able to play only at 50fps (50Hz lock display). PS3, PS4 Pro and X360 we're all the same.

    HDMI supports 60Hz, so don't worry about it. It's not the reason.
     
  3. tiner

    tiner Notebook Evangelist

    Reputations:
    100
    Messages:
    405
    Likes Received:
    16
    Trophy Points:
    31
    Note that I'm playing every last game with 60hz.

    It's something origin games related...

    Enviado desde mi Aquaris M5 mediante Tapatalk
     
  4. Tanner@XoticPC

    Tanner@XoticPC Company Representative

    Reputations:
    342
    Messages:
    2,646
    Likes Received:
    2,796
    Trophy Points:
    181
    Do they Frames ever go over 60 or are they capped? As well what application as you using to measure your FPS?
     
  5. anna88

    anna88 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Maybe try to reboot the settings in TV?
     
Loading...

Share This Page