Step by Step: 980m Install in Alienware 18

Discussion in 'Alienware 18 and M18x' started by 1Schumsta1, Jan 8, 2015.

  1. KrisValentine

    KrisValentine Notebook Enthusiast

    Reputations:
    0
    Messages:
    40
    Likes Received:
    5
    Trophy Points:
    16
    Hi everyone,

    I am an Alienware 18 owner, my laptop has 2 GTX 780Ms in SLI, 32GB RAM and an i7 processor.

    My cards are starting to be a little on the underwhelming side now, they run my HTC vivr fine for most things but my AW18 could do with an upgrade.

    I would like to upgrade to the 980Ms in SLI.

    I have upgraded my BIOS to A13 from A03 (although now I understand the BIOS has to be unlocked to swap cards?), I have been looking GTX980Ms on ebay and eurocom, i have the right heatsyncs (the ones with my 780ms) but I cannot source the Prema Mod vBIOS anywhere, I've been all over every site these guys have and have come up short.

    Please could any of you guys give me some help to accomplish this mod please?

    questions:

    1. Does anyone have any updated links or have the vBIOS package still on their computer I could have

    2. could anyone give me an update for 2018, such as BIOS issues, fan, heatsync issues etc or if these have been rectified

    3. Does anyone know if i can use the SLI cable going between my 780Ms for SLI with the 980ms

    4.I keep finding 2nd hand cards on ebay with g-sync, what does that mean

    5. Does anyone know an alternative vBios if I can't get hold of the Prima one

    6. What is the differnce betweek a locked and an unlocked bios, where can i get an unlocked bios and why can't I jsut swap the cards out for the new ones on a stock BIOS downloaded from Dell

    thank you, I really appreciate any help people can give me. :D
     
    Last edited: Jun 20, 2018
  2. KrisValentine

    KrisValentine Notebook Enthusiast

    Reputations:
    0
    Messages:
    40
    Likes Received:
    5
    Trophy Points:
    16
    -
     
    Last edited: Jun 20, 2018
  3. imest

    imest Notebook Consultant

    Reputations:
    6
    Messages:
    112
    Likes Received:
    27
    Trophy Points:
    41

    1. Does anyone have any updated links or have the vBIOS package still on their computer I could have
    Prema has asked not to share the vBIOS. Not sure where to get, might try sending him a PM or maybe Mr. Fox can be of assistance.
    2. could anyone give me an update for 2018, such as BIOS issues, fan, heatsync issues etc or if these have been rectified
    It is recommended to stay on A12 as A13 reduces performance of CPU.
    3. Does anyone know if i can use the SLI cable going between my 780Ms for SLI with the 980ms
    Yes, you can use the same SLI cable. (Please correct me if I am wrong).
    4.I keep finding 2nd hand cards on ebay with g-sync, what does that mean
    I believe there are 2 versions of the 980m GTX card one is g-sync and another is not.
    5. Does anyone know an alternative vBios if I can't get hold of the Prima one
    Here is one posted by Raidriar http://forum.notebookreview.com/threads/release-980m-single-undervolted-vbios.800491/
    6. What is the differnce betweek a locked and an unlocked bios, where can i get an unlocked bios and why can't I jsut swap the cards out for the new ones on a stock BIOS downloaded from Dell
    You do not need an unlocked BIOS, you just need A12 or higher for Nvidia GTX 980m to work with the Alienware 18 (Viking). The difference is Dell's hidden settings are available with an unlocked BIOS (not needed for 980m upgrade just A12 or higher).
     
  4. Kade Storm

    Kade Storm The Devil's Advocate

    Reputations:
    1,591
    Messages:
    1,860
    Likes Received:
    198
    Trophy Points:
    81
    I can confirm that the same cable for the SLi 780M GTX works with the SLi 980M GTX upgrade.
     
    Aroc and imest like this.
  5. KrisValentine

    KrisValentine Notebook Enthusiast

    Reputations:
    0
    Messages:
    40
    Likes Received:
    5
    Trophy Points:
    16
    Thank you guys for the helpful replies. Do the cards not cove with a vBIOS pre installed? or is custom needed to get the cards to work? It's turning out to be quite the project :)
     
  6. imest

    imest Notebook Consultant

    Reputations:
    6
    Messages:
    112
    Likes Received:
    27
    Trophy Points:
    41
    The cards should come with a vBIOS installed. Just ask the vendor you buy them from and verify that it is a compatible Dell vBIOS.
     
    Aroc likes this.
  7. opacik

    opacik Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hello,
    Pls help cause I have an issue with 980ms sli in aw18.
    Bios a13 official from dell's site, two different official vbioses to 980ms from dell's site also installed (bioses made by dell to properly see fans). Set UEFI mode in bios.
    Both cards install fine in sli, everything ok with drivers etc.
    But aw18 shuts off after some minutes of turning on ... fans going max velocity, three seconds of space and computer shuts off...
    I checked temps of both cards in hwinfo and in gpuz and temps are completely ok - 50-60 degrees.
    Why my aw18 shuts off???
     
    Last edited: Aug 3, 2018
  8. skindoe

    skindoe Notebook Geek

    Reputations:
    10
    Messages:
    81
    Likes Received:
    13
    Trophy Points:
    16
    Try unplugging the battery and see if it works OK. A dead battery can cause random lock-ups and shutdowns from my experience.
     
  9. Rengsey R. H. Jr.

    Rengsey R. H. Jr. I Never Slept

    Reputations:
    995
    Messages:
    2,574
    Likes Received:
    824
    Trophy Points:
    131
    AW 18 has been broken from day 1 lol ... I think I went through 2-3 motherboard when I had that model.
     
  10. electrosoft

    electrosoft Tick Tock Clarice....

    Reputations:
    1,694
    Messages:
    2,834
    Likes Received:
    483
    Trophy Points:
    101
    @opacik

    Did you reset your cmos (remove battery, cmos battery, hold power button for 30 sec)?
    Verify your PSU is properly being detected in the BIOS
    Run Dell diagnostics
    Remove both cards and test with Intel graphics
    If working with integrated graphics, remove your slave card and test master card in single configuration. If working, flash slave to master and test in single card config to confirm both cards are working.

    If I had to guess, those dual 980m's are putting too much strain on what may be a compromised system board. Only way to really check is to pull them, cmos reset, run diagnostics just because, verify 100% operation with no GPUs installed then test each card as a master in slot 0.

    @Rengsey R. H. Jr. is pretty much on point. I've owned, repaired and deployed dozens of AW18 to family, friends and guildies. Running less demanding GPUs and low to no problems. As soon as you put in some heavy hitter cards (780m/880/980m), that's when things start to go south, especially in SLI. At this point, I run my few remaining AW18's with 770m/860m's w/ 4930's and 4940's and have zero problems.
     
    Rengsey R. H. Jr. likes this.
Loading...
Similar Threads - Step Step 980m
  1. Kittys
    Replies:
    4
    Views:
    844

Share This Page