Spectre and meltdown - firmware/UEFI update

Discussion in 'MSI' started by tiliarou, Jan 8, 2018.

  1. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    3,852
    Messages:
    14,096
    Likes Received:
    16,773
    Trophy Points:
    931
    uCode fix for Spectre, HT bug fix and Meltdown
    http://forum.notebookreview.com/thr...-fix-and-meltdown.806451/page-4#post-10662550

    That thread's been around since the Intel HT microcode update situation, still ongoing, and now updated to add the new microcode fixes, I sure hope they work...

    It's not clear if simply loading in the OS a new microcode overlay fixes or activates the protections - @cesvicmor doesn't think so - but vendor BIOS updates are coming through and the test scripts / apps are showing success.

    More info here too:

    CPU Vulnerabilities, Meltdown and Spectre, Kernel Page Table Isolation Patches, and more
    http://forum.notebookreview.com/thr...patches-and-more.812424/page-48#post-10662593
     
    Vasudev likes this.
  2. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    622
    Messages:
    6,774
    Likes Received:
    1,322
    Trophy Points:
    331
    Need BIOS update
    Need OS update
    Need virus definition update
     
    hmscott and Vasudev like this.
  3. tiliarou

    tiliarou Notebook Consultant

    Reputations:
    14
    Messages:
    131
    Likes Received:
    165
    Trophy Points:
    56
    Yes I saw these topics. But at the time of my posting, the first one was not updated for Spectre Meltdown.
    Moreover, the Vmware driver is loaded at boot after kernel and thus, is not a proper mitigation as is a real microcode update via Bios update, but it's better than nothing cause exploit needs to happen before this driver is loaded (at least that's my understanding).
     
    hmscott likes this.
  4. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    3,852
    Messages:
    14,096
    Likes Received:
    16,773
    Trophy Points:
    931
    Do the tests run and show success when using the vmware driver microcode application?
     
    Vasudev likes this.
  5. tiliarou

    tiliarou Notebook Consultant

    Reputations:
    14
    Messages:
    131
    Likes Received:
    165
    Trophy Points:
    56
    For my system (laptop MSI GT72 2QE, i7 4710MQ, Haswell), only partly, windows is not activating mitigation measure since he detects that the hardware is not using proper microcode...

    As per: https://www.win-raid.com/t3351f47-Microcodes-for-branch-target-injection.html#msg46070
    "It depends on the CPU. My IB-E has no HW support for mitigation against BTI, but new microcode brings that HW support, and it happens that Windows kernel is loaded before VMware driver and it sees that there is no HW support and disables the mitigation. Only after I patched the BIOS file and flashed it Windows enabled the mitigation. So if your CPU has HW support for BTI mitigation (with current microcode) then you can use VMware driver."
     
    Vasudev and hmscott like this.
  6. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    3,852
    Messages:
    14,096
    Likes Received:
    16,773
    Trophy Points:
    931
    Would you be so kind as to reply to @cesvicmor in the other thread? I think they would appreciate the additional details in that thread too. :)
     
  7. Koen

    Koen Notebook Enthusiast

    Reputations:
    21
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    16
    I asked MSI Tech Support about the possibility of a GP60 2QF bios update and they said that:
    'We are currently working on this with MS&Intel.
    And we will release the update in the [future].'

    I hope Tech Support is informed fully of MSI's plans.
     
    hmscott likes this.
  8. sulky

    sulky Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    6

    Hi this is my first post, i too own a GT72 2QE, and on Wednesday this week my wife used it for the 1st time after Christmas and it updated . Turned it off until Friday and it wouldn't post past the MSI screen, but i stumbled upon a work around

    the full story is here,

    https://forum-en.msi.com/index.php?topic=298281.0


    but for some reason i cant access the msi forums as it says my password is wrong no matter if i change it or not.

    Now for the kicker i went on today and uninstalled the update for spectre and disabled the windows update function. It now starts every time with out fail. So if any of you 2QE guys run into this, try getting rid of the update.

    but it means that we NEED a bios update from MSI, if any off you are a member of the MSI forums and can log it can you update the post, so hopefully someone at MSI will see it
     
  9. Falkentyne

    Falkentyne Notebook Deity

    Reputations:
    1,587
    Messages:
    1,985
    Likes Received:
    2,135
    Trophy Points:
    181
    The MSI forums bug happens like every other day.
    It's a bug.
    Sometimes it says your password is wrong.
    Sometimes it says the capitcha is wrong.
    In those cases, you just have to wait....
     
Loading...

Share This Page