Sound card not detected...

Discussion in 'Alienware 18 and M18x' started by yohojones, Jun 11, 2012.

Thread Status:
Not open for further replies.
  1. Mr. Fox

    Mr. Fox BGA Filth-Hating Elitist

    Reputations:
    35,142
    Messages:
    37,539
    Likes Received:
    63,716
    Trophy Points:
    931
    Hibernation has some problems, too. But, it saves data to HDD and shuts down the system and sleep simply lowers power. I'm glad to know that helped. It proves it is a problem related to sleep, and ultimately a power-related issue. As mentioned, this is a very common problem with all kinds of hardware.

    Look for something in Windows Control Panel, not necessarily in Device Manager or the power profile. The M18x R1 has different hardware, but here is an example of something similar you should have in the Control Panel. See example image... The IDT Audio app has a way to disable power management. Your SoundBlaster audio probably does as well.

    IDT CP.JPG
    (click to enlarge image)
     
  2. digz6666

    digz6666 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    I updated my M17x R4 bios to A05 and it fixed the problem.
     
  3. Digit100100

    Digit100100 Notebook Enthusiast

    Reputations:
    0
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    15
    Not to keep this thread too active, but I may have come up with a solution. I have flashed A03 twice and the problem still occurs. But I just had a thought that maybe the issue was a conflict in the order of the drivers.

    This fixed it once for me (hopefully others can confirm or tell me whether I bring false hope):
    - through control panel, disable the HD audio controller that has the yellow exclamation or cross next to it (can't remember how it shows up but simply right click and choose disable).
    - right click and disable the HD audio controller that doesn't have an issue.
    - then re-enable the one that had issues - on mine it enabled perfectly once the other was disabled.
    - then re-enable the second one...also this enabled with no issues

    Straight away brought my sound back. Can someone else confirm this works for them?

    Not sure of a permanent solution, but hopefully this identifies the source of the conflict.
     
  4. pavlaras1

    pavlaras1 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hi,
    I have an Alienware M17x R4.
    And I have the same problem.
    It happen more than 5 times now even I had Windows 7 Ultimate 64bit and even with my Windows 8 Pro 64bit.
    No solution have been found also I have problem with the ejection button of my CD drive it doesn't work on windows 8 only on windows 7.
    There is many problems with this computer and specially on windows 8.
    Also my BIOS version is A10.
    I had also problem with my WIFI killer 1103 network card but I solved easy by re-installing the drivers every time that I had problem.
    The same problem that I had with my Ati Radeon HD7970M I solved the problem by re installing the drivers.
    But the sound card is dissapeard and the drivers cant see it and I cant re install it.
    I don't know what I must to do.
    Please if anyone know anything help me.
    Thank you.
     
  5. Alienware-Karen_M

    Alienware-Karen_M Company Representative

    Reputations:
    0
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    5
    Please send me a PM with your service tag, phone number and I'll check the available options to get a resolution.
     
  6. shadowyani

    shadowyani Notebook Deity

    Reputations:
    214
    Messages:
    791
    Likes Received:
    137
    Trophy Points:
    56
    My m18x r2 does this every few weeks. Removing the battery and holding down the power button to drain the board of charge fixes clears it up. It happens at such odd times I sympathize with Dell tech's frustration with diagnosing and fixing the issue. Personally I've given up on fixing all the little things with my machine (dpc latency still something my machine suffers from for example) since its out of warranty.

    Nowadays I just focus my energy on enjoying my machine when it does work. I've uploaded my personal fix for sli flicker, for example, and I'm pretty much burnt out with all the troubleshooting.

    Dell has replaced my system several times in the past, so I commend them on trying to make things right. I hope the best for Dell as they go through with tough choices they're currently facing as the company through their latest transition.

    To the rest of you seeking perfection from your m18x's, I salute you.


    For further discussion on Soundblaster Recon3Di issue, please visit this thread: http://forum.notebookreview.com/ali...questions-here-m18x-r2-m17x-r4-audio-fix.html
     
Loading...
Thread Status:
Not open for further replies.

Share This Page