[Solved] Corsair K95 RGB Keyboard - Windows 7 and Linux Stopped Working

Discussion in 'Desktop Hardware' started by Mr. Fox, Jun 27, 2019.

  1. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    27,885
    Messages:
    34,653
    Likes Received:
    54,471
    Trophy Points:
    931
    A few days ago I installed a new version of Corsair iCUE software for my K95 RGB mechanical keyboard and M65 Pro RGB mouse. This software package included a firmware update for the keyboard and mouse. After installation, the keyboard only functioned in Windows 10. It stopped functioning altogether in Windows 7 and it almost always had to be unplugged and reconnected several times in Linux to restore functionality. During verbose bootup, Linux was also throwing a ton of USB device enumeration errors. It functioned normally in Windows 10 and in the BIOS. It only malfunctioned after POST and hand-off to the Windows 7 and/or Linux OS occurred. The mouse never stopped working under any OS, only the keyboard.

    That sucks, because I use Windows 7 and Linux more than I do Windows 10 and I didn't want to have to use two keyboards, or replace it. I like it... older, but still super nice and extremely well made mechanical keyboard. Also, it is ridiculously expensive (way more than I would ever consider spending again on a replacement).

    Under Windows 7 it would not light up, none of the keys worked at all... basically dead with no evidence of life, and Device Manager showed it under Human Interface Devices with a code 10 "This device cannot start" problem status. If I deleted it in Device Manager and scanned for new hardware, the keyboard would light up initially, then the device would fail to install and end with the code 10 and the lights would go out.

    So, I contacted Corsair and found out it was a known issue and I would have to downgrade the firmware for Windows 7 and Linux because the "new and improved" cancer is incompatible with anything except Windows 10. What the Redmond Retards have done with Windows 10 is a sin and a crime. There is no excuse for making hardware only work on their latest abortion OS... apparently some sort of absurd nonsense with "USB device compliance for Windows 10" according to Corsair.

    The support people at Corsair were kind enough to provide the older/better firmware and instructions for flashing it. Awesome since it is no longer under warranty and still an amazing keyboard that cost me way too much to be faced with the only option being tossing it into the garbage or using Windows 10 only... neither of those are good options. Kudos to Corsair for having such great support. (I've used their support in the past for other products and it's always fantastic, very similar to EVGA's outstanding support.)

    If you find yourself in this predicament with a K95 keyboard, the instructions to fix it and the firmware are attached. (Ignore the typos in the instructions, like reference to a mouse instead of a keyboard.)

    Reinstalling the firmware of your device may correct the issue. We suggest doing this manually, and have uploaded the firmware for your device to the ticket in order to do so. Please follow the directions below:

    1: Unplug your keyboard from the computer.
    2: Locate the small pinhole underneath your mouse. For some, this will be located near the polling rate switch by the cable. On others, it will be located underneath on the tilt legs on the bottom of the keyboard.
    3: Using a small paperclip or push-pin, press down on the button inside the pinhole.
    4: Plug your mouse back into the computer, while holding down the pinhole button.
    5: Once it is plugged back in, your computer should recognize a drive called CRP_Disabled. Please open this.
    6: Download the firmware file from the ticket. If it is compressed into a .RAR file, please extract this file to an easily found location on the computer.
    7: Delete the file FIRMWARE.BIN from the CRP_DISABLED drive, and then place the file with ISP in it’s name to the CRP_Disabled drive.
    8: Once you have performed the steps above, please unplug your keyboard and then plug it back in. The device will then return to normal.

    Please test to see if the issue reappears. If it does, please inform us on the ticket for further troubleshooting.

    The new Corsair iCUE software works fine with the old firmware. No need to downgrade the entire software package. All is well now and I'm back in business with the K95. Works perfect under Windows 7 again, and I am posting this running from Linux. No USB device enumeration errors from Linux.

    So, the moral to the story here (which most of us already know) is "if it ain't broke, don't fix it" and "newer doesn't always mean better" LOL. But, whodathunk that such danger would apply to something as seemingly innocuous as installing a keyboard utility software.
     

    Attached Files:

    Last edited: Jun 27, 2019
    evenflow153 and heliada like this.
Loading...

Share This Page