SMplayer: Avoiding Mouse Pointer Activation?

Discussion in 'Linux Compatibility and Software' started by Kyle, Nov 24, 2019.

  1. Kyle

    Kyle JVC SZ2000 Dual-Driver Headphones

    Reputations:
    1,740
    Messages:
    930
    Likes Received:
    441
    Trophy Points:
    76
    I'm having an issue with my laptop that has developed recently: When I'm watching videos in full screen mode, the mouse often somehow gets activated for a split second and this is bugging me. This behavior does not happen if I'm watching on battery, only when the AC charger is plugged in.

    Is there any way to disable cursor activation in SMplayer?
     
  2. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    6,634
    Messages:
    19,995
    Likes Received:
    24,816
    Trophy Points:
    931
    If there is no control setting in SMplayer, perhaps it is a mouse setting or UI setting that will control it? Sensitivity perhaps? Idle behavior?

    If this is a laptop, and you have an external mouse plugged in that is doing this, try changing ports on the laptop - use a power hub in between the laptop or mouse.

    Something that induces a glitch like a power spike or line noise might be involved too as it doesn't happen on battery, so get a line conditioner or simply move to using a different power strip or plug, isolate your heater or refrigerator from feeding power glitches into that particular line in your house.

    If it is an external mouse, you could simply unplug it and use the trackpad for video watching...

    Maybe a wireless trackpad / mouse / keyboard like the K400S from Logitech might help?

    Please let us know what it turns out to be. :)
     
    Mr. Fox, Kyle and jclausius like this.
  3. Kyle

    Kyle JVC SZ2000 Dual-Driver Headphones

    Reputations:
    1,740
    Messages:
    930
    Likes Received:
    441
    Trophy Points:
    76
    Thanks.

    It's not an external mouse, it's the laptops tracpad mouse.

    For now, I found smplayer has a setting where the play bar gets activated only when the mouse is moved to the bottom of the scree. I now have that setting. And I move the mouse to the top right corner while playing fullscreen video, so the bother is less.
     
    hmscott likes this.
  4. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    6,634
    Messages:
    19,995
    Likes Received:
    24,816
    Trophy Points:
    931
    Cool, good solution. I also forgot to mention if it is a built in trackpad being glitched, maybe plug in an external mouse - or that wireless keyboard - and set in the BIOS to disable the built in trackpad when plugging in an external pointing device.

    It is telling that it only happens when plugged in, and if it happens in multiple locations (power plugs, house, school, work) it could be a sign of a bad power brick or loose cabling.

    Good luck :)
     
    Kyle likes this.
  5. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    28,794
    Messages:
    35,075
    Likes Received:
    55,658
    Trophy Points:
    931
    It could be some driver or software is polling the system and causing what is known as "stealing focus" is resulting in what you are experiencing. Things like "on-screen display" (OSD) features that show an on-screen overlay when you do things like activate caps lock or change volume can steal focus. In addition to OSD software/drivers, Bluetooth monitoring apps are another example of something that can also cause this problem. Any TSR program can potentially cause this.

    If you run MSCONFIG and disable all non-Microsoft services (hide the Microsoft services and disable what remains) and reboot, to then find that the problem goes away, try re-enabling the services one or two at a time (process of elimination) to determine when the problem resurfaces. This will pinpoint the offending driver/service/app. Remember to reboot after making each change. In some of the most severe causes of drivers and utilities stealing focus it can crash games, or cause them to randomly minimize like an alt-tab does. That used to be a frequent problem a number of years ago, but it's not as common as it used to be.

    upload_2019-12-4_22-27-17.png
     
    Last edited: Dec 5, 2019
    hmscott and alexhawker like this.
  6. ALLurGroceries

    ALLurGroceries   Super Moderator

    Reputations:
    15,681
    Messages:
    7,125
    Likes Received:
    2,235
    Trophy Points:
    331
    @Mr. Fox this is the Linux subforum, so msconfig isn't applicable :p

    @Kyle maybe there is a polling setting related to power management that makes your mouse more sensitive on AC power. Are you running laptop mode tools or TLP? Or it could be that your touchpad needs to be cleaned, or that it is just overly sensitive in general. There are a lot of possibilities. :-/
     
    hmscott and Mr. Fox like this.
  7. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    28,794
    Messages:
    35,075
    Likes Received:
    55,658
    Trophy Points:
    931
    LOL, sorry for my lack of observation, bro. I didn't notice that. Ha! :vbbiggrin:

    Have a nice weekend.
     
    hmscott likes this.

Share This Page