Slower shutdowns in Windows 10 after fall 2017 update

Discussion in 'Windows OS and Software' started by hatcher, Jan 9, 2018.

  1. hatcher

    hatcher Notebook Consultant

    Reputations:
    24
    Messages:
    214
    Likes Received:
    5
    Trophy Points:
    31
    Just as the title states I am experiencing slower shutdowns after the fall 2017 update. My shutdowns used to be nearly instantaneous, less than one second, after the fall 2017 update shutdowns now take upwards of 15 seconds.

    Anyone else experiencing this? if so, is there any fix? or is this the new normal? at least until the next update. Thanks.
     
  2. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    16,599
    Messages:
    18,486
    Likes Received:
    26,035
    Trophy Points:
    931
    1) Open Notepad and copy/paste the following text in it:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
    
    "WaitToKillServiceTimeout"="5000"
    Now save that file and name it Decrease Shutdown Time.reg (not .txt)

    Now double click on that file to merge it with your registry and try.

    2) If that didn't help much, then try to disable Fast Startup in Windows under Control Panel > Power Options > Choose what the power button does (from the left pane) > then click Change settings that are currently unavailable to unlock the options below

    Now uncheck the box which says Turn on fast startup (recommended)

    You see, with Windows 8 and Windows 10, when you shutdown, it's not a full shutdown. It's part shutdown and part hibernation as in, Windows stores the currently loaded drivers and services for a supposedly faster startup. The caveat is now your shutdown will take much longer as the system state has to be saved before it fully shuts down and it doesn't really speed up the startup by a significant amount that's worth keeping this option on.

    If you did decide to go with option 2, to save some space on your Hard Drive, you can completely disable the Hibernation file and save up a large amount of space.

    To do this, just type powercfg -h off in an elevated command prompt and notice how much space you have more now.
     
    Vasudev and KY_BULLET like this.
  3. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    507
    Messages:
    3,196
    Likes Received:
    384
    Trophy Points:
    151
    If you have a HDD or age of the drive could also lead to the lapse. And since no one here has history of before or after this is mostly all hearsay right now. There are a mirard of hardware and software setups that could lead Windows seem slower but could be that it was the same before and one is assuming but since there isn't a way to test it then no one here can really know what is happening.
     
  4. macmyc

    macmyc Notebook Consultant

    Reputations:
    93
    Messages:
    294
    Likes Received:
    226
    Trophy Points:
    56
    I have noticed at least a 5 to 10 seconds delay on my machine aswell after the update. Hibernation and other windows crap is disabled yet my system is slower at turning off than it was before the update. It's not a big deal for me but i understand your point, i would like to know why it's slow aswell.
     
  5. hatcher

    hatcher Notebook Consultant

    Reputations:
    24
    Messages:
    214
    Likes Received:
    5
    Trophy Points:
    31
    It's not a big deal for me either, more so just curiosity as to why the slow down. I too have Hibernation disabled and have turned off Fast Startup, neither had much effect, if any at all.

    After researching on the web this appears to be a very common issue, but one with very few answers. Post #5 in the following link is the best answer I've found to date...https://www.tenforums.com/general-s...pdate-shutting-down-significantly-slower.html
     
    Vasudev likes this.
  6. macmyc

    macmyc Notebook Consultant

    Reputations:
    93
    Messages:
    294
    Likes Received:
    226
    Trophy Points:
    56
    So it's that feature kicking in at each shutdown? I wish i could disable it, guess ALT + F4 will do lol.
     
    Vasudev likes this.
  7. hatcher

    hatcher Notebook Consultant

    Reputations:
    24
    Messages:
    214
    Likes Received:
    5
    Trophy Points:
    31
    Yep! that's what's kicking in at every shutdown and slowing it down. ALT + F4 is certainly one work around, there are other "fixes" available if you follow the links within the link. Personally speaking I just live with it, now if it was slowing down the startup time I would have an issue with it. lol
     
    macmyc likes this.
  8. TreeTops Ranch

    TreeTops Ranch Notebook Deity

    Reputations:
    285
    Messages:
    821
    Likes Received:
    75
    Trophy Points:
    41
    Interesting. On my Win 7 it always takes many seconds to shut down. Sometimes half a minute or so.
    I just thought it was creating a restore point.
     
  9. Papusan

    Papusan JOKEBOOKS = That sucks! Dont wast your $ on FILTHY

    Reputations:
    16,404
    Messages:
    20,169
    Likes Received:
    31,840
    Trophy Points:
    931
Loading...
Similar Threads - Slower shutdowns Windows
  1. JAnguita
    Replies:
    11
    Views:
    869

Share This Page