skype makes my computer really slow - need help!

Discussion in 'Windows OS and Software' started by canonyau, Mar 23, 2006.

Thread Status:
Not open for further replies.
  1. canonyau

    canonyau Notebook Consultant

    Reputations:
    5
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    30
    Hey, can anyone help me? I recently downloaded skype 2.0 and it freezes my laptop when I start it up. I currenly have a Dell 510M with 1.3GHz celeron M and 640MB of RAM. I have used skype successfully before on this laptop, don't know what's gone wrong.

    When I eventually get it to work, it is still very slow and unresponsive. I have gotten through to someone on a call once, but their voice was slow and distorted. It uses 100% of my CPU when I run it too.

    Any help would be great, skype is a programme I use regularly.

    I've already tried uninstalling and reinstalling it.

    Thanks
     
  2. vassil_98

    vassil_98 Notebook Deity

    Reputations:
    133
    Messages:
    1,524
    Likes Received:
    0
    Trophy Points:
    55
    go the previous version, which you have used successfully. Skype is a very demanding messanger and 1.3 Celeron may not be enough.
     
  3. canonyau

    canonyau Notebook Consultant

    Reputations:
    5
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    30
    thanks vassil. Does anyone know where i can get the previous version of skype from?
     
  4. Jason

    Jason Overclocker NBR Reviewer

    Reputations:
    906
    Messages:
    5,054
    Likes Received:
    0
    Trophy Points:
    205
    Skype should have no problem running on a Celeron 1.3. The System requirements from skype.com: "We also recommend that you have at least 400 MHz processor, 128 MB RAM and 15 MB free disk space on your hard drive." I don't know what to tell you about it freezing. It should be fine. You could try running a previous version. Perhaps you could Google an older version of skype that you could download.

    Also be sure to check for spyware and adaware. This could be slowing down your system.

    You could also try disableing it to start up when windows boots. Go to Start -> RUN -> type "msconfig" -> OK -> Startup -> then uncheck "Skype". Then after your system boots up you can try and run skype.

    Good luck! :)

    -Jason
     
  5. vassil_98

    vassil_98 Notebook Deity

    Reputations:
    133
    Messages:
    1,524
    Likes Received:
    0
    Trophy Points:
    55
Similar Threads: skype makes
Forum Title Date
Windows OS and Software Skype v7.4.32.102 Apr 23, 2015
Windows OS and Software skype with windows 8.1 Oct 12, 2014
Windows OS and Software skype log in problem May 22, 2014
Windows OS and Software Can't access internet explorer but Skype works Dec 8, 2012
Windows OS and Software Skype raises price on (some) subscriptions by 60%! Nov 27, 2012

Thread Status:
Not open for further replies.

Share This Page