SetFSB Game Timing Problem? (G60JX)

Discussion in 'ASUS Gaming Notebook Forum' started by Disgustipated, Apr 8, 2011.

Thread Status:
Not open for further replies.
  1. Disgustipated

    Disgustipated Notebook Consultant

    Reputations:
    74
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    30
    Ok, so one of those theories is correct then. Have you tested it with SetFSB to see where the threshold lies?
     
  2. Keith

    Keith Notebook Deity

    Reputations:
    889
    Messages:
    778
    Likes Received:
    216
    Trophy Points:
    56
    Not officially. :D

    But I can tell you it seems like once you go beyond where Power 4 Gear overclocks to, that's when things seem to start getting ot of whack.
     
  3. Disgustipated

    Disgustipated Notebook Consultant

    Reputations:
    74
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    30
    Hmm ok. And perhaps going past Power4Gear's 141 FSB doesn't give huge gains in games. I know it gives huge gains in benchmarks and everyday computing, though.
     
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,088
    Messages:
    5,848
    Likes Received:
    4,987
    Trophy Points:
    431
    The problem you guys are running into is a new Windows 7 "feature".

    To accurately measure time in a Windows PC, software uses the QueryPerformanceCounter function. Many applications, especially games, depend on this Windows function to accurately calculate FPS as well as for many other timing purposes in game including sound.

    The problem is that for many computers, this function in Windows 7 is now based on the clock speed of the processor. If you overclock in the bios and then boot up, this timer is calibrated and will work 100% correctly. If you use SetFSB or a similar program and you change the bus speed from within Windows, you have now just screwed up this very important timing mechanism. The number of applications that can choke after you do this is surprising, especially games.

    I wrote a program called WinTimerTester to test for this problem.

    WinTimerTester 1.1
    http://www.mediafire.com/?xzo9n84d8lze9nb
    http://www.sendspace.com/file/xadvhe

    What it does is it runs two different clocks in your CPU at the same time and compares them to make sure they are both running at the same speed. It compares the Windows GetTickCount function to the QueryPerformanceCounter function and within approximately 60 to 100 seconds, these two timers should be running at a perfect 1.0000 : 1 ratio.

    If you overclock your CPU with SetFSB and WinTimerTester reports that these timers are not running at a 1.0000 : 1 ratio, that shows that you have this bug and you have also overclocked this important timer within your computer which can screw up a variety of programs in a variety of ways.

    Luckily there is a solution to this Windows bug. Microsoft actually considers this a feature but for anyone that uses SetFSB on a regular basis, it's a big bug.

    To fix this problem, open up a command window and type in this:

    bcdedit /set useplatformclock true

    You will have to exit the command window and reboot before this setting can take affect. What this does is it changes Windows so the QueryPerformanceCounter function will be based on a fixed counter that is not influenced by SetFSB. That one line of code should correct this problem and your games will run fine when using SetFSB.

    If you ever want to go back to the original buggered up timer that Windows uses then open up a command window and type in this.

    bcdedit /deletevalue useplatformclock

    Once again, reboot and things will be back to the default Windows 7 timer. These two images should show you when your internal timers are broken and what WinTimerTester will report when your internal timer is fixed. This only applies to Windows 7. There is a similar fix for Windows XP so PM me if you need it.

    http://img202.imageshack.us/img202/3778/timerbroken.png

    http://img96.imageshack.us/img96/8417/timerfix.png

    Let me know if this finally solves your problem. My friend some_one over on XtremeSystems told me about this little trick.

    Disgustipated: On a different note. It would be a good idea to run ThrottleStop and increase your TDP/TDC settings to ensure that you get full turbo boost when you are overclocking with SetFSB. If you don't increase TDP/TDC then your bus speed can go up but your multiplier might go down when fully loaded so you won't get the full benefit of your overclock. Send me a PM if you need to know more about how to properly test for full turbo boost at full load.

    One last thing. Many 3D gaming benchmarks don't correct for this problem so you can't trust their results when using SetFSB if your laptop has this timing issue. I believe the 3DMark series corrects for this problem and can be trusted.
     
    Mr. Fox, duttyend and t456 like this.
  5. Disgustipated

    Disgustipated Notebook Consultant

    Reputations:
    74
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    30
    WOW. I've been using Throttle Stop and it's amazing, but to have the creator come and totally figure out what's causing my problem with a *different* program AND offer a solution - just wow. :eek:

    THANK YOU, Unclewebb. I'm going to test and see if indeed this does fix the timing program, if so, SetFSB overclocking for games is a GO!

    I'll be sending you a PM to learn about testing for full turbo boost.

    Again, thank you. You might have just solved a game timing issue for not just G60JX owners, but for all gaming laptop owners limited to SetFSB. :D

    Update! Just finished testing and changing settings - Unclewebb's done it! Works perfectly - no more timing issues, the games play perfectly but with a nice boost in performance thanks to my 3.1 Ghz overclock (stock turbo boost only goes to 2.5 ghz).

    Stable so far in small FFT mode with Prime95 @ 165 mhz for the FSB. RAM is @ 660 Mhz.
     
  6. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,088
    Messages:
    5,848
    Likes Received:
    4,987
    Trophy Points:
    431
    You're welcome Disgustipated. I guess you've got nothing to be disgusted about now. :)
    You'll be too busy checking out all the games that were screwed up before.

    On my desktop computer, this was a bug in Windows XP, Microsoft fixed it in Vista and then reintroduced it as a new feature in Windows 7 so they could be ACPI compliant.

    IBM and other manufacturers know about this problem so if anyone is afraid to try this solution, you can read all about it here.

    http://www-947.ibm.com/support/entry/portal/docdisplay?brand=5000008&lndocid=MIGR-5084072

    Copy and Paste this info to other forums so users can find out about this easy and permanent fix.

    For Windows XP, you need to add this to the boot.ini file.

    /usepmtimer
     
    duttyend likes this.
  7. Disgustipated

    Disgustipated Notebook Consultant

    Reputations:
    74
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    30
    Thanks UncleWebb. I posted this on NeoGAF and in the Gaming section of NotebookReview. This is going to help a lot of people.
     
  8. Boost_

    Boost_ Notebook Consultant

    Reputations:
    31
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    30
    Yeah, thanks! This worked for me as well. My mouse doesn't slow down any more after SetFSB is activated. Performance has increased slightly too.

    One thing though, when I run your program after the "fix" to check the ratios, I always get .998x:1 wether I use setfsb or not. This is better than the 1.05xx:1 I would get prior to the fix when using setfsb. Should it be a perfect 1.0000:1?
     
  9. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,088
    Messages:
    5,848
    Likes Received:
    4,987
    Trophy Points:
    431
    When you boot up, before you use SetFSB, what does WinTimerTester say after you let it run for about 100 seconds? After that amount of time, it's usually a perfect 1.0000 : 1 ratio for me.

    A tiny difference like 0.998x means there is still some error in your high performance timer but at least that shouldn't cause any noticeable problems in games.

    The problem might not be noticeable after a slight bus speed adjustment but the problem is still there. Try adjusting the base clock from 133 MHz to 135 MHz and WinTimerTester should show you that you are screwing up your internal clocks.
     
    duttyend likes this.
  10. Keith

    Keith Notebook Deity

    Reputations:
    889
    Messages:
    778
    Likes Received:
    216
    Trophy Points:
    56
    So in other words even the built in overclock apps from Asus and Msi for example will have this bug too, but not be as obvious. Thank you sir. :)
     
Loading...
Thread Status:
Not open for further replies.

Share This Page