Secondary SSHD keeps cycling on/off constantly as soon as screen turns off while on battery only?

Discussion in 'Hardware Components and Aftermarket Upgrades' started by GreatD, Aug 1, 2018.

Thread Status:
Not open for further replies.
  1. GreatD

    GreatD Notebook Consultant

    Reputations:
    64
    Messages:
    279
    Likes Received:
    103
    Trophy Points:
    56
    Good day all. Please help,
    I have a bit of a dilemma and it might be a quick fix but I'm not sure. My Secondary HDD (not the C drive SSD) spins off and on continuously as soon as the screen backlight turns off and the laptop is still on but it only does it on battery and not when the charger is plugged in. It's weird though as soon as I change my power option to Performance option in Win 10 power options it goesaway and the drive stays on and doesnt spin off but I cant leave it on performance mode as my CPU stays boosted to max and that will eat my battery faster.

    What I could do and try to stop the HDD from spinning off and on continuously in battery mode on Balanced and Power saver win 10 power settings. On AC mode I dont have a problem but on battery I do. I have disabled APM and I tried to enable it back to factory but still the same issue.

    Anyone know what it could be causing this issue that's only when I have the AC unplugged. Thanks all, I really appreciate any assistance. :)
     
  2. michealscott

    michealscott Notebook Consultant

    Reputations:
    10
    Messages:
    100
    Likes Received:
    48
    Trophy Points:
    41
    Turn off Windows power management or let windows turn off this device, something along those lines for the drive in Device manager.

    Sent from my SM-G925F using Tapatalk
     
  3. kingofswag187

    kingofswag187 Notebook Deity

    Reputations:
    303
    Messages:
    1,817
    Likes Received:
    719
    Trophy Points:
    131
    Confusion in power management, turn off HDD spin down in power
     
  4. michealscott

    michealscott Notebook Consultant

    Reputations:
    10
    Messages:
    100
    Likes Received:
    48
    Trophy Points:
    41
    Yup, forgot that. :) It should be in power plan settings.

    Sent from my SM-G925F using Tapatalk
     
    kingofswag187 likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page