Screen flickering problem with Clevo P950HP6

Discussion in 'Sager and Clevo' started by Shadow Cloud, Jan 11, 2019.

  1. Shadow Cloud

    Shadow Cloud Notebook Consultant

    Reputations:
    0
    Messages:
    150
    Likes Received:
    7
    Trophy Points:
    31
    Oh boy I wonder if I mess up something because it feels like the fan(near the display cable) is running more constant now. This piece(circled in red) here is now slightly lifted up when I was re-seating the display cable. Could it be due to that?
     

    Attached Files:

  2. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,887
    Messages:
    49,897
    Likes Received:
    13,924
    Trophy Points:
    931
    Those are the CPU cooling fins. If the heatsink is not sitting right then the CPU could be making poor contact to the heatsink. You could check by removing it and taking a picture of the pattern on the CPU and contact point on the heatsink left by the past.
     
  3. Shadow Cloud

    Shadow Cloud Notebook Consultant

    Reputations:
    0
    Messages:
    150
    Likes Received:
    7
    Trophy Points:
    31
    I guess the issue I have is how do I put the heatsink and CPU cooling fins back to their original positions since they seem to be permanently lifted?
     
  4. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,887
    Messages:
    49,897
    Likes Received:
    13,924
    Trophy Points:
    931
    It would suggest the heatpipes are bent or the thermal pads are not sitting right.
     
  5. Shadow Cloud

    Shadow Cloud Notebook Consultant

    Reputations:
    0
    Messages:
    150
    Likes Received:
    7
    Trophy Points:
    31
    Is there any of kind of paste to hold it back in place? Like should I be using IC Diamond? When I was putting in the new cable. I also took out the fan to clean it a bit and wonder if it's because of that I have this loud fan problem. I've attached pictures of my new issue.
    http://imgur.com/gallery/RZYTZ0X
     
    Last edited: Feb 11, 2019
  6. KevC123

    KevC123 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    5
    Hi, I am facing the same problem and I would like to know how did you open the back and what exact cable did you reseat to fix the problem. Thank you in advance!
     
  7. Shadow Cloud

    Shadow Cloud Notebook Consultant

    Reputations:
    0
    Messages:
    150
    Likes Received:
    7
    Trophy Points:
    31
  8. KevC123

    KevC123 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    5
    I will try reseating the cable first, to see if the problem can be solved this way. Thank you!
     
Loading...

Share This Page