Replace Quadro K5100m with GTX 970M Zbook G1

Discussion in 'Hardware Components and Aftermarket Upgrades' started by Koniptn, Nov 27, 2018.

  1. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    Hi,

    I recently acquired a HP Zbook 17 G1 F7W21UT (yes, the Dreamcolor with the K5100m). I have updated to the latest HP bios available for it, L70 v 1.44 8/8/2018

    The first 970m I bought ended up being a busted card. That has since been replaced.

    I bought another GPU, this time reportedly from a Clevo laptop.

    The video card does work, but with a caveat. It does not power the backlight of the laptop panel. I can use external monitors without an issue for now however. I have the old Chinese iCAFE drivers from nvidia's website here: https://www.nvidia.cn/content/Drive...t-international-whql.exe&lang=cn&type=GeForce


    I suspect this is a dreamcolor thing, but I am not entirely sure. I can actually get into the OS, and I can see the screen is getting images.

    My first goal is to flash some kind of vBIOS onto the card that identifies it as HP. As of now, I have the microsoft VGA driver powering it just fine. Afterwards, I will install the chinese iCAFE drivers, and see if those work with the card.


    More to come...
     
    Last edited: Dec 6, 2018
  2. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    reserved
     
    Last edited: Dec 6, 2018
  3. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    reserved
     
    Last edited: Dec 6, 2018
  4. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    So I discovered that running the system in Legacy mode actually works. The card displays and powers the backlight of my monitor.

    My laptop, however, is currently Windows 10, and unfortunately, is in full UEFI mode (GPT formatted disk). As soon as the boot loader moves over to Windows, I lose all visuals on the monitor and am forced to plug into an external for display.

    I do not know why this card doesn't work in UEFI. According to the sys info screen in the UEFI, the vBIOS revision is "nvidia gpu uefi driver (84.04.22.00.11)"

    When I switch to UEFI/Hybrid mode, I get simply "nvidia 09/05/14"

    So vBIOS is definitely the issue here, but I cannot seem to find a compatible vBIOS for this card. I've asked a member on this forum to see if he still has his old vBIOS that he got from prema. Hopefully he does, because I've got nothing else left to try here, except reformatting my OS to be non UEFI mode.

    I kind of expected to have problems with legacy modes, not UEFI modes.
     
  5. truhlik

    truhlik Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Whoa, so you are saying here, that the 17 G1 actually DOES work with something different than K3100/4100/5100? Was reading everywhere else on the internet, that those G1/G2s are incompatible with practically everything. And now -bang- you say opposite!

    How is the behaviour during POST? Can you see the HP logo after powering-on? And how about BIOS? Backlight working normally?

    I must say your post is quite encouraging, cos` I have here a brand new 17 G2 components waiting to be assembled together (yes, I am building my next laptop on my own, per-partes) and I want to play a little bit with Maxwell-gen cards. Beside the certified K5100M, I got an original HP M3000M from ebay for ~150€ just to test it and I start to be a little bit more optimistic... Btw, it will be Dreamcolor as well :p
     
  6. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    No, the issue is that I'm saying it doesn't work.

    The card only works on a zbook 17 g1 with a dreamcolor screen when:

    The BIOS and OS are in full Legacy mode. UEFI only seems to send images to the screen, but will not power the backlight. In Legacy mode, the system will do both, while in the OS and in the BIOS.

    The OS base driver is installed. Actual nVidia drivers of all sorts of revisions instantly make the screen go black. The screen isn't even seen by the OS after nVidia drivers are installed. No idea how to fix that.

    So basically, if you want a 970m with zero output to a screen with any decent drivers, go for it.

    I'm trying to contact the greats, like @Prema to see if they have a fix. No responses thus far.

    @TenGauge managed to get his 8770w to run a 980m with a dreamcolor screen. Trying to see if he still has his drivers
     
  7. sicily428

    sicily428 Donuts!! :)

    Reputations:
    780
    Messages:
    3,579
    Likes Received:
    1,946
    Trophy Points:
    231
    what's your panel exactly? is there optimus in your system?
     
  8. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    @sicily428

    It is one of those DreamColor LG panels, specifically the LP173WF3-SLB4

    As for Optimus, I don't think so. I don't recall seeing that option anywhere.

    The SKU is up top, F7W21UT. I couldn't find a mention of Optimus. I'm not sure it came with the G1 zbooks at all.
     
    Last edited: Dec 13, 2018
  9. Koniptn

    Koniptn Notebook Enthusiast

    Reputations:
    0
    Messages:
    41
    Likes Received:
    15
    Trophy Points:
    16
    Oh, I'm looking over a review...

    It appears it might actually have Optimus. Strange, I never saw an option for it after getting some drivers installed, but maybe I missed it.

    Do you know if Optimus would mess with stuff?

    I may have to try again. I currently have a Win10 drive non UEFI I could slap back into the system.

    What's bugging me though, is that in the BIOS (latest revision, mind, 8/8/2018) there is no option for going between dGPU and iGPU...I don't even think this thing has an iGPU, so I dunno why Optimus would be a reported option....
     
    Last edited: Dec 13, 2018
  10. truhlik

    truhlik Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Yes, I forgot to say that i don`t care about UEFI mode (for now) and want to stay in Legacy. Windows 7 is my choice...

    Optimus was present in the G1, but not supported in combination with Dreamcolor screen. Likely the DC screen is the reason why you cannot find any clue of it anywhere in the system...
     
Loading...

Share This Page