Repair not working Dell Alienware m17x R5

Discussion in 'Alienware 17 and M17x' started by Hellsik, Apr 23, 2019.

  1. Hellsik

    Hellsik Notebook Guru

    Reputations:
    12
    Messages:
    74
    Likes Received:
    37
    Trophy Points:
    26
    Hello I would like introduce my new project. Maybe some parts help some members :)
    I bought not working Dell Alienware m17x R5 (Ranger) on ebay auction for 279 euro.

    s-l1600.jpg s-l1600 (1).jpg s-l1600 (2).jpg s-l1600 (3).jpg

    Specifications:

    Intel Core i7-4800mq
    Nvidia GTX 780m
    FullHD LCD 120Hz
    16 GB DDR3L
    80 GB SSD

    First step:
    When notebook arrived I was very exited where is fault and will it works. With notebook I also recieved 240W poweb brick, that has got not functional led indication. I test it with another notebook and works normally.

    Second step:
    Well after I connect adapter to notebook it immediately power of and conector on notebook smells realy bad. I take power cable off and see what is wrong. Cable has wire without procection. That cause short curcit with chassis. Then I compare it with m6600 and m4800 power cable, but they do not match. I straight power cable and tape it. Than connect it again to mathebord and plug in ac adaper, push power button. After few seconds it power up :D

    Third step:
    So notebook is working, booting to windows, but overheat. I repaste CPU and GPU clear both fans. When I cleaned CPU fan rotor has broke of stator and I must use glue for temporarily solution. Well I start stress test on CPU with OCCT and after few second it crash with error. I test it more that five time with same result. When I use same program to stress GPU I got brown screen, red screen and crashing driver. At this point i thought that motherboard and gpu are dead. So I changed processor take out gpu, see what is wrong, and put it in. After more test it was same result. Then I take off memory out, put in abother DDR3L and rust tests. It work normal, but when I restart notebook posted bluescreen. Than I put old memory modules back and run test again. After this no more problems with crashing stress test with OCCT or IBT. Next was diagnose GPU, I lower core and memory clock lower and test works for more than 2-3 mins and again crash. Well I install clean Windows 10 with drivers on chipset and graphics card. This ends with same result. After this I use older GPU driver from 2015 and run test. The GPU and CPU is working in stress test for more than 2 hours without crash.

    Things for repair:

    Because power cable working, but it is not safe a ordered original used one. I do not recomended buy china copy from aliexpress.
    Power cable

    Next part that is broken is CPU fan. I searched on forum which model to buy. Most members of forum use fan from Alienware 14 R2 with 10,5-11 CFM and modify it. I found more than four diffrend models. But best for testing I ordered china "copy" with 10,6 CFM which do not need modification.
    CPU "turbo" fan 10,5 CFM

    Dell power brick has not working led blue light and look connector looks terible. On ebay I cannot found right cable for 240W. On aliexpress is one seller that gas got right type. I will order it and repair my two adapter.
    Dell 240W power brick cable

    I also buy 330W poer brick in my country, but when I plug it in to notebook it cas detected as "unknown". I test it in four notebook with same result. Than I search some solution for repair this adapter. I found only one solution which is replace original ID chip with emulated one. I do not have stuff for programming, but on ebay I found seller that has got "plug-n-play" solution, that should works. I will order this emulator in next week.
    Dell 330W power brick repair ID chip (DS2501)
     
    Last edited: Apr 23, 2019
  2. kaibsora

    kaibsora Notebook Consultant

    Reputations:
    10
    Messages:
    131
    Likes Received:
    22
    Trophy Points:
    31
    I have the 330w adapter and its detected properly, are you sure that that adapter isnt fake?

    Sent from my SM-N950U1 using Tapatalk
     
  3. Hellsik

    Hellsik Notebook Guru

    Reputations:
    12
    Messages:
    74
    Likes Received:
    37
    Trophy Points:
    26
    I opened it buy it looks like original. More member it has the same problem with 240W adapters. When I repair it and test I will post more info. New adapter from china is more than 80-100 dolars. You realy do not know which is original.

    Build quality it look same as original 240W

    IMG_20190422_154522.jpg IMG_20190422_153836.jpg IMG_20190422_154447.jpg
     
  4. kaibsora

    kaibsora Notebook Consultant

    Reputations:
    10
    Messages:
    131
    Likes Received:
    22
    Trophy Points:
    31
    I dont think I bought mine from China, but I got it on Ebay used for 50 bucks.

    Sent from my SM-N950U1 using Tapatalk
     
Loading...

Share This Page