[Release] Improved M18x R2 Maxwell Legacy BIOS

Discussion in 'Alienware 18 and M18x' started by Raidriar, Jan 16, 2017.

  1. ssj92

    ssj92 Neutron Star

    Reputations:
    2,328
    Messages:
    4,277
    Likes Received:
    5,360
    Trophy Points:
    581
    If you are already running A11 unlocked, you can flash the BIOS over the current one
     
  2. Maxware79

    Maxware79 Notebook Deity

    Reputations:
    141
    Messages:
    918
    Likes Received:
    616
    Trophy Points:
    106
    Thanks again. I'll try to have a go tonight.

    All flashed without an issue. It feels great not to have the Boot Agent come up every time. First boot did seem slower than before, even with the Atheros screen, but hopefully it was just getting settled.
     
    Last edited by a moderator: Aug 15, 2019
  3. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,565
    Messages:
    5,604
    Likes Received:
    4,034
    Trophy Points:
    431
    Yes
     
  4. Johndill

    Johndill Notebook Consultant

    Reputations:
    20
    Messages:
    173
    Likes Received:
    96
    Trophy Points:
    41
    The UEFI boot image is not the white Alienware name, are you able to add back the correct logo? :)
     

    Attached Files:

    Last edited: Aug 28, 2019
  5. Smilz

    Smilz Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hello,
    i have an Alienware M18x R2
    I have upgraded grafigcard to GTX 980m.

    Without bios update, i got 8 beeps and screen do not show anything.
    So, also not possible to go into bios by F2

    I have removed grafigcard - then it was possible to go into bios.
    I have flashed bios: M18x_R2_A11_Maxwell_Legacy.
    I have swiched of legacy.
    Then put in grafigcard GTX 980m (one piece, no SLI)
    Result:
    Bios shows chipset grafigcard ivy bridge, but no additional grafigcard
    Installed Windows 10, device manager shows unknown device, but no gtx card.
    Try to install nvidia driver, but failed, because it do not find any grafig card.
    On board grafigcard shows error.

    After reboot, gtx980m was present and works without problems,
    also optimus, so this is working.

    But
    not working is: go to raid controller during boot process
    (set bios to raid, installed Windows 10)
    No key is working: ctrl + i, also shift ctrl + i and a lot of other key combination.

    - i have installed two SSDs and two harddisks

    My question: is this a problem with this bios or what can i do.
     
  6. Homer S

    Homer S Notebook Consultant

    Reputations:
    11
    Messages:
    299
    Likes Received:
    82
    Trophy Points:
    41
    Assuming the 980m is in the primary "left" slot. This is the one seen in the image here. When you boot into BIOS, what is the graphics selection? I think it should be Auto or PEG, not iGFX or SG. Boot into Windows and verify that Device Manager sees the 980m. Don't forget to install with unsigned drivers.

    Homer
     
  7. godlikemouse

    godlikemouse Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    2
    Trophy Points:
    6
    Hi everyone, quick question. I'm running dual GTX 980m in SLI on Windows 10 and I've always had throttling and other issues. Have you found the performance to be better in Windows 7 legacy versus Windows 10? I'm still running stock vBIOS on the GPUs but running Swick BIOS on the motherboard. Thanks.
     
  8. Homer S

    Homer S Notebook Consultant

    Reputations:
    11
    Messages:
    299
    Likes Received:
    82
    Trophy Points:
    41
    I think 7 technically has less overhead, but I didn't see any real difference going from 7 to 10, other than 10 is more "modern" feeling. Throttling is a way of life now that NVidia crippled the drivers trying to force us all to upgrade. Also, unless you have a double power supply or a single big one, the 980Ms will try to pull more than your single PS is capable of.

    Homer
     
  9. godlikemouse

    godlikemouse Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    2
    Trophy Points:
    6
    Hi Homer,

    Thanks for the reply. Yeah, I ended up trying both yesterday. From what I can tell there's a slight performance gain when running under Windows 10 but not really by much at all. I also ordered and have been trying to use the Eurocom 780w power supply to help what I thought were power throttling issues but I can't for the life of me seem to get the m18x R2 to use more than 300w of power. It seems to just choke back and not accept anything near to what the power supply can provide.
     
  10. Johndill

    Johndill Notebook Consultant

    Reputations:
    20
    Messages:
    173
    Likes Received:
    96
    Trophy Points:
    41
    How can I fix this, the UEFI boot image is not the proper white Alienware name logo on this A11 unlocked bios, does anyone else have this? :)
     

    Attached Files:

Loading...
Similar Threads - [Release] Improved M18x
  1. ibmthink
    Replies:
    8
    Views:
    2,277

Share This Page