[Release] Improved M18x R2 Maxwell Legacy BIOS

Discussion in 'Alienware 18 and M18x' started by Raidriar, Jan 16, 2017.

  1. vaspup88

    vaspup88 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Expected version 2.0?
     
  2. AaronSV

    AaronSV Notebook Geek

    Reputations:
    2
    Messages:
    93
    Likes Received:
    15
    Trophy Points:
    16
    Hey I wonder if someone could help me, I seam to be having the same problem as someone else had not long ago.

    Just put in a 980m into my M18xR2 running A11 unlocked with the horrible picture at boot :( .
    I'm using windows 7 and I can only get my laptop to boot If I have the system set to SG mode, also works on just the Intel graphics to. If I try and set it to PEG I get a black screen and 8 beeps all the time, to which I have to reset the BIOS back to SG.

    I have not flashed any Vbios yet as I have no idea if what I have is a G-sync model or not, and I would rather not brick the card by flashing randomly.
    Ran the metro last light redux benchmark and got a steady 60FPS most of the time, so don't think it is the card which is the problem.
    Currently running 980m driver version 378.49 from Eurocom and no issues there, only problem is my device manager is having issues to.

    Any ideas ? any help would be apreciated as I have 0% experience at this kind of thing.
     

    Attached Files:

    • gpu.png
      gpu.png
      File size:
      161.5 KB
      Views:
      119
  3. AaronSV

    AaronSV Notebook Geek

    Reputations:
    2
    Messages:
    93
    Likes Received:
    15
    Trophy Points:
    16
    Just wanted to add that I have just flashed your improved version of the A11 Bios...thanks you so much for making the bootup look stock. I was rather annoyed how they changed it, now only if I could get my 980m to work this easily.
     
  4. jerryzago

    jerryzago Notebook Consultant

    Reputations:
    41
    Messages:
    202
    Likes Received:
    50
    Trophy Points:
    41
    As my memory helps me, devce ID for a non g-sync 980m is 13D7. Seen a different device ID, you might have a g-sync model.

    If other can chime in, I believe the gsync model, will not post in PEG mode.
     
  5. AaronSV

    AaronSV Notebook Geek

    Reputations:
    2
    Messages:
    93
    Likes Received:
    15
    Trophy Points:
    16
    You might be right, had a look and I think this is my card https://www.techpowerup.com/vgabios/177729/177729.
    If I am stuck with SG mode that's fine I guess as the 980m is running games properly. Only issue is the device manager missing a lot of stuff. Only paid £300 for the card and considering a 780m or 880m on E-bay are between £240-£360 I think its still a good buy.
     
  6. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,269
    Messages:
    4,989
    Likes Received:
    3,281
    Trophy Points:
    331
    i use slimdrivers to update all the drivers, except for AW command center and AW OSD which you have to get from Dell directly.

    as for your GPU, you got a weird one. 13d7 is the 980M non-gsync version, so you will probably be stuck using optimus. I would return this GPU and get a non-gsync version instead, PEG is much better to deal with than optimus.
     
  7. AaronSV

    AaronSV Notebook Geek

    Reputations:
    2
    Messages:
    93
    Likes Received:
    15
    Trophy Points:
    16
    I would return it if the other 980s on Ebay were not over £500 and from the US, import charges alone make it hard for me to justify the price.

    I can always wait and see if anything else comes along, my 675m SLI was dying so I didn't have the luxury of waiting. Plus my CPU was also on the fritz suffering from screen pull when in IGFX mode, Now I have a 3940mx and everything seam to be running ok..for now.
     
  8. AaronSV

    AaronSV Notebook Geek

    Reputations:
    2
    Messages:
    93
    Likes Received:
    15
    Trophy Points:
    16
    OMG I am such an idiot, device manager is perfectly fine now -.- I completely forgot that the Chipset version I installed was before the 3940mx was out. now I updated all my drivers everything is registered properly...wow so dumb.
     
  9. aaronne

    aaronne Notebook Evangelist

    Reputations:
    316
    Messages:
    450
    Likes Received:
    492
    Trophy Points:
    76

    Contact Klem over T|I forum and gave him your gpu's id for your ad personam bios ^_^
     
  10. AaronSV

    AaronSV Notebook Geek

    Reputations:
    2
    Messages:
    93
    Likes Received:
    15
    Trophy Points:
    16
    Done and done, now I play the waiting game...again. At least I currently have a working and better R2 than I started with.
     
Loading...
Similar Threads - [Release] Improved M18x
  1. Raidriar
    Replies:
    9
    Views:
    988

Share This Page