[Release] Improved M18x R2 Maxwell Legacy BIOS

Discussion in 'Alienware 18 and M18x' started by Raidriar, Jan 16, 2017.

  1. anarky321

    anarky321 Notebook Deity

    Reputations:
    65
    Messages:
    1,181
    Likes Received:
    48
    Trophy Points:
    66
    i tried UEFI mode...and legacy too i think...im running win 8 UEFI right now so... and this card ran games 100% for months with zero issues before i flashed the new BIOS...its something simple im missing

    EDIT: im considering throwing in my 780m and seeing if it boots on PEG mode with this BIOS...because right now im sitting without a working GPU anyway and it sucks

    EDIT: i think im just going to flash A10 unlocked back on the system and call it a day at this point...i didn't really expect to encounter so many issues

    EDIT: what's really irritating is that i can view the card, in device manager, gpu-z, nvidia inspector and even BIOS but can't boot in PEG with it....weird
     
    Last edited: Apr 28, 2017
  2. anarky321

    anarky321 Notebook Deity

    Reputations:
    65
    Messages:
    1,181
    Likes Received:
    48
    Trophy Points:
    66
    so in the name of further testing i threw in my 780m and it booted right up in PEG mode....so that's nice but still doesn't get me any closer to answering the question of why my 980m isn't working so im just downgrading back to previous BIOS for now

    EDIT: well this is getting interesting...put the 980 back in and it booted up in PEG mode....im open to explanations on that one

    EDIT2: running in UEFI win 8.1 full PEG mode.....and i fixed this....just by taking it out and putting it back in? are you ****ing kidding me i just spent 2 days on this
     
    Last edited: Apr 28, 2017
  3. jerryzago

    jerryzago Notebook Consultant

    Reputations:
    41
    Messages:
    202
    Likes Received:
    49
    Trophy Points:
    41
    Seems your GPU fails to initialize during boot. You could try loading setup defaults from bios and then switching to PEG. In a12 official it worked for me in pure UEFI without problems.

    When I flashed swicks unlocked bios, I removed first and after the battery, the coin battery and pressed the power button for 10sec afterwards.

    I could sent you some photos of my settings, but there are so many there and I am running legacy mode.
     
  4. Raidriar

    Raidriar Notebook Prophet

    Reputations:
    1,133
    Messages:
    4,555
    Likes Received:
    2,880
    Trophy Points:
    231
    BIOS works fine, tested with Clevo and Dell 980Ms so something is wrong with the way you put the card in or the card itself.

    Gsync cards not supported in case that wasn't clear.
     
  5. anarky321

    anarky321 Notebook Deity

    Reputations:
    65
    Messages:
    1,181
    Likes Received:
    48
    Trophy Points:
    66
    its working fine now, taking it out and putting it back in solved the problem...don't ask me why its not like you can put it in wrong
     
    jerryzago likes this.
  6. Raidriar

    Raidriar Notebook Prophet

    Reputations:
    1,133
    Messages:
    4,555
    Likes Received:
    2,880
    Trophy Points:
    231
    maybe some debris preventing the pins for making proper contact.
     
  7. anarky321

    anarky321 Notebook Deity

    Reputations:
    65
    Messages:
    1,181
    Likes Received:
    48
    Trophy Points:
    66
    ehh honestly highly unlikely considering how many times i've taken these apart i usually always wipe the pins and blow out the socket before i insert its just on autopilot by now

    but either way its a happy ending i kept UEFI windows and have a cracked bios now....im happy
     
  8. MZWiZard

    MZWiZard Notebook Consultant

    Reputations:
    94
    Messages:
    178
    Likes Received:
    31
    Trophy Points:
    41
    Thanks for this bios to you all! :biggrin:
     
  9. maxslo

    maxslo undefined

    Reputations:
    232
    Messages:
    878
    Likes Received:
    221
    Trophy Points:
    56
    Installed it myself aswell, as preparation for 970M upgrade, the upgrade went without a hiccup :D thanks @Raidriar
     
  10. vaspup88

    vaspup88 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    need to reinstall the system?
     

Share This Page