[Release] Improved M18x R2 Maxwell Legacy BIOS

Discussion in 'Alienware 18 and M18x' started by Raidriar, Jan 16, 2017.

  1. JTech80

    JTech80 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    5
    I got it to work. Had to use Rufus to reformat the usb. I had assumed that even though is was a FAT32 format to begin with that it would work, guess I was wrong. Now on with the tear down to see if it recognizes the new card. Thanks!
     
  2. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,585
    Messages:
    5,623
    Likes Received:
    4,067
    Trophy Points:
    431
    You must make a UEFI compatible DOS USB, or remote the 980M, set mode to legacy BIOS (disable UEFI), then flash.


    Edit: never mind I see you got it to work. Good luck
     
  3. JTech80

    JTech80 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    5
    Yep, I just booted into Windows 10 with success! Thanks again for the bios!
     
  4. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,585
    Messages:
    5,623
    Likes Received:
    4,067
    Trophy Points:
    431
    My pleasure to give back to the community that helped me learn when I was much younger.
     
  5. JTech80

    JTech80 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    5
    Well dang. Apparently windows 10 isn’t compatible with the 980m. Guess I’ll have to switch back to the 660 and get a new computer. :(
     
  6. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,585
    Messages:
    5,623
    Likes Received:
    4,067
    Trophy Points:
    431
    ??? Of course it is. You must mod INF from the nvidia installer to recognize the 980M.
     
    M18x-oldie likes this.
  7. JTech80

    JTech80 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    5
    I tried that. The whole international folder keeps disappearing from the files. I was able to grab it during the install and modify it, but when I run it again it just overwrites it. I’m done with this thing, I already have a new computer on the way.
     
  8. Azther

    Azther Notebook Consultant

    Reputations:
    10
    Messages:
    114
    Likes Received:
    63
    Trophy Points:
    41
    download the driver installer, extract with 7-zip to a custom location, then modify the nvdmi file inside of the display.driver folder. restart and disable driver enforcement, then run the setup file (within said custom location) as admin.

    heres the link for the procedure:
    https://null-src.com/posts/nvidia-notebook-driver-inf-mod/post.php
     
    Last edited: Oct 7, 2020
    M18x-oldie, @tomX and islam like this.
  9. JTech80

    JTech80 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    5
    Ok I did that. It still showed a compatibility issue but now it shows up in the device manager. I’m re-installing flight simulator now to see if it works. Either way if it doesn’t work, I have a new computer on the way. Know anyone looking for an M18xR2? Thanks
     
  10. Azther

    Azther Notebook Consultant

    Reputations:
    10
    Messages:
    114
    Likes Received:
    63
    Trophy Points:
    41
    u would have to copy the hardware ID from device manager and alter the existing IDs in the drivers to that, since a section of those numbers is ur laptop model, what i did for my r1 is change all of the 780m IDs to my ID that was in device manager (theres 4 sets of IDs per OS section and same for the String section) after that it should work no problem.
     
Loading...
Similar Threads - [Release] Improved M18x
  1. ibmthink
    Replies:
    8
    Views:
    2,939

Share This Page