Razer Blade 2016 File Explorer Opening Time

Discussion in 'Razer' started by ananas, Aug 12, 2016.

Thread Status:
Not open for further replies.
  1. ananas

    ananas Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    Why does it take so long to open File Explorer? Everything else seems fine, but it just takes a bit longer than it should to open it. My 5 year old Aspire S3 (also with an SSD) opens it instantly, yet the Blade takes like a second. I know it's not a huge disaster, but I find myself opening File Explorer quite often, so that gets noticeable.
    It's a fresh Win 10 Anniversary install, only 3rd party apps are Chrome, Drive and Spotify.

    I know this sounds like whining, but why does a much lower end laptop perform better in an identical scenario?
     
  2. Galm

    Galm "Stand By, We're Analyzing The Situation!"

    Reputations:
    1,228
    Messages:
    5,706
    Likes Received:
    2,951
    Trophy Points:
    331
    Have you checked your disk usage? That shouldn't be happening.
     
  3. ananas

    ananas Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    Just did. It was at 0%. Then went up to 2.
    CPU usage doesn't go above 20% (usually stays at 1 - 5), memory stays at ~30%.

    Here's my CrystalDiskMark, PCMark Storage and PCMark Home results: http://imgur.com/a/BqAH4
     
    Last edited: Aug 12, 2016
  4. Galm

    Galm "Stand By, We're Analyzing The Situation!"

    Reputations:
    1,228
    Messages:
    5,706
    Likes Received:
    2,951
    Trophy Points:
    331
    Huh in that case, I'm not sure what's wrong. That's very weird.

    You aren't on like power saver are you?
     
  5. ananas

    ananas Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    Nope, I'm actually on High Performance. Interestingly enough if I make a shortcut of "My PC" and pin it to taskbar it opens instantly - even tho it's an identical window to the one opened with the File Explorer. I've done a fresh Windows install, and that doesn't change anything.
     
  6. Galm

    Galm "Stand By, We're Analyzing The Situation!"

    Reputations:
    1,228
    Messages:
    5,706
    Likes Received:
    2,951
    Trophy Points:
    331
    Lol I would just start using that instead then.
     
  7. ananas

    ananas Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    I was gonna, but that one doesn't have drop down menus for quick access, like Downloads, Documents etc. :(
    Do you have anything like this on your blade?

    Edit: just noticed you have the stealth
     
  8. ETisME

    ETisME Notebook Guru

    Reputations:
    4
    Messages:
    70
    Likes Received:
    29
    Trophy Points:
    26
    It should not be a hardware issue.
    Razer should definitely be faster than your other laptop.

    Honestly this will be hard to analyze, did you check the read write speed to see if the ssd is performing well?

    And is it only the file explorer? I rarely use it but I guess it could be a win10 optimization issue?

    Mine is coming in two days, I could probably run some speed test against yours.
     
  9. ananas

    ananas Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    I pasted them earlier in my comment, but here are my benchmark results: http://imgur.com/a/BqAH4
    It would be really helpful if we could compare our results.

    Oh and yes, it seems like it's only happening with File Explorer and only with the opening time. As I noted earlier, if I make a shortcut to My PC it opens instantly from that. But this is a fresh Windows install, identical to that on the Aspire.
     
  10. ETisME

    ETisME Notebook Guru

    Reputations:
    4
    Messages:
    70
    Likes Received:
    29
    Trophy Points:
    26
    Ok, I will check with you once I get the machine.
    but from the benchmarking, it doesn't look like a ssd issue at all. It must be something else, maybe post your question on a tech support for windows page also.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page