Razer Blade 15 (gtx2070) strange behavior on system boot

Discussion in 'Razer' started by Paul16, Sep 26, 2019.

  1. Paul16

    Paul16 Notebook Enthusiast

    Reputations:
    2
    Messages:
    45
    Likes Received:
    13
    Trophy Points:
    16
    Hi. I have a very strange problem that is not regular so i can't "catch" it.
    When laptop is off for some time and i try to turn it on it goes in 5 cycles of restart.
    Screen is fully black. Keyboard lighting turns on and off.
    After 5-7 cycles it loads windows 10 like everything is fine.
    There are no erros, no bsod and etc.
    Nearest service is located in another country so i can't send it easy way. And i am pretty sure if i do this, error wont show up when they will try to turn it on(because it happens rarely)
    This problem drives me crazy because of laptop price.

    this is video of process.
     
  2. senso

    senso Notebook Deity

    Reputations:
    254
    Messages:
    750
    Likes Received:
    177
    Trophy Points:
    76
    Kinda looks like its retraining memory timings.
    Can you force your RAM to run at a slower clock(like 2133Mhz) in the BIOS and see if the issue still remains?

    Also, are you running the latest BIOS?
     
    Paul16 likes this.
  3. Paul16

    Paul16 Notebook Enthusiast

    Reputations:
    2
    Messages:
    45
    Likes Received:
    13
    Trophy Points:
    16
    Hmmm... This is some kind of solution i've couldn't even think about.
    I'l check it. Thank you!
     
  4. Joikansai

    Joikansai Notebook Deity

    Reputations:
    157
    Messages:
    1,153
    Likes Received:
    446
    Trophy Points:
    101
    From the keyboard light behavior maybe it’s Synapse issue try to upload setting, reinstall it and check it again with or without Synapse. And maybe try Synapse Version as well the original from their Blade support website (if there’s any) or the latest updated one.
     
Loading...

Share This Page