Razer Blade 15.6" (GTX 1060/1070, 2018 edition) Owner's Lounge

Discussion in 'Razer' started by X33nbat, May 20, 2018.

  1. Joikansai

    Joikansai Notebook Geek

    Reputations:
    14
    Messages:
    94
    Likes Received:
    34
    Trophy Points:
    26
    Just like previous Blade 14 7700HQ, Kick on in random time on idle (usually when down loading something or maybe Synapse is doing something back there), then silent again right? At first time, like a month owning it I had also headache about that, but after that it was slowly gone even sometimes comes but not as often as on first month...or maybe because I was getting used to that Fans behavior;) But no I think, before I sold it and checked it it didn’t do that, only when downloading something maybe they addressed it from bios update or something like from intel update.
     
  2. childprotectorofthenight

    childprotectorofthenight Notebook Consultant

    Reputations:
    0
    Messages:
    120
    Likes Received:
    23
    Trophy Points:
    31
    Awesome thanks. I'm using balanced and auto. Do I set Turbo Ratio for 35 manually on all six cores if I want 3.5 ghz? Turned off turbo boost and it’s a night and day difference with fan noise. They don’t ramp up at all now when browsing and watching videos. Hopefully doesn’t have a huge impact on gaming. Lastly how do I limit the FPS to 144 so it matches the screen. It’s going well above in most games and causing extra fan noise. Vsync or does this cause a delay and defeat the purpose of the high refresh rate?
     
    Last edited: Jun 14, 2018
  3. wickette

    wickette Notebook Deity

    Reputations:
    240
    Messages:
    984
    Likes Received:
    475
    Trophy Points:
    76
    Seriously 100°C ? Pretty sure with Witcher 3 it'd be the same, anyone else hit the thermal limit on their razer blade ? If yes I will no other choice but to cancel the preorder : I really like how they market the new razer blade with a revolutionary vapor chamber cooling but still reaches 100°C...OMG just go for the quad core i5 at this point ! If your barebone can't handle 6 cores then be it.
     
  4. Joikansai

    Joikansai Notebook Geek

    Reputations:
    14
    Messages:
    94
    Likes Received:
    34
    Trophy Points:
    26
    No, I think AC Origins eat more CPU, it’s also because their new drm protection inside it, have both games Witcher 3 is more cpu friendly, and i think i saw someone saying hacked version AC Origins isn’t so much eat cpu. Actually when i saw Far Cry 5 temperature i feel like it is too high because it is not so demanding games like FFXV or AC Origins. I play Far Cry 5 on 4K (core 1080ti setting, all max) 50~60 FPS though never playing at high 100~ FPS, never see my cpu (7700HQ) reaching 80 but with AC Origins yes it was closing 90, without undervolting and if I don’t limiting turbo boost or lowering setting to high, it should cross 90 and throttle I believe.
     
    raz8020 likes this.
  5. Petrov

    Petrov Notebook Deity

    Reputations:
    207
    Messages:
    772
    Likes Received:
    43
    Trophy Points:
    41
    Yes - set each core to 35 if you want 3.5ghz. If you turn off Turbo Boost totally you will be running at 2.1ghz only, which will impact a lot of games (but it will be very quiet :)).

    Limiting the fps to 144 depends on the game. I don't think that many games have that functionality (many allow you to limit it to 60 with vsync, but im not sure many do 144).

    Using 60hz vync defeats the purpose of a 144 display, correct. I'd also like to have a 144 llimit and control thermals/fan better.
     
  6. Petrov

    Petrov Notebook Deity

    Reputations:
    207
    Messages:
    772
    Likes Received:
    43
    Trophy Points:
    41
    Deleted - incorrect information
     
    Last edited: Jun 14, 2018
  7. Assault

    Assault Notebook Consultant

    Reputations:
    22
    Messages:
    239
    Likes Received:
    162
    Trophy Points:
    56
    If you want to maximize thermals and still keep high fps, do not disable Turbo Boost on the hard games. Run lower clock speeds using FIVR in Throttle stop, but don't outright disable your ability to clock up. I'm constantly tweaking these settings and paying attention to the changes, and so far running even just 3.0ghz has landed me the same FPS in Fortnite, but not nearly as hot, keeping all my cores at high 70s and low low 80s. Feel free to copy these settings under a seperate profile with Throttlestop and try it out. Your undervolt may not be as high as mine, but if you run these lower speeds even just while gaming, you should see dramatic thermal drops. ***I'm still learning recipes for what optimizes the Blade well, so don't stake me for an idiot just yet. Any changes or input is highly welcome

    Screenshot (79).png Screenshot (80).png

    edit: when i alt-tab and brought up my graph for the screenshot, it affected my displayed fps in the background, i get much higher than 80 fps while in game. The point of the screenshot was to display the temps.
     
    Last edited: Jun 14, 2018
    Halaja, Darkhan and raz8020 like this.
  8. ubelai

    ubelai Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    6
    Are you still getting 144fps with those settings?
     
  9. Assault

    Assault Notebook Consultant

    Reputations:
    22
    Messages:
    239
    Likes Received:
    162
    Trophy Points:
    56
    yes but using high settings i believe. Epic bounces between 80 and 110
     
  10. childprotectorofthenight

    childprotectorofthenight Notebook Consultant

    Reputations:
    0
    Messages:
    120
    Likes Received:
    23
    Trophy Points:
    31
    Thanks for all the info :) I’ll try this all out
     
Loading...

Share This Page