Razer Blade 15.6" (GTX 1060/1070, 2018 edition) Owner's Lounge

Discussion in 'Razer' started by X33nbat, May 20, 2018.

  1. Joikansai

    Joikansai Notebook Deity

    Reputations:
    150
    Messages:
    1,068
    Likes Received:
    433
    Trophy Points:
    101
    Same here 2018 early batch model, use often web cam for Skype things and sometimes for fun recording myself playing guitar lol. But yes I saw some users reporting webcam defect, maybe due hardware that’s put in such tiny frame or maybe heat on webcam cable that cross over heatsink?
     
  2. rinneh

    rinneh Notebook Prophet

    Reputations:
    782
    Messages:
    4,651
    Likes Received:
    2,107
    Trophy Points:
    231
    I really hope they used the right materials for the cable, As long if it can handle temps up to 90c it should be fine. I do suspect they used some form of insulation. But the rubbing of the cable when opening and closing the screenlid might be a factor.

    I couldnt find any long term usage cases where the cable was damaged though. Saw a lot of posts that the webcam didnt work but no reason why that was.
     
    Joikansai likes this.
  3. darkloki

    darkloki Notebook Deity

    Reputations:
    407
    Messages:
    1,826
    Likes Received:
    177
    Trophy Points:
    81
    I mean I bought the 1060 Advanced model for this exact reason to avoid heat to destroy components within the system and I made the assumption that the 1060 has been around for a while so surely thermals for that particular card should be a walk in the park. I bought the Core to go along with my system and thought I had a perfect setup. I have a perfect setup for gaming but for everyday computing I don't quite have it.

    To have the issues I've had on a simple Camera Video Conference since August of 18 until now is somewhat inexcusable. If you go through my posts in the history I've been fair and supporting Razer this whole time until now because simply enough is enough. To have 2 laptops and now just a wait period to get my Camera to work just infuriates me. If they don't get this resolved by this August it'll be 1 year.

    Sorry again I don't mean to turn this thread or this post into a rant, but it's quite frustrating.
     
  4. Joikansai

    Joikansai Notebook Deity

    Reputations:
    150
    Messages:
    1,068
    Likes Received:
    433
    Trophy Points:
    101
    No it’s great to sharing your experience so other users can now the possibility issue on their unit. Just got Skype important meeting I would also be xxxxxx if the camera didn’t work. Damn it’s long enough issue you had, I would probably send it and getting new one if they can’t repair it.
     
  5. darkloki

    darkloki Notebook Deity

    Reputations:
    407
    Messages:
    1,826
    Likes Received:
    177
    Trophy Points:
    81
    I'm more then likely going to sell my laptop and purchase the 17 inch Razer when it comes out later this month. I'm doing this primarily because I have a 15 inch Macbook Pro and I'll probably just end up using the macbook more then the razer while on the go and doing my everyday computing.

    It's just unfortunate because Razer really almost got there, they came real damn close to making the perfect notebook but missed on this note. I say miss because if other people are complaining about it also (As noted above) and I've had 2 that missed that's more then enough to convince me that they missed here.

    Anyone who doesn't have problems consider yourself Lucky, Very Lucky...
     
    Goracij likes this.
  6. Goracij

    Goracij Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    5
    Trophy Points:
    6
    Mine was with TurboBoost off since first week of ownership, temps didn't go above 72°C ever since and still camera and microphone died on 3rd month. Doesn't look like a temp issue. Someone said the same issue persists on 2019 rtx models as well...

    Also had to wait for 4 weeks for it to be repaired. And guess what? They fixed issue but lost a one screw in the gpu fan - it stacked and locked the fan)))) Hopefully fan works and now I have a spare bottom cover screw...
     
    Last edited: May 5, 2019
  7. rinneh

    rinneh Notebook Prophet

    Reputations:
    782
    Messages:
    4,651
    Likes Received:
    2,107
    Trophy Points:
    231
    Havent found any 2019 issue sonline yet. But I will keep my eye out. I really wonder what causes these webcam modules to die.
     
  8. Goracij

    Goracij Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    5
    Trophy Points:
    6
    Here is one for instance (mercury white, rtx 2070 model). And there were more - just can't find the general topic for mic/camera issue on reddit.
     
  9. Joikansai

    Joikansai Notebook Deity

    Reputations:
    150
    Messages:
    1,068
    Likes Received:
    433
    Trophy Points:
    101
    About your web cam issue, did they provide you Bios 1.07? Apparently some users with webcam issues got fix with this bios update from support, it’s not official yet (on website latest is still 1.05).
    Yeah I am very lucky, 11 months no issues whatsoever....Maybe very very lucky as well since before my old Blade 14 was also doing great.
     
  10. Goracij

    Goracij Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    5
    Trophy Points:
    6
    Yepp, I have bois 1.07 and ec 1.03. The guy from support sent me the link to the bios update after reset failed to solve the issue (before it was 1.06).
    By the way, seems like razer have few iterations of that camera ribbon. Mine was 2.0 and they replaced it for the same revision.

    Maybe you are... Wonders do happen.
     
    Last edited: May 6, 2019
Loading...

Share This Page