Razer Blade 15.6" (GTX 1060/1070, 2018 edition) Owner's Lounge

Discussion in 'Razer' started by X33nbat, May 20, 2018.

  1. Assault

    Assault Notebook Evangelist

    Reputations:
    58
    Messages:
    415
    Likes Received:
    248
    Trophy Points:
    56
    Unsure on what model mine would be, but the update seemed to go right through. I do have a 1tb SSD in mine but don't know how that would affect it.
     
  2. Joikansai

    Joikansai Notebook Deity

    Reputations:
    254
    Messages:
    1,663
    Likes Received:
    703
    Trophy Points:
    131
    It’s on bottom cover. E073A2FF-0558-4F2B-8E81-295BDB98647D.jpeg
    Idk what does it mean, maybe later than 385;) Mine Born in June. Just upgrade SSD to 512gb evo 960 nvme haha, won’t pay more than my portable 2.5 5TB HDD. I still have time though getting 1 TB one for €270, but 512gb for €107 is just better value. I updated bios to latest one yesterday on original and when I try ec update after installation it stated already updated to the newest.
     
    Last edited: Aug 15, 2018
  3. kessomatt

    kessomatt Notebook Geek

    Reputations:
    1
    Messages:
    78
    Likes Received:
    11
    Trophy Points:
    16
    I updated both my bios and ec. Noticed sleep mode works correctly/differently now. Before if the lid was closed and I used an external mouse to wake the device the screen would not come back on if I opened it(. I would have to close the screen to put it back to sleep and open it again for the screen to turn back on.

    Also noticed it wakes quicker and the fans will turn on while in sleep mode(green flashing light) Wonder if this is working as intended.

    Edit: Figured it out. My settings for closing the lid were set to “do nothing”. Weird I never changed it. But the wake with external mouse bug is fixed when waking up from sleep. I know I saw someone else posted that they had the same problem.
     
    Last edited: Aug 15, 2018
  4. Chris Marshall

    Chris Marshall Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    3
    Trophy Points:
    6
    Share your undervolts please!?
    I'm at 150cpu / 150/ 125gpu
     
  5. Chris Marshall

    Chris Marshall Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    3
    Trophy Points:
    6
    How do you guys deal with the first scratch / mark you make on your Razer. I'm feeling depressed and it's hardly even visible.

    A damn USB cable hit it and put a dent next to the trackpad.
     
  6. Assault

    Assault Notebook Evangelist

    Reputations:
    58
    Messages:
    415
    Likes Received:
    248
    Trophy Points:
    56
    Mine did the same thing! Power plan changed on me and it wasn't me lol.

    Casualty of war, there's only 3 things I'd do. 1 is try to touch up paint it with a very fine point brush or marker, and 2 is cover it with a skin. Decalrus.com has interior skins, Dbrand has the best exteriors.

    3 live with it
     
  7. Joikansai

    Joikansai Notebook Deity

    Reputations:
    254
    Messages:
    1,663
    Likes Received:
    703
    Trophy Points:
    131
    I’m at -135mV per xtu, I’m not using default overclocking gaming mode but afterburner 210/700 (gaming mode only OC 100/300). Lower than that will cause crashing I believe, since it’s already crashing on +215 core clock on Firestrike.
     
  8. paradigm

    paradigm Notebook Deity

    Reputations:
    202
    Messages:
    1,127
    Likes Received:
    54
    Trophy Points:
    66
    so yeah, its a 386, mine too. I have downloaded the BIOS but it does not update me to 1.05, it goes through the motions but nil change to the version number. Can you elaborate anything you might have done differently ( like i even used administrator mode, disabled AV) the only thing i have modified is the WIN10 Pro and running on a 970Evo, and BIOS on defaults. Have you disabled the security options in the BIOS?????
     
  9. paradigm

    paradigm Notebook Deity

    Reputations:
    202
    Messages:
    1,127
    Likes Received:
    54
    Trophy Points:
    66
    Skin it, you'll forget it was ever there...not to mention, no more cleaning oils of the palmrest.. :)
     
  10. Joikansai

    Joikansai Notebook Deity

    Reputations:
    254
    Messages:
    1,663
    Likes Received:
    703
    Trophy Points:
    131
    No I didn’t change any setting on bios, Blade bios is quite laughable compared to other manufacturers, good they don’t reduce the performance unlike previous Blade, otherwise I’ll try anything to flash it. Btw don’t do bios update yet, seems have issue according a user on Reddit, something with usb and web camera, I think that 1.05 update is fixing trackpad on Linux. EC 1.02 Update is fine. I will apply thermal pad on SSD, the new one still 70ish. That’s all my upgrade atm SSD and its thermal Pad.
     
Loading...

Share This Page