Random beeping and no G-sync after clean install in P870DM-G

Discussion in 'Sager and Clevo' started by Cerberus, Apr 24, 2017.

Thread Status:
Not open for further replies.
  1. TomJGX

    TomJGX I HATE BGA!

    Reputations:
    1,449
    Messages:
    8,707
    Likes Received:
    3,311
    Trophy Points:
    431
    You lucky man...

    You kind of get screwed over warranty wise in the US... In Europe, it's 2 years min sop you are much better covered!
     
    Ultra Male likes this.
  2. Cerberus

    Cerberus Notebook Evangelist

    Reputations:
    212
    Messages:
    364
    Likes Received:
    68
    Trophy Points:
    41
    But I bought my machine from a US retailer so does that still allow me to benefit from Europe's min 2-year warranty?
     
  3. Prostar Computer

    Prostar Computer Company Representative

    Reputations:
    1,257
    Messages:
    7,425
    Likes Received:
    1,010
    Trophy Points:
    331
    Not exactly. Your warranty is still through your original seller and subject to their warranty terms, no matter where you are.
     
  4. Cerberus

    Cerberus Notebook Evangelist

    Reputations:
    212
    Messages:
    364
    Likes Received:
    68
    Trophy Points:
    41
    Yeah that's what I thought as well, thanks for the clarification.
     
  5. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    20,081
    Messages:
    20,260
    Likes Received:
    29,277
    Trophy Points:
    931
    so did you RMA it?
     
  6. Cerberus

    Cerberus Notebook Evangelist

    Reputations:
    212
    Messages:
    364
    Likes Received:
    68
    Trophy Points:
    41
    First thing tomorrow morning, the box is all wrapped up :)
     
    Ultra Male likes this.
  7. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    20,081
    Messages:
    20,260
    Likes Received:
    29,277
    Trophy Points:
    931
    All the best man, hope it gets fixed sooner than later.
     
    Papusan and Cerberus like this.
  8. Cerberus

    Cerberus Notebook Evangelist

    Reputations:
    212
    Messages:
    364
    Likes Received:
    68
    Trophy Points:
    41
    Thanks a lot buddy I appreciate it. I'll keep you posted.

    Cheers
     
    Ultra Male likes this.
  9. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,956
    Messages:
    50,250
    Likes Received:
    14,157
    Trophy Points:
    931
    Just as a note unless the company has an office in the region you are ordering you would certainly be subject to the laws of the country you are ordering from. However such an issue would be a nightmare to raise internationally at all usually.
     
  10. Cerberus

    Cerberus Notebook Evangelist

    Reputations:
    212
    Messages:
    364
    Likes Received:
    68
    Trophy Points:
    41
    Major Update:

    The post office informed me that should I go ahead and ship the laptop I will AGAIN have to pay the full VAT value when it will be shipped back to me. That's $700 on top of the shipping back and forth cost which is around $300.

    This means that I'm looking at roughly $1000 just to RMA my machine which is ludicrous!

    With that said it's no surprise that I decided not to ship the laptop and to try and find the solution myself.

    First thing I did was reseat the GPU. Ever since I did that I haven't experienced any beeping and the machine logs into Windows every single time. On top of that after repasting with Arctic MX-4 which was the only thermal paste I had readily available at the time, the GPU now idles at 40 degrees Celsius instead of the 49 degrees it used to idle at before, knowing that the original thermal paste is IC Diamond which is a bit surprising.

    So that makes me believe that the GPU is fine, and it is performing just fine in gaming. So the only issue now is that I don't have G-sync and the 60hz refresh rate. Therefore I started looking at the display for possible answers. I checked a thread on Tech Inferno about display EDID issues in Windows 10. @Mr. Fox and @Prema have extensive knowledge in this area so maybe they can assist me here.

    I compared the EDID info @Mr. Fox left generously in the P870DM-G thread with mine. Here's what I get in MonInfo:

    My MonInfo.jpg Mr. Fox's  MonInfo.jpg

    What do you think @Mr. Fox @Prema ? Does that mean that my EDID is corrupt and needs to be reflashed?
     
    Mr. Fox likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page