PSA: You can now overclock your laptop monitor [intel/intel+optimus]

Discussion in 'Gaming (Software and Graphics Cards)' started by margroloc, Mar 4, 2017.

  1. jaug1337

    jaug1337 de_dust2

    Reputations:
    2,135
    Messages:
    4,871
    Likes Received:
    1,030
    Trophy Points:
    231
    Yes exactly.

    Intel's custom resolution tool broke a few displays and furthermore, always was broken. However, launching it manually, works! And yes, it works on the built in display.

    Sad to know it doesn't work in W8.1 :(
     
  2. TheRealJohnp

    TheRealJohnp Notebook Enthusiast

    Reputations:
    2
    Messages:
    31
    Likes Received:
    8
    Trophy Points:
    16
    Hey, I'm not the same guy but I own a MSI GE62 2QD-276US Apache Pro and was able to overclock my display up to 100Hz (Didn't get past 105Hz). I7-5700HQ+960M. I have the SDC324C screen on my 15.6 inch laptop and the screen is made by Samsung but not much info is available on it.

    I installed the latest driver and played around following the directions on the first post. I used the LCD Reduced settings and 100Hz was fine with no flickering. When I don't use LCD Reduced I'm only able to get to 90Hz without flicker, so use that setting. I also tested with https://www.testufo.com/#test=frameskipping this tool and had absolutely no frame skipping. My settings: http://i.imgur.com/ZFhtb5B.png

    Some weird behavior I noticed is that when I overclocked the display to 60-70Hz I had bad flickering but after I got into the 80-100Hz Range using reduced it worked perfectly with no flicker at all. I never had a black screen until I tried 105Hz. Tested in games and my settings are select-able there and work great.

    I usually lurk and made this account to post this, hope it helps (Might not check again). Check your display model. If it's the same it should be good.
     
    margroloc likes this.
  3. Gagan@1234

    Gagan@1234 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    So... Was able to push from 60 to 100hz on my Asus Rog GL552 using default monitor values.... :D At 105, the display turns black..
    FEELS PRETTY GR8 AT 100 :D

    Edit : After trying out 105 now at 100 flickering is hugely visible.. Any solutions to this or my display is fked now? Whereas earlier when i tried 100 after 75, it seemed to work perfectly.. No flickering n stuff.
     
    Last edited: Aug 1, 2017
  4. TheRealJohnp

    TheRealJohnp Notebook Enthusiast

    Reputations:
    2
    Messages:
    31
    Likes Received:
    8
    Trophy Points:
    16
    Try selecting "LCD reduced" like I did here: http://i.imgur.com/ZFhtb5B.png

    There's weird behavior that nobody seems to be able to explain. Like I had flicker at 60-70Hz but no flicker at 80-100Hz. In any case, if you still have flicker it should be no problem to settle in the 90Hz-96Hz range. Maybe when you went from 105-->100 there was a setting that didn't properly save so you still get the flicker so when you go from 75-->100 there's no issues. Always try restarting your computer too.
     
  5. Gagan@1234

    Gagan@1234 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Restarting didnt help.. So after a few hrs of display running , flickering went away itself n now its perfectly normal.. yea maybe the display didnt revert back properly from 105 instantly. And at that time it used to flicker even on 75.. Ty for the help tho :D EZ 100hz masterrace xD

    Edit : Random flickering is till there.. HZ doesnt matter.. even on 75 it occurs. Seems like something is fkd up..
     
    Last edited: Aug 2, 2017
  6. margroloc

    margroloc Notebook Geek

    Reputations:
    96
    Messages:
    82
    Likes Received:
    135
    Trophy Points:
    41
    The first time overclocking I pushed the display too far and it went crazy. So I started to drop the refresh rate back down but the screen was still glitching out occasionally at settings that were previously stable. I got super scared and thought I wrecked my display and because anything slightly beyond 60hz (61hz, 62hz etc) caused the screen to still glitch out once in a while.

    I was going to call it quits until I realized that while I was overclocking the display the first time, I changed the timings to try and get some stability. Turns out that I switched my timings to the 'LCD-reduced' preset, which caused the display to go crazy, but while dropping the refresh rate back down I never changed the timings back to the default for my display. So afterwards whenever I kept trying to overclock and adjust the timings, I never managed to get close to settings that were previously stable. After realizing this and starting over I now have this display at 104hz and it's been working fine since last year.

    Point is: try deleting all the CRU settings to go back to a stock config, then work your way back up again. Maybe you changed the timings a little bit without realizing it made the display unstable? Worst case, if you want to go back to default refresh rate & default timings you can nuke all of CRU's EDID overrides via 'reset.exe'
     
    jaug1337 and TheRealJohnp like this.
  7. TheRealJohnp

    TheRealJohnp Notebook Enthusiast

    Reputations:
    2
    Messages:
    31
    Likes Received:
    8
    Trophy Points:
    16
    Very logical explanation. I also experienced the same thing but did not know it.
     
  8. Gagan@1234

    Gagan@1234 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Well i used my stock monitor timings but i'll try this. Thanks.
     
  9. Dantei

    Dantei Notebook Consultant

    Reputations:
    12
    Messages:
    269
    Likes Received:
    29
    Trophy Points:
    41
    Someone tried overclocking Acer's VN7-592g with IPS screen?
     
  10. TheRealJohnp

    TheRealJohnp Notebook Enthusiast

    Reputations:
    2
    Messages:
    31
    Likes Received:
    8
    Trophy Points:
    16
    MSI GE72 6QD Apache Pro 17.3 Inch Skylake with the Chi Mei CMN1735

    was able to be OC to 85Hz with native(norma) timings and 90Hz with the LCD reduced setting. Good result as from what I noticed here, the Chi Mei panels don't OC as well as others. 17.3 inch panels do well as somebody pointed out earlier.

    Always worth a try guys and if you try it... come here and post your results!
     
    margroloc likes this.
Loading...

Share This Page