PSA: You can now overclock your laptop monitor [intel/intel+optimus]

Discussion in 'Gaming (Software and Graphics Cards)' started by margroloc, Mar 4, 2017.

  1. margroloc

    margroloc Notebook Guru

    Reputations:
    82
    Messages:
    71
    Likes Received:
    115
    Trophy Points:
    41
    Did you try using CRU? I am pretty sure the main post is outdated now. There are new drivers for HD4000 + windows 10 and there might be a chance that changes in CRU will stick now.

    Sorry to see that. First time I've seen this process break a screen.

    Are you sure the other person had the same display? Lots of laptop manufacturers use multiple displays in same model laptops.

    Hope you were able to solve it. For future reference: Try plugging in an external monitor and resetting the settings that way. Run reset.exe in the CRU folder to clear the settings, or change the refresh rate back to normal in windows. You could also try booting up in safe mode and uninstalling the intel video driver (DDU).

    Thanks for your testing :)

    Updated the main post with all the results so far. thank you everyone who has posted.
     
    plummms likes this.
  2. ssj92

    ssj92 Neutron Star

    Reputations:
    1,152
    Messages:
    2,539
    Likes Received:
    2,627
    Trophy Points:
    181
    CRU doesn't support HD 4000 (3rd gen CPU based models). Only 4400+

    I already tried CRU and the latest drivers, unfortunately it's just unsupported.
     
    margroloc likes this.
  3. plummms

    plummms Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    3
    Trophy Points:
    6
    I fixed all my flickering problems for both 60 and 90+ Hz
    Access Intel Graphics Control Panel -> Power -> DISABLE Panel Self-Refresh for both On battery and Plugged In
     
    Last edited: Aug 21, 2018
  4. Eddye

    Eddye Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hi there, thanks for this trick. Just to let you know that I get 72 Hz maxi with my Razer Blade 2016 GTX 1060, FHD screen.
    Stable a 72 Hz but this seems to be the limit after hours of timing tweaking. I choose to use 70 Hz for Nvidia whisper mode (can't choose 72 FPS).
    However, this operation still have some risks. During this, I had to reboot the laptop a lot and after a while, the screen got full grey at start … impossible to see the desktop or whatever. Must hard reboot. I thought, I had loose my display.
    Well, I guess the pixel clock limit is 240 MHz but CRU automatic timing can't match Something good above 72 Hz (only LCD Native at 72 Max worked + 72 with default 60 Hz timing settings.)

    [​IMG]

    I realy can see the difference playing Overwatch with vsync at 70Hz. :) If some of you got higher rate pls give the settings !!
     
  5. y50user

    y50user Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    6
    Hey guys, I'd like to know if I'm doing something wrong.
    I tried adding like 61Hz, 62Hz or even 75Hz in CRU, but it never shows up in intel graphics panel. I thought I would be at least able to see it not work, like in getting a black screen or something, but I can't even select other refresh rates? However, Intel information center shows these new resolutions as supported. Does that simply mean that I'm out of luck with my panel?

    By the way, my driver is 4963 so I guess it's okay.
    [​IMG]
    [​IMG]
    [​IMG]
     
    hmscott likes this.
  6. nutta

    nutta Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    6
    Manage to get my dell inspiron 7567 BOE0690 FHD TN pannel to 90hz using standard timing with no artifact and frame skipping.
     
    Vasudev and hmscott like this.
  7. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    4,920
    Messages:
    17,315
    Likes Received:
    21,256
    Trophy Points:
    931
    Intel hasn't provided OC friendly resolution customization controls as Nvidia has, and while there are exceptions there are also challenges introduced into the mix by Intel iGPU control panel customization that ruins display OC'ing for many.
     
    Vasudev likes this.
  8. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    3,952
    Messages:
    7,056
    Likes Received:
    4,712
    Trophy Points:
    431
    Always get the message Bandwidth Limits exceeded.
     
  9. c0d3h4x0r

    c0d3h4x0r Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    Hardware: Lenovo IdeaPad U530 Touch, i7-4500U CPU, Intel HD 4400 graphics w/ nVidia GeForce GT 730M, 1920x1080 built-in LCD display
    OS: Win10 x64 (ver 10.0.17134 Build 17134)
    Intel HD Graphics Driver: 20.19.15.4963

    I need 50Hz refresh rate so I can correctly emulate European (PAL) mode classic computers/consoles (such as Commodore Amiga) w/ V-Sync enabled.

    Even after installing CRU-1.4, using it to add 50Hz display modes, and rebooting, the 50Hz display modes STILL do not show up in either the Windows control panel pages or the Intel graphics properties app. I cannot get 50Hz display modes to work at all. I thought the latest Intel drivers were supposed to have unlocked EDID override?
     
    Last edited: Aug 22, 2018
  10. Anoxyx

    Anoxyx Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    TLDR:
    Successfully overclocked my monitor from 60 to 90hz.
    ASUS G551JM, i7 4710HQ, GTX 860M, panel LG Philips LGD042C, 1080p, win10, driver 15.40.37.4835, 60hz -> 90hz

    OC achieved using standard timings. Could probably push it a bit higher with custom timings but 90hz a great success for me.
    Latest Intel drivers don't seem to work (15.40.38.4963), no custom resolution was shown. Drivers recommended in OP worked for OC but caused problems elsewhere: Resolution scaling kept resetting to 125% and my secondary monitor was set to duplicate instead of extend after waking from sleep or restart. Also overclock wouldn't stick after reboot. With 15.40.37.4835 driver I have none of these issues.

    Overall I am very happy with the results. The difference is noticeable in everyday use and in games that can push 60+fps. Thanks!
     
Loading...

Share This Page