Predator Helios 300 Power Loss while gaming

Discussion in 'Acer' started by Kunal Shrivastava, Aug 30, 2018.

  1. Kunal Shrivastava

    Kunal Shrivastava Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Need help with laptop randomly switching off during high-end gaming sessions. Runs fine under normal workloads and laptop is not overheating during intense gaming(80c max). Bios has been updated to latest v1.19 (model G3-572). Had opened recently for repaste(liquid ultra-II) but I have made sure that all screws are securely fastened and the ram cover pushes the battery switch. Laptop runs fine on battery but loses power while connected to mains and running CPU/GPU intensive apps after 5-10 mins,then laptop does not restart and after pressing the power switch only keyboard powers on for 5-10 seconds and it cuts out power again: this loops for about 2-3 times after which screen finally turns on to display the predator logo and then laptop boots and works as expected...until it happens again.Event ID 41 is generated at startup. I use MSI afterburner to monitor temps while gaming so pretty sure its well within the temperature threshold. Is there anything else that could be causing this issue ? I suspect its related to power delivery. Have already tried resetting the battery..Pretty sure I cant get a warranty repair done after a repaste.
    Also an observation: The same thing happened when I flashed Bios 1.19, fans at full speed during the flashing process and then laptop lost power unexpectedly. However its booting into the Bios without any issues.
     
  2. Mr.K-1994

    Mr.K-1994 Notebook Consultant

    Reputations:
    5
    Messages:
    150
    Likes Received:
    49
    Trophy Points:
    41
    I suspect the BIOS and/or the AC adapter is running amok here.
    I am an Helios 300 user too.But I have yet to update the BIOS to 1.19.
     
Loading...

Share This Page