Precision 7720 Owner's Thread

Discussion in 'Dell Latitude, Vostro, and Precision' started by BillDownTheStreet, Sep 14, 2017.

  1. Sparkybruce

    Sparkybruce Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    6
    I have just installed CPUz and it is actually reporting that the ram is running at 1333Mhz (so ddr gives 2666Mhz date rate). So windows is just lying.
    Given the three attempts it has taken to get the fall update installed correctly I'm not too surprised. (the fix to that appears to be update the Nvidia driver first directly from the dell download site).
     
  2. RealJEDI

    RealJEDI Notebook Consultant

    Reputations:
    23
    Messages:
    113
    Likes Received:
    10
    Trophy Points:
    31
    Hi there,

    Who is brave enough for the latest BIOS (1.8.4)? :)

    Cheers,
    Alex
     
  3. iieeann

    iieeann Notebook Evangelist

    Reputations:
    298
    Messages:
    484
    Likes Received:
    42
    Trophy Points:
    41
    I installed few days ago, so far general use no issue, but most probably is because I don't use most of the functions this machine has to discover any.
     
    RealJEDI likes this.
  4. RealJEDI

    RealJEDI Notebook Consultant

    Reputations:
    23
    Messages:
    113
    Likes Received:
    10
    Trophy Points:
    31
    Hi,

    Did the BIOS update and no negative observations so far. Have to check my different docking stations...

    Cheers,
    Alex
     
  5. iieeann

    iieeann Notebook Evangelist

    Reputations:
    298
    Messages:
    484
    Likes Received:
    42
    Trophy Points:
    41
    :eek: An urgent 1.9.0 bios was released on X'mas...
     
  6. RealJEDI

    RealJEDI Notebook Consultant

    Reputations:
    23
    Messages:
    113
    Likes Received:
    10
    Trophy Points:
    31
    Hi,

    Since I've got less work to do between Christmas and New Year I did the update and the notebook is still working :)

    Cheers,
    Alex
     
    Last edited: Dec 30, 2017
  7. Pirx

    Pirx Notebook Virtuoso

    Reputations:
    2,999
    Messages:
    3,001
    Likes Received:
    406
    Trophy Points:
    151
    BIOS 1.9 seems to be working fine as in, not any worse than what we had before, but I'm not sure if any of the known issues are fixed.

    The system hangs after the screen having gone to sleep have been quite infrequent (by now roughly once every couple of weeks or so), so it's too early to tell if that has been fixed. Audio still lags randomly so system sounds are unusable. And, of course, we still have the stuttering due to the half-broken hybrid graphics stack.

    Long story short, for a laptop in that class the 7720 basically behaves like a $500 piece of crap. Not good if you paid $5k... Taken together with that idiotic keyboard layout, this will have been the last Dell I have bought, and quite possibly the last Windows machine, too.
     
  8. Pirx

    Pirx Notebook Virtuoso

    Reputations:
    2,999
    Messages:
    3,001
    Likes Received:
    406
    Trophy Points:
    151
    Just for completeness, I had another hang last night and had to power-cycle to get access. Great machine/OS, see above. :(
     
  9. iieeann

    iieeann Notebook Evangelist

    Reputations:
    298
    Messages:
    484
    Likes Received:
    42
    Trophy Points:
    41
    I don't have this issue, i disabled intel graphic in the bios anyway. I don't use battery often, and electric bill is none of my concern so power saving is not needed.
    I sleep only the monitor but the system is always on. 95% of the time is on dock station with external peripherals.
     
    alexhawker likes this.
  10. RealJEDI

    RealJEDI Notebook Consultant

    Reputations:
    23
    Messages:
    113
    Likes Received:
    10
    Trophy Points:
    31
    Hi,

    One of the last 2 BIOS versions (1.8.4 or 1.9.0) brought back the old problem that the screen stays black after waking up docked. Pretty annoying.

    Had to switch off Optimus, because the Intel graphics driver totally screwed up the picture (strong banding with darker colors). Maybe the wake-up problem is connected with this (or the NVIDIA driver).

    Cheers,
    Alex
     
Loading...

Share This Page