Precision 7530 & Precision 7730 owner's thread

Discussion in 'Dell Latitude, Vostro, and Precision' started by Aaron44126, Jun 27, 2018.

  1. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    858
    Messages:
    5,424
    Likes Received:
    1,936
    Trophy Points:
    331
    It's a headset that you plugged in (3.5mm plug with three rings)?

    I just checked and it does not work for me either. (I know that it has worked before.) Using Realtek driver 10.0.18362.356.

    I tried switching to the Microsoft audio driver (which I generally prefer to use anyway; the Realtek one snuck back on during an update). Still doesn't work. So it's not a problem with the driver.

    Could a firmware update have broken this ...?

    These days I'm using a USB headset so I never would have noticed.
     
  2. Ionising_Radiation

    Ionising_Radiation ?v = ve*ln(m0/m1)

    Reputations:
    749
    Messages:
    3,228
    Likes Received:
    2,642
    Trophy Points:
    231
    Indeed.

    As you mentioned, I get a feeling an EC/Intel ME update might have borked things. I updated to BIOS 1.12.1 a month or so ago (when it was released), and promptly rolled back because I'd lost brightness control with graphics switching disabled, but the ME and EC updates stayed.
     
  3. paulmofyourhand

    paulmofyourhand Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have a 7530, i7, p3200 gfx card, windows 10 1909. all latest driver and bios updates via Command | Update.

    I'm having issues with it getting stuck on a blank screen.
    Scenario 1: cold boot, dell logo appears, circle of dots appear, then the laptop remains on, but doesn't hit the windows login screen. I have to hard reset and then it'll come up.
    Scenario 2: I hit WindowsKey+L to lock my screen to walk away and do some errands. When I get back to wake it up, it won't, but I can hear the machine still on. Hard reset is the only way I can get it to come back up.
     
  4. Regular_Ragnor

    Regular_Ragnor Notebook Consultant

    Reputations:
    15
    Messages:
    105
    Likes Received:
    53
    Trophy Points:
    41
    I was having 3.5mm jack issues too. Regular stereo headphones are not recognized when plugged in; audio continues to play through the laptop speakers.

    There's a new audio driver online; released on 8th on January. It fixed the issue for me.
    EDIT: nvm... I rebooted and the issue popped up again.
     
    Last edited: Jan 19, 2020
  5. dafunk60

    dafunk60 Notebook Consultant

    Reputations:
    15
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    30
    I'm having the same issue reported in Scenario 1. 7730 Xeon E-2186M & Quadro P4200. Disabling Switchable Graphics allows me to boot into windows with a working display. Unfortunately, as one would expect the dGPU is always on and there is no backlight brightness control. I can shut down, re-enable Switchable Graphics and it will boot fine, but only once. A subsequent cold boot gets me back to a black screen. I've uninstalled & reinstalled all graphics drivers from the Dell website but the problem persists.

    EDIT - SOLVED?
    I suspect there is some incompatibility with the most recent Nvidia Quadro driver and Bios 1.12.1 causing the black screen for me. Bios 1.12.1 & Quadro driver from Sept 12 2019, H6F8G_WIN_26.21.14.3123_A05 appears to have resolved the issue (fingers crossed).

    ADDITIONAL INFO
    I took an image of my system before starting to troubleshoot. I restored that image to a 2nd 7730 system with the same specs and the black screen issue was not present. The bios version of the second system is 1.8.2. All bios settings were the same. This makes me think the bios must be involved and the update to version 1.12.1 corresponds to the start of my issue. There were several drivers updated the same day, including both graphics drivers so it could be any of them.

    7730 Update History.png


    On the original system, I rolled back to earlier bios versions, removed windows updates, DDU & reinstalled Nvidia & Intel graphics drivers without any success. One odd thing I noticed is that when the Nvidia driver was not installed the black screen issue did not occur.

    There appears to be a variety of display / gpu issues with recent bios updates over in the Dell Community forums.

    EDIT 2 - NOT SOLVED
    So the problem came back after several reboots. I am able to work around it somewhat by disabling “Discrete Graphics Controller Direct Output Mode” & enabling “Enable Switchable Graphics" in the BIOS. This does prevent me from using the laptop display with 3 external monitors through the TB18DC dock. I've opened a support request with Dell.

    EDIT 3 - SOLVED
    Just posting this in case someone with a similar issue runs across this. The problem turned out not to be a Dell problem at all but instead an issue with LogiOptions software from Logitech. Simply unplugging the Logitech USB receiver allowed the computer to boot normally. The reason I could not reproduce the issue when restoring a backup to different hardware was because I did not move the Logitech USB receiver to the other 7730. Uninstalling & reinstalling the LogiOptions software resolved the issue. Not sure what was going on & what that software / USB receiver was doing to prevent the PC from booting but I'm glad the issue is resolved.
     
    Last edited: Mar 7, 2020
  6. Baddemichl

    Baddemichl Notebook Consultant

    Reputations:
    21
    Messages:
    114
    Likes Received:
    130
    Trophy Points:
    56
    Can someone share the RTX5000 (notebook) Vbios, please.
     
  7. xklis

    xklis Notebook Consultant

    Reputations:
    8
    Messages:
    151
    Likes Received:
    18
    Trophy Points:
    31
  8. Baddemichl

    Baddemichl Notebook Consultant

    Reputations:
    21
    Messages:
    114
    Likes Received:
    130
    Trophy Points:
    56
    Thanks,

    with this Vbios, i only get a black screen at start up.
    Is there another version available?
     
  9. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    858
    Messages:
    5,424
    Likes Received:
    1,936
    Trophy Points:
    331
    Are you using Quadro RTX 5000 in the Precision 7740 or some other system?
     
  10. Baddemichl

    Baddemichl Notebook Consultant

    Reputations:
    21
    Messages:
    114
    Likes Received:
    130
    Trophy Points:
    56
    I´m using the RTX (80w Vbios) in an M18xR2.
    So i would like to try some higher Watt versions. 90W would be fine.
    But they are not so easy to find.
     
Loading...

Share This Page