Precision 7530 & Precision 7730 owner's thread

Discussion in 'Dell Latitude, Vostro, and Precision' started by Aaron44126, Jun 27, 2018.

  1. rwzeitgeist

    rwzeitgeist Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    5
    Trophy Points:
    6
    128GB

    (1) Dell's configurator stops at 128GB (4x32GB DDR4 2666MHz Non-ECC) but currently shows only an i7-8850H, not an i5 option. https://www.dell.com/en-us/work/shop/cty/pdp/spd/precision-17-7730-laptop/xctop7730hwus
    (2) Kingston's memory upgrade page for the 7730 says 128GB. https://www.kingston.com/us/memory/search?model=98913&devicetype=3&mfr=DEL&line=Precision
    (3) Crucial's memory upgrade page for the 7730 says 128GB. https://www.crucial.com/usa/en/compatible-upgrade-for/Dell/precision-7730

    Neither Kingston nor Crucial mentions memory limitations due to processor selection, i.e., i5 vs. i7.

    Intel's i5-8500 page says the processor supports up to 128GB. https://ark.intel.com/content/www/u...5-8500-processor-9m-cache-up-to-4-10-ghz.html
     
    supermoth likes this.
  2. frostbytes

    frostbytes Notebook Consultant

    Reputations:
    2
    Messages:
    227
    Likes Received:
    17
    Trophy Points:
    31
    supermoth likes this.
  3. supermoth

    supermoth Notebook Consultant

    Reputations:
    10
    Messages:
    119
    Likes Received:
    4
    Trophy Points:
    31
    Thanks for the info.

    Thanks for your help
     
  4. avdo

    avdo Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    What's people's thought on the Intel 760p supplied in some 7530's.

    I'm seeing some low write speeds compared to my other drives?
     
    Last edited: Jan 9, 2020
  5. Ionising_Radiation

    Ionising_Radiation ?v = ve*ln(m0/m1)

    Reputations:
    641
    Messages:
    2,743
    Likes Received:
    2,276
    Trophy Points:
    181
    So, the Jack Mic on my notebook doesn't detect microphones plugged into the combo 3.5mm port anymore:
    [​IMG]

    There is currently a pair of earpieces, with a microphone (RHA m750i) plugged in. This problem did not previously occur. Does anyone have a clue why this might be happening?
     
  6. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    727
    Messages:
    4,112
    Likes Received:
    1,145
    Trophy Points:
    231
    It's a headset that you plugged in (3.5mm plug with three rings)?

    I just checked and it does not work for me either. (I know that it has worked before.) Using Realtek driver 10.0.18362.356.

    I tried switching to the Microsoft audio driver (which I generally prefer to use anyway; the Realtek one snuck back on during an update). Still doesn't work. So it's not a problem with the driver.

    Could a firmware update have broken this ...?

    These days I'm using a USB headset so I never would have noticed.
     
  7. Ionising_Radiation

    Ionising_Radiation ?v = ve*ln(m0/m1)

    Reputations:
    641
    Messages:
    2,743
    Likes Received:
    2,276
    Trophy Points:
    181
    Indeed.

    As you mentioned, I get a feeling an EC/Intel ME update might have borked things. I updated to BIOS 1.12.1 a month or so ago (when it was released), and promptly rolled back because I'd lost brightness control with graphics switching disabled, but the ME and EC updates stayed.
     
  8. paulmofyourhand

    paulmofyourhand Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have a 7530, i7, p3200 gfx card, windows 10 1909. all latest driver and bios updates via Command | Update.

    I'm having issues with it getting stuck on a blank screen.
    Scenario 1: cold boot, dell logo appears, circle of dots appear, then the laptop remains on, but doesn't hit the windows login screen. I have to hard reset and then it'll come up.
    Scenario 2: I hit WindowsKey+L to lock my screen to walk away and do some errands. When I get back to wake it up, it won't, but I can hear the machine still on. Hard reset is the only way I can get it to come back up.
     
  9. Regular_Ragnor

    Regular_Ragnor Notebook Geek

    Reputations:
    15
    Messages:
    97
    Likes Received:
    52
    Trophy Points:
    26
    I was having 3.5mm jack issues too. Regular stereo headphones are not recognized when plugged in; audio continues to play through the laptop speakers.

    There's a new audio driver online; released on 8th on January. It fixed the issue for me.
    EDIT: nvm... I rebooted and the issue popped up again.
     
    Last edited: Jan 19, 2020
  10. dafunk60

    dafunk60 Notebook Consultant

    Reputations:
    15
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    30
    I'm having the same issue reported in Scenario 1. 7730 Xeon E-2186M & Quadro P4200. Disabling Switchable Graphics allows me to boot into windows with a working display. Unfortunately, as one would expect the dGPU is always on and there is no backlight brightness control. I can shut down, re-enable Switchable Graphics and it will boot fine, but only once. A subsequent cold boot gets me back to a black screen. I've uninstalled & reinstalled all graphics drivers from the Dell website but the problem persists.

    EDIT - SOLVED?
    I suspect there is some incompatibility with the most recent Nvidia Quadro driver and Bios 1.12.1 causing the black screen for me. Bios 1.12.1 & Quadro driver from Sept 12 2019, H6F8G_WIN_26.21.14.3123_A05 appears to have resolved the issue (fingers crossed).

    ADDITIONAL INFO
    I took an image of my system before starting to troubleshoot. I restored that image to a 2nd 7730 system with the same specs and the black screen issue was not present. The bios version of the second system is 1.8.2. All bios settings were the same. This makes me think the bios must be involved and the update to version 1.12.1 corresponds to the start of my issue. There were several drivers updated the same day, including both graphics drivers so it could be any of them.

    7730 Update History.png


    On the original system, I rolled back to earlier bios versions, removed windows updates, DDU & reinstalled Nvidia & Intel graphics drivers without any success. One odd thing I noticed is that when the Nvidia driver was not installed the black screen issue did not occur.

    There appears to be a variety of display / gpu issues with recent bios updates over in the Dell Community forums.

    EDIT 2 - NOT SOLVED
    So the problem came back after several reboots. I am able to work around it somewhat by disabling “Discrete Graphics Controller Direct Output Mode” & enabling “Enable Switchable Graphics" in the BIOS. This does prevent me from using the laptop display with 3 external monitors through the TB18DC dock. I've opened a support request with Dell.
     
    Last edited: Jan 26, 2020
Loading...

Share This Page