Poor gaming performance on battery - Clevo PB70EF (Powerspec 1720)

Discussion in 'Sager and Clevo' started by Harte, Nov 13, 2019.

  1. Harte

    Harte Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    6
    I own a PowerSpec 1720/Clevo PB70EF-G, but I'd assume the issue I'm having may apply to all similarly-built laptops. When gaming on battery, I'm getting very, very poor framerates and stuttering, in the range of 15-20fps. When plugged in, I'm easily getting 60fps with the same games. I know that to extend battery life, certain settings are changed by the system to conserve power, but it's almost unplayable. I'm not expecting hours and hours of cord-free gaming - just looking for an hour or so during my lunch break without having to lug the AC adapter with me to work.

    When gaming on battery, it normally starts off good, in the 30-45 range, but then slows down considerably. I'm assuming the act of heating up is causing the CPU or GPU to throttle?

    I tried changing my power profile in the Clevo Control Center to "Performance" instead of "Power Saving" or "Entertainment", but that didn't help much if at all. I also tried going into the Windows Power settings to change the battery settings to match the plugged in settings, such as active cooling instead of passive on the CPU, no power management on the PCI link, performance instead of power savings on the wireless adapter, etc. But no improvement.

    Are there settings I'm missing that can make the laptop perform as well when on battery as it does when plugged in, even at the cost of battery life? Maybe something I can tweak within the Nvidia GeForce experience (which I don't currently have installed)?

    Again, not looking for long battery life or even 60fps while on battery. Just 45 mins with 30 fps would be awesome. With that fancy g-sync it comes with, the 30fps wouldn't even look too shabby, I gather.

    Cheers!
     
    Last edited: Nov 13, 2019
  2. jc_denton

    jc_denton Notebook Deity

    Reputations:
    1,170
    Messages:
    833
    Likes Received:
    882
    Trophy Points:
    106
    Check nVidia control panel > Manage 3D settings > Power management mode > "Prefer maximum performance"
    In global settings make sure that the preferred graphics processor is set to "High-performance nvidia processor"
     
  3. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,275
    Messages:
    52,263
    Likes Received:
    14,962
    Trophy Points:
    931
    Current battery technology can't supply full power to the system without exploding and even if it could they would generally drain in about 15 minutes.
     
  4. Harte

    Harte Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    6
    Thanks for the replies...I forgot about the "prefer maximum performance" option. I'll give that a try next time I'm on battery.

    And understood about the current battery tech. Maybe I'll just buy a 2nd ac adapter and keep at work. Although having the battery only keeps me from getting in trouble with long gaming lunches >.<
     
  5. Support.3@XOTIC PC

    Support.3@XOTIC PC Company Representative

    Reputations:
    1,265
    Messages:
    7,163
    Likes Received:
    995
    Trophy Points:
    281

    Definitely, a spare AC adapter is pretty much required in that situation.

    Can't help you on the long gaming lunches. Maybe get your boss playing too, then it's their fault when they go long.
     
  6. JEAMN

    JEAMN Notebook Geek

    Reputations:
    5
    Messages:
    85
    Likes Received:
    30
    Trophy Points:
    26
    I can get a good 1hr or so of gaming out of mine using NVidia's battery optimizer.

    Do you have hybrid mode enabled? I notice with mine, that it will sometimes launch with iGPU on battery. Even if the dGPU is throttled by the battery, it's still much faster than the iGPU.
     
  7. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,275
    Messages:
    52,263
    Likes Received:
    14,962
    Trophy Points:
    931
    Turn that and the nvidia activity icon enabled in the nvidia driver control panel will confirm if the dedicated gpu is active.
     
Loading...

Share This Page