plz help! alienware 17 r5 gtx 1070 low GPU usage and fps

Discussion in '2015+ Alienware 13 / 15 / 17' started by johnnylive, Dec 2, 2018.

  1. johnnylive

    johnnylive Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    6
    im getting fps drops no matter what game i play and i see the GPU usage drop to like 28% when the drops happen the laptop is only one-day old go from 60 to like 32 fps then it goes right back up to 60fps my r5 my GPU usage only hit around 50% usage maybe 60% sometimes my temps on GPU is 47 C CPU 50 to 60 cps usage 18% to 26 makes me wanna send this thing back guys

    • Windows 10 Home operating system

    • 2.2GHz eighth-generation Intel Core i7-8750H hexa-core processor with 8MB cache, up to 3.9GHz with Turbo Boost

    • 17.3" diagonal Full HD anti-glare display with 1920x1080 resolution, IPS technology

    • 16GB 2400MHz DDR4 RAM

    • 1TB hard drive

    • 500GB SSD

    • 802.11ac Wi-Fi

    • Bluetooth 5.0 wireless technology

    • NVIDIA GeForce GTX 1070 OC graphics with 8GB GDDR5 memory
     
  2. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    354
    Messages:
    2,222
    Likes Received:
    1,251
    Trophy Points:
    181
    Try using HWInfo64, run your game or what ever it is you're doing with it on and let us know what it says.

    Will let us know if there is anything obvious to look at. Then from there we can start ruling things out.
     
    M18x-oldie likes this.
  3. xKilXlerx

    xKilXlerx Notebook Guru

    Reputations:
    6
    Messages:
    70
    Likes Received:
    12
    Trophy Points:
    16
    What power state are you using? Power saving/balanced/Performance? Might affect the performance of your laptop.
     
    Last edited: Dec 3, 2018
    M18x-oldie likes this.
Loading...

Share This Page