Plugged in: Stuck at full clock speed?

Discussion in 'Dell XPS and Studio XPS' started by Kaitlyn2004, Aug 20, 2018.

Thread Status:
Not open for further replies.
  1. _sem_

    _sem_ Notebook Deity

    Reputations:
    95
    Messages:
    760
    Likes Received:
    263
    Trophy Points:
    76
    Are the profiles actually gone in the last Windows release (I still haven't migrated)? I recall they disappeared with the former "feature update" but I could get them back by creating a new profile, then the others were also offered as the starting point.
     
  2. custom90gt

    custom90gt Doc Mod Super Moderator

    Reputations:
    7,277
    Messages:
    3,302
    Likes Received:
    3,522
    Trophy Points:
    331
  3. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,897
    Messages:
    5,696
    Likes Received:
    4,552
    Trophy Points:
    431
    I did a clean install of Windows 10 1803 on an early desktop Core i CPU yesterday and the power profiles were exactly the same as the good old days. Same thing with a 7th Gen Core i7 desktop computer I have. Perhaps the new fangled Windows power slider is only installed on laptops.
     
    hmscott likes this.
  4. pressing

    pressing Notebook Deity

    Reputations:
    262
    Messages:
    1,773
    Likes Received:
    874
    Trophy Points:
    131
    On my XPS 9550 laptop, I am on Windoze 10 Pro1803 and power profiles are unchanged
     
  5. Papusan

    Papusan JOKEBOOK's Sucks! Dont waste your $$$ on FILTHY

    Reputations:
    24,956
    Messages:
    24,567
    Likes Received:
    43,225
    Trophy Points:
    931
    You find them in Win Mobility Center
    [​IMG]

    And you can as well add in the Ultimate power plan (Scam) intended for Win Pro Workstation. Optimal Ytelse in Norwegian.
    upload_2018-8-22_1-33-46.png
     
    Ashtrix and pressing like this.
  6. MrBuzzkill

    MrBuzzkill Notebook Consultant

    Reputations:
    31
    Messages:
    176
    Likes Received:
    102
    Trophy Points:
    56
    Power profiles still exist, they are just hidden under the right click menu on the battery icon.

    If your system is using the High Performance profile, it will stay at the max clock speeds indefinitely. Doublecheck to see if you are not using the High Performance Profile, and if you aren't, try checking the Energy Saving profile and see if it lowers your clocks. If there is no Energy Saving power plan, add your own: https://www.windowscentral.com/how-manage-custom-power-plans-windows-10. The slider shouldn't matter for AC use, I just tried it and it won't clock to max.
     
  7. kilimats

    kilimats Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    6
    Been searching for this on google for 5min and found your thread which describes EXACTLY my problem, i have the same laptop and CPU lol and im stuck at 2.8GHz

    I loaded the latest bios 1.11.0, released on aug 15th a few days ago so think maybe related? what bios are you running?
     
  8. Sptz

    Sptz Notebook Consultant

    Reputations:
    5
    Messages:
    140
    Likes Received:
    10
    Trophy Points:
    31
    I'm a bit confused as to why people are saying there's a difference between balanced power plan and high performance? If you manually customise each setting to behave a certain way for battery and AC mode, then shouldn't that same power plan act as a "high performance" on AC and "energy saving" on battery? Since you're selecting power saving values for when on battery and high performance ones for when on AC?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page