Plugged in: Stuck at full clock speed?

Discussion in 'Dell XPS and Studio XPS' started by Kaitlyn2004, Aug 20, 2018.

Thread Status:
Not open for further replies.
  1. Kaitlyn2004

    Kaitlyn2004 Notebook Enthusiast

    Reputations:
    0
    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    16
    Have an XPS 15 9560 w/ i7 processor.

    When plugged in and looking at HWMonitor, it seems my clock is stuck consttantly at 2.8GHz, even when idle.

    On battery when idle it will drop down to 800MHz. Plug it in, and it'll never drop from 2.8GHz. I don't necessarily need or want it to STAY at full power when plugged in, have I set something incorrectly?


    I am also using Throttlestop, but I don't have any special "battery vs plugged-in power profiles"
     
  2. custom90gt

    custom90gt Doc Mod Super Moderator

    Reputations:
    7,272
    Messages:
    3,301
    Likes Received:
    3,521
    Trophy Points:
    331
    Maybe post a capture of your throttlestop settings so we can comment on that. It may also be a windows power profile so you can check that too.
     
  3. Kaitlyn2004

    Kaitlyn2004 Notebook Enthusiast

    Reputations:
    0
    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    16
    Clicking battery icon in system tray is on "Best performance", but changing this doesn't seem to have an impact.

    Here are my ThrottleStop settings:

    throttlestop.png
     
  4. improwise

    improwise Notebook Deity

    Reputations:
    60
    Messages:
    1,511
    Likes Received:
    429
    Trophy Points:
    101
    You might want to check you BIOS settings as well for Turbo, SpeedStepz Cstates etc. Perhaps also Dell Power Manager if installed.

    Sent from my SM-N950F using Tapatalk
     
  5. Kaitlyn2004

    Kaitlyn2004 Notebook Enthusiast

    Reputations:
    0
    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    16
    Clean windows install, so no Dell Power Manager but there is the intel thermal framework (but I imagine that wouldn't be doing anything to KEEP it at 100% clock speed?)

    Speedstep is enabled in BIOS and in throttlestop.

    As mentioned, it downclocks as expected when not performing tasks on battery power (and hits full speed when needed)
     
  6. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,897
    Messages:
    5,695
    Likes Received:
    4,550
    Trophy Points:
    431
    ThrottleStop shows that your CPU is spending 22.9% of the time in the C0 state. That means it is busy working on something so of course it is not going to idle down when it is plugged in. Why should it? Your 7700HQ has work to do so best to do that at full speed. It would get more work done faster if you did not check the Disable Turbo box.

    If you want your CPU to slow down, open up the Task Manager and find out what is running in the background.

    Here is what an idle laptop looks like.

    [​IMG]

    My 4700MQ only needs to spend 0.4% of the time in the C0 state to process all of the various Windows background tasks. Your computer is up to something so find out what that is.
     
    Papusan likes this.
  7. Kaitlyn2004

    Kaitlyn2004 Notebook Enthusiast

    Reputations:
    0
    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    16
    Here is what I get after a reboot... it happily ran around the 800-1200MHz range until I plugged in, and then it jumps up to full clock speed and doesn't move at all once there. I don't really understand the C-states

    resources.png
     
  8. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,897
    Messages:
    5,695
    Likes Received:
    4,550
    Trophy Points:
    431
    When a core has something to do, it will go into the C0 c state. When it has nothing to do, it will go into one of the low power c states like C3, C6 or C7. Look in the ThrottleStop C0% column that I posted. Almost all of the threads are spending less than 0.5% of the time in the C0 state. That means the CPU is idle. Now look at your screenshot in the C0% column. You have one thread at 18.3%. Your CPU is not idle. Click on the Task Manager Details tab and then click on the CPU column to arrange the running tasks from high CPU usage to low. A clean system can spend 99% of the time idle.

    [​IMG]

    If you want your CPU to slow down, start by fixing this problem. You have too much crap running in the background on your computer.

    Edit - And why is Disable Turbo checked? When you slow your CPU down, it will spend more time in the C0 state processing background tasks when it could be in the low power C7 state instead.

    Edit #2 - Are you using the Windows Balanced power profile with the minimum processor state set to 5%. The High Performance profile will use max CPU speed, even when idle.
     
    Last edited: Aug 20, 2018
    _sem_ and Papusan like this.
  9. Kaitlyn2004

    Kaitlyn2004 Notebook Enthusiast

    Reputations:
    0
    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    16
    Here is a shot of the details. It moves around a bit of course, but was 95 +/- 3%

    I've disabled Turbo (in BIOS too) because my understanding is that this helps keep thermals under control?

    Yes I'm using the Balanced profile - only profile listed, and yes when plugged in it's on "Best Performance" for the battery slider. I guess that's actually it - having it on "Best" locks it in? Simple as that?

    Thanks for all your help BTW

    CPU.png
     
    custom90gt likes this.
  10. custom90gt

    custom90gt Doc Mod Super Moderator

    Reputations:
    7,272
    Messages:
    3,301
    Likes Received:
    3,521
    Trophy Points:
    331
    Sadly Microsoft decided to do away with power "profiles" now and lets you slide a slider from battery savings to best performance. Running it on best performance will do exactly that and keep your CPU running at a faster frequency.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page