Please help, My HP CD drive wont recognize disks.

Discussion in 'HP & Compaq' started by kalbracht, Mar 24, 2010.

Thread Status:
Not open for further replies.
  1. kalbracht

    kalbracht Notebook Enthusiast

    Reputations:
    0
    Joined:
    Aug 14, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Everytime I put a disk into my laptop and try to load it, it tells me the disk is blank. I have tried putting in a blank disk for itunes to burn a cd and when I tried to burn it the drive opened and told me to insert a disk. So then I tried even a different brand of blank disks and still had no luck. I have also put in a actual cd and a cd for a program in but when I tried to run them the drive opened and said to please insert a disk. I'm not sure why its doing this. It was working perfectly fine a couple days before. I have typed "regedit" and deleted the upper and lower filters and then restarted the computer, I have used the control panel to uninstall the drive and then restarted the computer, I have made sure my drive was up-to-date and it said it was, and I have even tried restarting the computer while holding the eject button until the computer was loaded. I have no idea what to do. Please someone help!
     
  2. sgttoughbook

    sgttoughbook Notebook Consultant

    Reputations:
    79
    Joined:
    Jan 15, 2010
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    30
    ok for one have you changed the OS latl;ey like upgraded if so windows might have reasigned you drive letters wich dosent fly well with hp's. just assuming this is what happened hear is how to change it back.

    To change it back:

    Right-click My Computer.

    Click Properties. The System Properties window appears.

    Click the Device Manager tab.

    Click the plus sign (+) next to CDROM.

    Double-click the CD-ROM name, and click the Settings tab.

    Under Reserved drive letters, select M (or the previously assigned letter) from the pull-down menu. Make sure that both the Start drive letter and the End drive letter are the same.

    Click OK, Close, and then click Yes.
     
  3. kalbracht

    kalbracht Notebook Enthusiast

    Reputations:
    0
    Joined:
    Aug 14, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    I didnt get to do what you suggested. It would probably help to know I'm using Windows 7 and have been for a while now. Sorry about not stating that earlier.
     
  4. SL2

    SL2 Notebook Deity

    Reputations:
    704
    Joined:
    Feb 8, 2006
    Messages:
    973
    Likes Received:
    64
    Trophy Points:
    41
    It's the same in W7. You can get to the device manager in many ways, one way is to open the start menu and type device manager , click it when it shows up in the menu.

    Or, open the Control panel and then System properties.

    Or, press Windows + Pause on the keyboard.;)
     
  5. deeastman

    deeastman Notebook Deity

    Reputations:
    977
    Joined:
    Dec 1, 2006
    Messages:
    1,095
    Likes Received:
    0
    Trophy Points:
    55
    I am running Windows 7 Pro and Windows XP on two of my computers but you cannot change the CD-ROM Drive letters by the approach you outlined on either of my systems in Drive Manager. There is no 'settings' tab.

    I would suggest:

    1. Click on Control Panel
    2. Click Administrative Tools
    3. Click Computer Management
    4. Click Disk Management (Under Storage)

    Or

    1. Right Click on My Computer
    2. Click Manage
    3. Click Disk Management

    In the Right Panel, Right Click on your CD-ROM and select “Change Drive Letter and Paths…”
    You can now Change, Add, or Remove drive letters
     
  6. kalbracht

    kalbracht Notebook Enthusiast

    Reputations:
    0
    Joined:
    Aug 14, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Its set to E: right now is that a problem?
     
  7. deeastman

    deeastman Notebook Deity

    Reputations:
    977
    Joined:
    Dec 1, 2006
    Messages:
    1,095
    Likes Received:
    0
    Trophy Points:
    55
    You didn't mention what model HP laptop you have. If it is model which only has room for only one HD, i.e. not a 17" model, then the CD/DVD drive is set as the D: drive from the factory in HP laptops. If you have other logical partitions on your C: HD then the drive letter of the CD ROM will change. Although it shouldn't matter, if you only have a C: drive and no other logical partitions I would change it back to D:. It actually sounds like you have a bad CD drive or connection but trying to help by examining all other possible issues.

    Now, if your laptop is a 17" model with space for two HD's then leave the CD/DVD drive as E:. Your two internal HD drives would be identified as C: and D:. Even if only one HD is installed the second would be reserved as D:.
     
  8. kalbracht

    kalbracht Notebook Enthusiast

    Reputations:
    0
    Joined:
    Aug 14, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Yeah I have a C: and a D: drive! My hp model is the G60-458DX. Thanks for all the attempts to help, but does anyone else have any ideas :/
     
  9. KLF

    KLF NBR Super Modernator Super Moderator

    Reputations:
    2,523
    Joined:
    Apr 20, 2007
    Messages:
    2,285
    Likes Received:
    292
    Trophy Points:
    101
    Try booting with any bootable disc (ultimate bootcd, OS install disc etc), if even that doesn't work you probably have a broken drive.

    If booting works, then it's issue within Windows. Some games include DRM that may mess with drives, especially if you have some virtual disc or cd burning software installed.
     
  10. kalbracht

    kalbracht Notebook Enthusiast

    Reputations:
    0
    Joined:
    Aug 14, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    So you want me to reboot with the windows 7 cd?
     

Thread Status:
Not open for further replies.

Share This Page