Pascal ROG Strix GL502/GL702 Thread

Discussion in 'ASUS Gaming Notebook Forum' started by NBRlurker, Aug 16, 2016.

Thread Status:
Not open for further replies.
  1. ginandtonic

    ginandtonic Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    4
    Trophy Points:
    6
    Sorrry how do you install this? I tried to copy and paste in rog gaming center but it asks for an .exe file? I have a GL502VM.
    Thanks
     
    Last edited: May 13, 2017
  2. don_svetlio

    don_svetlio In the Pipe, Five by Five.

    Reputations:
    351
    Messages:
    3,616
    Likes Received:
    1,825
    Trophy Points:
    231
    That is for the VM versions which have a 1060 dGPU. If you have a VS model it will likely not work for you.
     
  3. Coldbird

    Coldbird Notebook Enthusiast

    Reputations:
    5
    Messages:
    26
    Likes Received:
    13
    Trophy Points:
    6
    I've experimented with the GL502VM/FX502VM series for a while now and found that the best gaming experience can be achieved simply by disabling turbo-boost alltogether.
    What I first believed to be a heat-throttling issue turned out to be a power-limiting issue instead, which means the heat we suffered was never the actual cause of throttling at all.

    What really happens on the GL502VM/FX502VM series is that the device turbo-boosts "too much" on the CPU, effectively driving the power consumption above the 28-seconds PL1 average power consumption limit, which in turn causes the hardware to throttle itself back to its minimal power consumption state <= 800mhz, which in turn causes horrible lagspikes in games.
    I've tried everything, from custom voltage curves for the GPU, CPU undervolts, PL1 parameter modification using XTU, etc. but have found that under permanent stress (on both the GPU and CPU), the highest average you can achieve on this notebook at somewhat-stable rates without exceeding the PL1 power limit is around 3ghz.

    The amount of configuration required for this however does not warrant the gain, as you can achieve stable permanent 2.8ghz on your CPU by simply modifying the windows registry and enabling a hidden setting in the windows power settings to effectively disable turbo boost altogether.
    Given that the device can't sustain stable 3.8ghz turbo boost beyond 28seconds runtime anyway, I think its the wiser choice, as it eliminates all lagspikes and makes this device a bliss to game on.

    Long story short: Follow the steps I've outlined below and your device will behave, no questions asked, with no throttling, however, you will trade in a variable 800mHz~3.8gHz CPU frequency range, that often jumps between max and min value (3.8gHz -> 800mHz -> 3.8gHz -> rinse repeat), to a more stable, always stays at the top under load, 800mHz~2.8gHz variable frequency range.
    1. Save the following text file as enable-hidden-power-settings.reg on your desktop: https://pastebin.com/QNKHPgkx
    2. Double-click the newly created file and merge it into your windows registry.
    3. Open your start menu and go into Power Options.
    4. Click on "Change Plan Settings" next to your currently active power profile, which I assume, given this is a gaming notebook is "High Performance".
    5. Click on "Change advanced power settings".
    6. Scroll down to "Processor power management" and unfold the node.
    7. Unfold the "Processor performance boost mode" node (this setting was hidden prior to you modifying the registry with my enable-hidden-power-settings.reg file).
    8. Change the setting "On battery" and "Plugged in" to Disabled.
    9. Click the "OK" button to confirm and save your changes.
    I consider the "problem" solved at this point, as those settings give me solid 60+fps on 1080p ultra on pretty much every game, and even at 1440p ultrawide on my desktop monitor if I disable Parallax Occlusion.
     
    Attila Papp, hmscott and ginandtonic like this.
  4. ginandtonic

    ginandtonic Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    4
    Trophy Points:
    6

    Thank you for that.

    I have applied these changes, need to do some game testing now.... fingers crossed
     
  5. Attila Papp

    Attila Papp Notebook Enthusiast

    Reputations:
    10
    Messages:
    44
    Likes Received:
    15
    Trophy Points:
    16
    Thanks for your outstanding work.

    I made several benchmarks with cinebench and it seems like that disabling turbo causes ~15% performance drop on avarage, but it fully eleminates the fps drops. In order to use your system's full potential you can quickly disable/enable turbo with this method:

    I created two power plan profiles in Windows, one with turbo disabled and one with turbo enabled. I also made a batch file to quickly switch between them. When I am gaming I disable turbo with double clicking on my batch file otherwise I keep it enabled.

    This way no undervolting is needed.

    If you are interested I can share the batch file.
     
  6. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,100
    Messages:
    20,384
    Likes Received:
    25,138
    Trophy Points:
    931
    C'mon guys, really???

    Disabling Turbo reduces your computer to Base Clock Speed, which is cutting out a lot of performance.

    Just try a CPU benchmark with "High Performance" power plan with 100%, and again with 99% or less (Turbo Disable starts at 99%).

    See how much performance you are losing.

    If you are having cooling issues when running 100% CPU performance, even with best undervolt, then get the laptop up on a laptop cooler stand.

    With the laptop at an angle to take advantage of convective cooling - and a clear path for the hot air to go so it doesn't come back into an air intake.

    Re-paste if you must to be able to run at 100% CPU perforamnce, but don't neuter your laptop by disabling Turbo.

    You might as well get a cheaper laptop with a worse performance CPU than neuter your high performance laptop by running with Turbo disabled.
     
    Last edited: May 14, 2017
    don_svetlio likes this.
  7. Coldbird

    Coldbird Notebook Enthusiast

    Reputations:
    5
    Messages:
    26
    Likes Received:
    13
    Trophy Points:
    6
    Oh boy where to start...

    First and foremost, as documented the issues with this notebook's lagspikes aren't because the CPU is overheating, it gets quite toasty, yes, but it isn't overheating and the throttle-reasons reported by the CPU are all PL1 power-limit related.
    Which, I repeat myself at this point, are caused by an extensive unsustainable power-draw caused by the CPU/GPU combo, which exceeds the "safe" limit set by Asus.

    This limit can not be modified (easily) without the assistance of Asus and an accompanying BIOS setting to toggle it, which means we are slaves to the PL1 power-limit they've set for us.
    Buying a notebook cooler would do absolutely nothing to help us here.

    Another note to consider is that when you set the CPU limit to 99% (like you did) you get 2.69gHz max clock, while with my method you at the very least get your base clock of 2.79gHz (2.8gHz), so you aren't even undercutting your base clock at this point yet.
    I also love how you say that we are sacrificing our performance by doing this... while this might be true on paper, I will take a fluid consistent 60+fps over a theoretically higher average fps with 2-minute long power-limiting lagspikes inbetween.

    There is however one thing I do agree on with you, if anyone bought this notebook series, and isn't in absolute need of the GTX 1060, I would definitely go with a cheaper but less PL1-limited GTX 1050 Ti notebook out there.
    Dell's new IPS-equipped "gaming" notebooks come to mind.

    However, a base-clocked GL502VM/FX502VM still performs way better than a boostable one of these, so in terms of raw power to price you are still getting a (slightly) better deal here, at the cost of having to handle this issue by yourself.
     
    hmscott and Attila Papp like this.
  8. Attila Papp

    Attila Papp Notebook Enthusiast

    Reputations:
    10
    Messages:
    44
    Likes Received:
    15
    Trophy Points:
    16
    We should contact Asus, maybe they can patch the PL-1 power limit with a BIOS update
     
  9. Coldbird

    Coldbird Notebook Enthusiast

    Reputations:
    5
    Messages:
    26
    Likes Received:
    13
    Trophy Points:
    6
    Already did... after a long time of haggling around with all kinds of support clerks I finally got in touch with one of their engineers but still, they refused to take action on the matter, which quite openly shows they don't care much about fixing this issue or making the PL1 power limit adjustable.
    While it is possible to adjust the PL1 power limit in XTU, its not the setting we are actually looking for sadly as the hardware-set one still remains unchangeable, which means we can regulate it further down from the 45W default value, but not increase it beyond said value.

    I mean we can... its just that it has no effect other than looking nice in the GUI.
     
    hmscott likes this.
  10. Attila Papp

    Attila Papp Notebook Enthusiast

    Reputations:
    10
    Messages:
    44
    Likes Received:
    15
    Trophy Points:
    16
    That's very sad. Am I wrong in assuming that uv only eleminates the problem by using less power and therefore not exceeding the 45W limit?
     
    hmscott likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page