P750DM2-G From HID

Discussion in 'Sager and Clevo' started by PeenX2, Apr 8, 2017.

  1. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,773
    Messages:
    41,661
    Likes Received:
    9,780
    Trophy Points:
    931
    Maybe speak to HID then as web browsing should be smooth normally on battery.
     
  2. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    @Prema Still fighting this thing...

    Flashed BIOS to new v2 Prema and now it's throttling worse! HWInfo is showing "IA: Electical Design Point/ Other (ICCmax, PL4, SVID, DDR RAPL)" as reason for throttle. Reinstalled Windows yet again, and running ThrottleStop is not helping.

    All my current limits are up in BIOS so not sure what's going on anymore.

    BIOS 1.06.09EVOC V2
    KBC/EC 1.06.050C
     
  3. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,773
    Messages:
    41,661
    Likes Received:
    9,780
    Trophy Points:
    931
    I wonder if somehow the power delivery circuitry from the battery has some sort of issue...
     
  4. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    Yeah maybe,

    Mine does the same thing as this video...which is an old video. And it was an EC issue.

     
    Last edited: Apr 23, 2017
  5. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
Loading...

Share This Page