P750DM2-G From HID

Discussion in 'Sager and Clevo' started by PeenX2, Apr 8, 2017.

  1. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    Does it on stock speeds too though...
     
  2. Phoenix

    Phoenix Super Tweaker

    Reputations:
    6,088
    Messages:
    13,339
    Likes Received:
    15,890
    Trophy Points:
    931
    you can't use the battery on such high performance clocks man, think of a battery as a backup not as a means of using the laptop. This is not your typical portable laptop. You can try to stay on the balanced plan and see if the clocks hold higher
     
    TomJGX likes this.
  3. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    Well that's a bummer. It has nothing to do with CPU clocks though, they stick where they are no matter what. Even with bios default's it has the same issue. Something to do with GPU I'm sure, like the BIOS won't allow the GPU to do much on battery.

    Can barely browse the web on battery, even 100% stock bios settings. Was hoping to be able to unplug once in awhile and use the internet. The battery lasts almost 3hrs on full charge, but pointless since it's unusable.
     
  4. Phoenix

    Phoenix Super Tweaker

    Reputations:
    6,088
    Messages:
    13,339
    Likes Received:
    15,890
    Trophy Points:
    931
    ill have a look soon, gimme a moment
     
    Last edited: Apr 15, 2017
  5. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,704
    Messages:
    40,928
    Likes Received:
    9,304
    Trophy Points:
    931
    It should still browse ok, which browser are you using?
     
  6. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    Chrome, Edge, FireFox, IE...they all lag horribly. It games fine on battery.

    Everything is set High Performance, tried setting card to Max Performance in nVidia Control Panel. Checked DPC latency, all good. Tried a seperate OS install as well on another SSD, still lags. Tried BIOS reset too.

    Feels like some sort of hardware limit to me. Once I plug back in, it's fine.
     
  7. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,704
    Messages:
    40,928
    Likes Received:
    9,304
    Trophy Points:
    931
    Try it with a more balanced profile and at stock instead.
     
  8. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    I've tried both, all profiles and 100% stock bios settings.
     
  9. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    17,375
    Messages:
    27,989
    Likes Received:
    30,659
    Trophy Points:
    931
    Have you already tried disabling hardware acceleration in your browser? This being enabled causes me all sorts of stupid issues and it also prevents the GPU clocks from dropping into 2D mode when enabled.

    If not, maybe give that a try. IE, Edge, Firefox and Chrome all have options for this. In Chrome go to the Advanced Settings and clear both check boxes under "Settings" then restart the browser.

    upload_2017-4-17_18-21-45.png
     
    Prostar Computer and Phoenix like this.
  10. PeenX2

    PeenX2 Notebook Enthusiast

    Reputations:
    16
    Messages:
    24
    Likes Received:
    11
    Trophy Points:
    6
    Yeah, I always turn it off anyways because of the same reasons you described.
     
Loading...

Share This Page