P170EMx still alive... but need help... ;)

Discussion in 'Sager/Clevo Reviews & Owners' Lounges' started by Marcus72, Nov 19, 2020.

Tags:
  1. Marcus72

    Marcus72 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi, everyone..

    I tried to post on the P170 thread but it's closed.... so sad...

    I have a 'brazilian' Clevo P170EMx branded as AVELL.

    Everything working fine under windows 10, except for the webcam. Tried everything, searched a lot of places, even tried those 'scam' driver update softwares, with no success. It was ok under windows 7.

    I don't know if it's a thing, but my BIOS is 1.00.03.

    https://photos.app.goo.gl/sQ2JPcCCFxLf1L886

    I'd appreciate any help at all.

    Regards.
     
    Last edited: Nov 19, 2020
  2. Dr. AMK

    Dr. AMK Living with Hope

    Reputations:
    3,686
    Messages:
    2,146
    Likes Received:
    4,463
    Trophy Points:
    281
    All old webcams having the same problem with Windows 10. Rollback to Win7 or use an external USB webcam.
     
  3. Marcus72

    Marcus72 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Really? no other way? :/
     
  4. Dr. AMK

    Dr. AMK Living with Hope

    Reputations:
    3,686
    Messages:
    2,146
    Likes Received:
    4,463
    Trophy Points:
    281
    The only way that you can see the webcam manufacturer in the device manager, then go to their website and see if there is any new drivers for it, then google it in case someone has the same problem and he developed something as a work around, other than that nothing really you can do.
    Good luck.
     
Loading...

Share This Page