P170em 7970m overheating help

Discussion in 'Sager and Clevo' started by jonny4312, Aug 21, 2018.

Thread Status:
Not open for further replies.
  1. jonny4312

    jonny4312 Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    Basically I've had a p170em with a 7970m for a while, it's a workhorse and never given me an issue. As of this week I'd be playing games and it would freeze requiring a power off/on. Upon booting up the card would be missing from device manager with the drivers. The card would appear after being removed and replaced or if I shut down windows again (in some instances). I started measuring temps, idle is fine at 45. During games it ramps up past 90 and beyond; 107 in cuisine royale today.
    I have cleaned the fans, repaste the GPU twice with different pastes. The fan spins fine and I lubricated it. No difference. Fresh install windows caused issues, it would freeze as soon as the GPU was activated on amd drivers if I updated them from ones windows installed. Worked around this by disabling it and removing the windows drivers, installing an older version of catalyst and then updated to the latest drivers. Still overheats however.
    Upon listening to the fan (CPU is fine do don't think it's mobile) it only seems to ramp up at 90 degrees, but it doesn't seems to be blowing out at full speed like it used too resulting in the 100+ temps and freezes. Any advice would be appreciated, I cannot control the fan speeds with it being a stock bios p170em
     
  2. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,215
    Messages:
    51,973
    Likes Received:
    14,849
    Trophy Points:
    931
    You could try reflashing the BIOS/EC in case the table got corrupted. You could also double check all the heatpipes are working properly.
     
  3. jonny4312

    jonny4312 Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    I have no idea where to start with the bios. Contacted a reseller and they said it's doubtful something messed with the ec and it's probably just the fan motor dying, but I'm struggling to find anywhere in the UK or Europe that doesn't sell them for extortionate prices (cough* eurocom £90)
     
  4. kothletino

    kothletino Notebook Consultant

    Reputations:
    60
    Messages:
    271
    Likes Received:
    94
    Trophy Points:
    41
    Problems with installing graphics drivers were the first signs that my graphics card was dying(7970m). She was in the oven twice then she worked for a year and 2nd time for 6 months but i changed to 8970m and then for gtx1060.
    As for fans, they can just end their lives maybe? Look on ebay, not by eurocom. :rolleyes:
     
  5. jonny4312

    jonny4312 Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    I'm trying to flash the EC/bios but all I'm getting is not enough memory after using Rufus and freedos
     
    Last edited: Aug 24, 2018
Loading...
Thread Status:
Not open for further replies.

Share This Page