P170EM & 1060 MXM - install, mods, nvidia inf mod (with photo)

Discussion in 'Sager and Clevo' started by origin17em, Feb 3, 2018.

  1. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,316
    Messages:
    57,645
    Likes Received:
    17,389
    Trophy Points:
    931
    @Prema and that's about it ;)
     
    Ionastip likes this.
  2. Ionastip

    Ionastip Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Ah thanks...

    @Prema

    Any chance I can get a V2 Prema BIOS Mod or even better a V3 Prema BIOS Mod for my p170em for a small donation?
     
  3. origin17em

    origin17em Notebook Enthusiast

    Reputations:
    17
    Messages:
    21
    Likes Received:
    29
    Trophy Points:
    6
  4. festa_freak

    festa_freak Notebook Enthusiast

    Reputations:
    0
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    5
    Hello, thank you origin17em for your tutorials on how to upgrade the video cards!

    I've been out of tech for a while and I want to upgrade my older P170EM from a 7970m to a better card. I've read that nvidia 9xx and 10xx work as you have shown. I've also read that I may need different heatsinks and such and different thermal pads etc.. What is the procedure to upgrade from an amd card such as mine? Would it be easier to upgrade to mobile versions of newer AMD cards?
     
  5. Jay333

    Jay333 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi all, I'm new to this so forgive me if I'm asking some dumb questions. I've been reading through a lot of different threads, but I've been unable to pinpoint exactly what's causing my issue.

    I'm looking to update my P170SM-A with an GTX 1060, and the card isn't being recognized by the BIOS (says VGA card unknown). Do I need to update and/or unlock my BIOS in order to make it work? The computer simply boots to a black screen unless I mash F2 to go into BIOS, so I can't even go into Windows and mess around with installing any drivers. I'm running Windows 10, by the way.

    @Prema, do you think you could help me get my hands on a BIOS version that might fix my issue? Grateful for any help!

    ----Details from my current BIOS:
    MB Series: P17SM-A
    BIOS version: 1.03.02R LS1
    KBC/EC Firmware Revision: 1.03.03
    VGA Card: NV GeForce GTX 870M
     
Loading...

Share This Page