Overclock/ Undervolt on Linux

Discussion in 'Linux Compatibility and Software' started by jclausius, Feb 19, 2018.

  1. jclausius

    jclausius Notebook Virtuoso

    Reputations:
    1,197
    Messages:
    2,613
    Likes Received:
    1,142
    Trophy Points:
    181
    OK. There's a lot more research I need to do on voltage, OC, etc. in regards to the Mighty Mini - to re-iterate, I've never done anything like this before, so am unsure of settings.

    Currently, the UEFI has the following (my settings are underlined):

    Core Voltage Mode: Auto, Adaptive, Override
    Core Voltage Override: Auto, or a numeric value within a range
    Core Voltage Offset: 0.010, Auto, or a number between 0.001 and 1.000
    Offset Prefix: -, +

    For "Core Voltage Offset", I've tried numbers between -0.020 and -0.085. Windows boots and passes stress testing just fine within this range. For Linux booting, under-volting between -0.020 and -0.085 will crash Linux. For -0.019 <= settings <= -0.001, I can boot, and log in, but it will freeze the computer within 10 to 120 seconds.

    I don't believe so. No.

    IIRC, the GTX 10x0 MXM cards changed the PCB layouts and I don't think there is room within the case to fit these newer cards.
     
  2. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    23,464
    Messages:
    32,416
    Likes Received:
    46,074
    Trophy Points:
    931
    Not 1080, but 1060 and 1070 there is a fair chance it will work. The biggest issue is the 10x0 series has no LVDS support, so when it does work it is typically only on laptops that use eDP.
     
    jclausius likes this.
  3. ALLurGroceries

    ALLurGroceries   Super Moderator

    Reputations:
    9,685
    Messages:
    7,042
    Likes Received:
    924
    Trophy Points:
    281
    Interesting. Are you setting any special kernel parameters? If you are unsure check the output of
    Code:
    cat /proc/cmdline
     
    Vasudev and jclausius like this.
  4. jclausius

    jclausius Notebook Virtuoso

    Reputations:
    1,197
    Messages:
    2,613
    Likes Received:
    1,142
    Trophy Points:
    181
    Here's the output :

    BOOT_IMAGE=/boot/vmlinuz-4.13.0-36-generic root=UUID={snipped_guid_of_samsung_960_partition} ro quiet splash vt.handoff=7

    ----

    Do you suppose the problem has to do with Voltage Mode being "Auto" instead of Adaptive or Override?
     
    Last edited: Feb 21, 2018
  5. ALLurGroceries

    ALLurGroceries   Super Moderator

    Reputations:
    9,685
    Messages:
    7,042
    Likes Received:
    924
    Trophy Points:
    281
    Nothing unusual or potentially related in your boot parameters.

    When it crashes in linux, is it always with a machine check exception, or are there different kernel oopses?

    If it's always an MCE you could try the mcelog utility to see what (if anything) useful comes out of decoding it.

    On the other hand, there are potential differences in your BIOS' ACPI handling based on the OS it detects. You could try spoofing it with the acpi_osi kernel parameter as "Windows 2015" for Windows 10 or "Windows 2016" or "Windows 2017"

    --
    edit: documentation: https://github.com/torvalds/linux/blob/master/Documentation/admin-guide/kernel-parameters.txt#L153

    Also, just in case you didn't already know, you don't need to permanently put this kernel parameter in your grub config. you can just hit the 'e' key at the grub boot menu and add it to the end of the normal boot parameters and then hit ctrl+x to boot

    You could also try the acpi_os_name parameter, although I don't ever remember using this one myself:
    https://github.com/torvalds/linux/blob/master/Documentation/admin-guide/kernel-parameters.txt#L144

    --

    I don't think the voltage being Auto should really explain why it's crashing in Linux and not windows, but if you haven't tried messing with it, it's worth a try.

    If you can, try booting into linux in some sort of recovery mode (non-graphical) and just sit there and see what comes along in your dmesg, syslog, or /proc/kmsg if syslogd isn't running. If you have lm_sensors configured run
    Code:
    watch -n1 sensors
    And keep an eye on your voltage

    None of this is going to get you anywhere definitive, but it'll start opening up possible lines of attack.
     
    Last edited: Feb 21, 2018
    Vasudev and jclausius like this.
  6. jclausius

    jclausius Notebook Virtuoso

    Reputations:
    1,197
    Messages:
    2,613
    Likes Received:
    1,142
    Trophy Points:
    181
    @ALLurGroceries - Thanks for the response... There's a lot there, and I'll go thru it in a bit. But I've made serious progress, and wanted to report it here:

    a) With everything back to defaults in UEFI, whlie using HWInfo, I ran Prime95 v26.6 on Windows along with OCCT to a max reading on the CPU voltage (VID).
    b) On a whim, I changed the following in the ASRock UEFI:
    Core Voltage Mode: Adaptive
    Core Voltage Override: Set to the max CPU voltage I encountered in step A (1.126V)
    Core Voltage Offset: -0.088 - uncovered during runs of Prime and OCCT in earlier testing.
    c) Saved settings

    Success!! I can now boot into the Linux partition, and without any MCE errors. So something about the 'Auto' settings was causing the issue.

    Now, I need to validate / find a voltage offset that works with Linux. I'm going to use 'stress-ng' and hopefully find the sweet spot for the CPU. I'll post my findings to this thread.
     
  7. Cihancan

    Cihancan Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    Ive a acer vn7-571g im planning to install linux on it. My computer disables its turbo when it reaches to 80 degrees celcius, i use throttlestop on windows to block it from disabling turbo at 80 degrees, do anyone know which cpu register i need to modify to get same effect of throttlestop on linux?
     
  8. Grant B Gibson

    Grant B Gibson Notebook Deity

    Reputations:
    230
    Messages:
    1,053
    Likes Received:
    421
    Trophy Points:
    101
    You shouldn't do that, you will damage your CPU if you do that over time, I don't know why you would ever do that
     
  9. Cihancan

    Cihancan Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    as i said im doing it for 2 years 7/24 without a problem, as long as i dont pass 105C which is shutdown temperature of i5-5200 there shouldnt be a problem
     
  10. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    3,753
    Messages:
    6,810
    Likes Received:
    4,516
    Trophy Points:
    431
    I think unchecking BD PROCHOT might solve the issue because I tried it on my sister's laptop with i5 5200U.
    Moreover repasting can bring down those temps considerably.
     
    Aroc and hmscott like this.
Loading...

Share This Page