Optimus IX (Clevo) and Linux Mint 19 - screen brightness problem

Discussion in 'Linux Compatibility and Software' started by BigMackCam, Oct 19, 2018.

Thread Status:
Not open for further replies.
  1. BigMackCam

    BigMackCam Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    Hello all

    I've just bought a 17.3" Optimus IX i7-8750H laptop PC with integrated Intel and discrete NVIDIA GTX 1050 Ti graphics from PC Specialist Ltd here in the UK. I believe it's based on a Clevo N850EK (?), although dmidecode reports it as N8xEJEK.

    After installing with acpi=off in grub, I've managed to get Linux Mint 19 up and running. I've also installed the relevant nvidia driver (390, I think), nvidia-prime and the nvidia settings desktop utility. The machine boots and is running stable without acpi=off in grub. I can see and switch between both GPUs without problem.

    I still have a few issues still to resolve, however, and the most crucial of these is the ability to adjust display brightness.

    Currently, when I use the relevant keyboard functions to increase or decrease brightness, the operating system clearly recognises that I'm trying to adjust it, as the adjustments show on screen as I press the brightness up/down keys. But the brightness remains constant - except when it reaches minimum, at which point the screen goes completely black, then when I increase it again, the screen returns to full brightness.

    I've tried each of the following settings in grub (followed by update-grub) without success:

    acpi_backlight=vendor

    acpi_backlight=video

    acpi_osi=! acpi_osi='Windows 2009'


    The contents of /sys/class/backlight shows intel_backlight. I've run the following command:

    systemctl enable systemd-backlight@backlight:intel_backlight.service

    ... and it returns the message "Failed to enable unit: Unit file systemd-backlight@backlight:intel_backlight.service does not exist."

    I've tried creating the sysbacklight script in the Ubuntu help pages, setting it to use intel_backlight. The script runs fine, but has no effect on the screen brightness.

    Lastly, I've created a 20-intel.conf xorg conf file in the /usr/share/X11/xorg.conf.d directory containing the following:

    Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"
    EndSection


    Before doing so, I checked that my Intel GPU is at PCI address 0:2.0 using "lspci -vnn | grep VGA -A 12".

    None of this has worked, so I'm at a loss.

    Can anyone suggest anything that might help, please? I'm afraid I'm still very much a linux novice, but I'm slowly finding my way around!

    Much of the information above was provided by @Dennismungai for another member facing similar problems. I'm very grateful to him for indirectly assisting me too, even though I haven't yet managed to get this working :p

    Thanks in advance

    Mike
     
    Last edited: Oct 19, 2018
  2. Dennismungai

    Dennismungai Notebook Deity

    Reputations:
    765
    Messages:
    923
    Likes Received:
    854
    Trophy Points:
    106
    Hello there,

    Attempt this first:

    For the grub options, make sure this line is identical:

    GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' blacklist=nouveau elevator=deadline drm.debug=0xe quiet splash"

    Then update grub:

    sudo update-grub

    Then reboot and attempt to toggle backlight control.

    Also, can you show me the output of:

    xrandr --listproviders
     
    Aroc, Spartan, steberg and 2 others like this.
  3. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,551
    Messages:
    10,464
    Likes Received:
    7,745
    Trophy Points:
    931
    @Dennismungai You need to pass nomodeset along with acpi quirks which you suggested above.
    I also recommend OP to install linux-firmware fo best experience and then running update-grub.
     
    BigMackCam likes this.
  4. BigMackCam

    BigMackCam Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    Thank you both :)

    @Dennismungai - I'm just trying the grub now; then I'll try with the suggestion from @Vasudev to include nomodeset.

    @Vasudev - my apologies for the linux newbie question, but when you say "install linux-firmware", would I do this with "sudo apt-get install linux-firmware" ??

    Thanks again, guys - I really appreciate your help.
     
  5. BigMackCam

    BigMackCam Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    Folks - I've reached a point where I think I'm going to have to run with Windows instead :(

    I'd tried an install of Windows 10 earlier today (which went fine) and also installed all of Clevo's supplied drivers and updates. Since doing that, now when I do a Linux Mint 19 install it crashes during bluetooth installation. I'm guessing that Clevo's updates might change the firmware of the machine, but that's only a guess. I had no such problems in my previous attempts to install Linux :(

    Many thanks again for your help.
     
  6. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,551
    Messages:
    10,464
    Likes Received:
    7,745
    Trophy Points:
    931
    Use synaptic package manager and type linux-firmware and install it.
    Do you use AMI Aptio 5 Bios or insyde h20 bios?
     
  7. BigMackCam

    BigMackCam Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    It's AMI Aptio...
     
    Vasudev likes this.
  8. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,551
    Messages:
    10,464
    Likes Received:
    7,745
    Trophy Points:
    931
    Have you tried with just nomodeset?
     
  9. xDjinn

    xDjinn Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    2
    Trophy Points:
    16
    Edit: GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash i915.alpha_support=1 acpi_osi=linux acpi_backlight=vendor "
    GRUB_CMDLINE_LINUX=""


    That's how my grub is setup after a cr** of trial and error I believe the "acpi_osi=linux acpi_backlight=vendor" is what allowed me to set keyboard shortcuts to control screen brightness.
     
    Last edited: Nov 24, 2018
  10. Dennismungai

    Dennismungai Notebook Deity

    Reputations:
    765
    Messages:
    923
    Likes Received:
    854
    Trophy Points:
    106

    If what you have in your signature is the machine you're running Linux on, please drop the acpi_osi=linux line such that it looks like this:

    GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash i915.alpha_support=1
    acpi_osi=! acpi_osi='Windows 2009' acpi_backlight=vendor "

    Using acpi_osi=linux is not recommended. Infact, Linux, by default, responds "false" to that specific _OSI query.
     
    Vasudev likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page