OpenSUSE vs Toughbook CF19_MK6

Discussion in 'Panasonic' started by SJLPHI, Jul 24, 2017.

  1. SJLPHI

    SJLPHI Notebook Guru

    Reputations:
    0
    Messages:
    71
    Likes Received:
    8
    Trophy Points:
    16
    Hello, recently I've acquired a toughbook cf19-mk6, and I've been wrestling quite some time to have OpenSUSE 13.2 KDE to be installed on it properly.

    So far, the laptop is given a 512gb SSD, 16gb RAM and is doing excellent on the Windows 7 side, but it's being very stubborn on the linux side. There are 2 issues that I'd like to address, all of which I do believe is driver issue.

    All buttons are picked up, and respond correctly to respective functionality, but they have no physical effect.

    a) Screen bright/dim buttons, and FN + F1/F2 shows that the KDE is "trying" to change things, but the actual screen doesn't change its brightness.
    b) Same exact issue with the sound, and in fact, it is not making any sound for the time being.

    After doing a bit of reading, I tried a kernel upgrade:
    4.12.3-2.g880dbd7-default #1 SMP PREEMPT Sat Jul 22 01:04:04 UTC 2017 (880dbd7) x86_64 x86_64 x86_64 GNU/Linux

    no cigar yet. I am constantly looking things online, but if someone has something to share, please do.

    My suspicion is that on the boot/grub, acpi is currently set to load vendor, if I can blacklist or load a specific one, I'll be golden. I've had this issue with Lenovo T410s v.s. Linux Mint before.

    Thank you for your time.
     
  2. Karl Klammer

    Karl Klammer Notebook Geek

    Reputations:
    30
    Messages:
    83
    Likes Received:
    32
    Trophy Points:
    26
    Hi,

    backlight via front buttons and function keys works just fine with grub_cmdline_linux "acpi_backlight=Linux acpi_osi=", at least on qubes3.2/fedora23 with kernel 4.4.67.

    Give alsactl init a shot for sound.
     
    kode-niner and Shawn like this.
  3. SJLPHI

    SJLPHI Notebook Guru

    Reputations:
    0
    Messages:
    71
    Likes Received:
    8
    Trophy Points:
    16
    Thank you Karl, the screen brightness is now working.

    alsactl init didn't quite work. Back to more reading/trying. Please let me know if you have other suggestions. Thanks again!
     
  4. Karl Klammer

    Karl Klammer Notebook Geek

    Reputations:
    30
    Messages:
    83
    Likes Received:
    32
    Trophy Points:
    26
    Hi SJLPHI,

    regarding sound: What do dmesg and lsmod report?
    sample output of my cf19mk6 191HC51FL included for reference

    Did you hit mute while/if/during it was booted into Windows? (win & lin seem to (un)mute differently...)


    $:~> dmesg | grep snd
    [ 38.683616] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VC: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    [ 38.683622] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [ 38.683625] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
    [ 38.683630] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
    [ 38.683633] snd_hda_codec_realtek hdaudioC0D0: inputs:
    [ 38.683638] snd_hda_codec_realtek hdaudioC0D0: Front Mic=0x19
    [ 38.683643] snd_hda_codec_realtek hdaudioC0D0: Rear Mic=0x18

    $:~> lsmod | grep snd
    snd_hda_codec_realtek 86016 1
    snd_hda_codec_generic 69632 1 snd_hda_codec_realtek
    snd_hda_intel 40960 4
    snd_hda_codec 126976 3 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel
    snd_hda_core 61440 4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
    snd_hwdep 16384 1 snd_hda_codec
    snd_seq 69632 0
    snd_seq_device 16384 1 snd_seq
    snd_pcm 118784 3 snd_hda_codec,snd_hda_intel,snd_hda_core
    snd_timer 32768 2 snd_pcm,snd_seq
    snd 77824 17 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
    soundcore 16384 1 snd
     
    kode-niner and Shawn like this.
  5. SJLPHI

    SJLPHI Notebook Guru

    Reputations:
    0
    Messages:
    71
    Likes Received:
    8
    Trophy Points:
    16
    Hey Karl, you're totally right. When I unmute on Window side, then alsactl init, I seem to get sound properly until reboot.

    SUPERNET:/etc/init.d # dmesg |grep snd
    [ 17.417562] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VC: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    [ 17.417564] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [ 17.417565] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
    [ 17.417565] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
    [ 17.417566] snd_hda_codec_realtek hdaudioC0D0: inputs:
    [ 17.417568] snd_hda_codec_realtek hdaudioC0D0: Front Mic=0x19
    [ 17.417568] snd_hda_codec_realtek hdaudioC0D0: Rear Mic=0x18
    SUPERNET:/etc/init.d # lsmod |grep snd
    snd_hda_codec_realtek 102400 1
    snd_hda_codec_generic 94208 1 snd_hda_codec_realtek
    snd_hda_intel 49152 3
    snd_hda_codec 167936 3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
    snd_hda_core 98304 4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
    snd_hwdep 16384 1 snd_hda_codec
    snd_pcm 147456 3 snd_hda_intel,snd_hda_codec,snd_hda_core
    snd_timer 40960 1 snd_pcm
    snd 106496 13 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
    soundcore 16384 1 snd
    SUPERNET:/etc/init.d #

    I am going to tell it to initialize alsa on boot from this point, but is there a way to bypass the Windows mute?
     
  6. SJLPHI

    SJLPHI Notebook Guru

    Reputations:
    0
    Messages:
    71
    Likes Received:
    8
    Trophy Points:
    16
    Well, this is getting a bit frustrating, putting alsactl init at the bottom of /etc/init.d/boot.local didn't work.
     
  7. Karl Klammer

    Karl Klammer Notebook Geek

    Reputations:
    30
    Messages:
    83
    Likes Received:
    32
    Trophy Points:
    26
    I didn't dig deeper into the Win-mute vs Lin-mute issue,
    as I usually pick either Win or Lin and virtualize the other.

    SuSE is using systemd now, which means we lack a trusty, useable init system.
    How about an @Reboot /usr/sbin/alsactl init crontab instead?
     
    Last edited: Jul 25, 2017
  8. SJLPHI

    SJLPHI Notebook Guru

    Reputations:
    0
    Messages:
    71
    Likes Received:
    8
    Trophy Points:
    16
    I will look into that Karl after I complete my avenue of approach.

    I've also tried to chmod permission the alsa to be accessible for non-root and tried to run it as user so it can be called from autostart in a script. No avail.

    Right now, some people have found a very well working solution, to directly install Realtek HD audio codec driver provided by RealTek.

    I am however at a loss because the driver simply will not compile, so I will have to do more reading.

    For reference, on the Windows side the sound is controlled by Realtek HD,

    Linux version is also available here:
    http://www.realtek.com.tw/downloads...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

    There is a nice set of instructions for installation available here:
    http://airbornesurfer.com/2015/04/how-to-install-realtek-hd-audio-driver-in-linux/
     
  9. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    17
    Messages:
    206
    Likes Received:
    63
    Trophy Points:
    41
    This problem sounds familiar.
     
    Shawn likes this.
  10. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,410
    Messages:
    6,595
    Likes Received:
    1,032
    Trophy Points:
    331
    Very familiar
     
Loading...

Share This Page