Open Hardware Monitor - Web Server / Win10 Firewall HELP!!

Discussion in 'Windows OS and Software' started by Hobbo91, Feb 5, 2018.

  1. Hobbo91

    Hobbo91 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    6
    Trophy Points:
    6
    I'm hoping someone can help me, so I'm running Open Hardware Monitor 0.8.0 Beta (Latest) on a Windows 10 Pro laptop. Everything works fine but a feature which appeals to me is the built in Web Server, It's nice to have my laptop plugged into the TV playing games, and be able to quickly check the temperatures on my phone.

    I cannot however for the life of me get the Windows Firewall to allow access to the application via port 8445 on my local network.

    Things I've tried:

    Control Panel -> Windows Defender -> Allow app or Feature through Firewall then enabled the rule, and ticked the 'Public' (tried private as well) check boxes.

    I have also specifically set up a TCP rule which opens the internal port of 8445 to the external port 8445 pointing at the Open Hardware Monitor executable.

    Neither will allow access, if I simply turn off the Windows firewall it does work fine so this is clearly something I am missing or doing wrong.

    Just to clarify the laptop has a static DHCP lease on the router so I know I am accessing the correct IP.etc
     
  2. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    500
    Messages:
    3,171
    Likes Received:
    378
    Trophy Points:
    151
    Did you also ask Microsoft Windows support as well since the Firewall and O/S is a Microsoft product? And did you contact Open hardware monitor support since that is their software and could offer more insight to the configuration?
     
  3. Hobbo91

    Hobbo91 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    6
    Trophy Points:
    6
    Hmm.. I think this would be a very quiet and boring forum if people just went direct to software vendors and followed defined support channels :)

    I managed to fix this in the end, this was an issue with how the Firewall was mapping its self to the application. Creating a rule which allows 'Any' local port, to the correctly specified remote port allowed me to connect whilst on the local network. This isn't the best way to go about managing firewall rules, but this machine will always be on a relatively secure network with an external firewall anyway...
     
    Starlight5 and alexhawker like this.
  4. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    500
    Messages:
    3,171
    Likes Received:
    378
    Trophy Points:
    151
    No it isn't boring they are the one behind the software and would offer some insights as well as they might learn something outside of their box. Why else do you think it's called their Support email. This is a End user forum to help and not something like a Official company support site. Those on here don't have access to company programming to know all the in and outs that they don't want others to know for reason of IP. If there is a problem with their software then they should know about it and fix it and then the rest can use it more better. But then again this is a End User forum help not something like a company support channel when it comes to help only on here.
     
  5. Hobbo91

    Hobbo91 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    6
    Trophy Points:
    6
    I was just asking a forum of like minded people a very basic technical question regarding the Windows 10 firewall. I'm well aware of what a support channel is, how they work and what they're for. But thanks anyway for your advice.
     
  6. Starlight5

    Starlight5 So what if I'm crazy? The best people are.

    Reputations:
    327
    Messages:
    2,557
    Likes Received:
    1,115
    Trophy Points:
    181
    @Hobbo91 check existing firewall rules, something is interfering probably.
     
  7. drwatz0n

    drwatz0n Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    5
    @Hobbo91 . This is a late reply, but I had a similar issue.

    If the device is on the same network and there's NAT involved with the router, change the following setting for the Firewall rule you set up for port 8085:

    Click the rule -> Advanced -> Edge Traversal -> Allow Edge Traversal

    This allowed me to access the page/server via a tablet device on the same network.
     
    alexhawker likes this.
Loading...

Share This Page