Omen Command Center update to Omen Gaming Center with UNDERVOLTING!

Discussion in 'HP' started by OneSickOmen17t, Nov 25, 2020.

  1. OneSickOmen17t

    OneSickOmen17t Notebook Consultant

    Reputations:
    10
    Messages:
    151
    Likes Received:
    8
    Trophy Points:
    31
    Go to Microsoft store and hit "Launch" it will update and then just restart your laptop. Now a tab for Undervolting is there. I'm a 10th gen i9-10885H and the display is working. Shows Intelligent and custom (up to -.995v) I will offically test today after work. This is why I love HP!
     
    4W4K3 likes this.
  2. OneSickOmen17t

    OneSickOmen17t Notebook Consultant

    Reputations:
    10
    Messages:
    151
    Likes Received:
    8
    Trophy Points:
    31
  3. K_Michael

    K_Michael Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Good News!
     
    Last edited: Dec 1, 2020
  4. Rocchire

    Rocchire Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    2
    Trophy Points:
    6
    It's also available and working with Omen 17 i7 9750h.

    Intelligent mode brought me down to -0,070 V, but before with thottlestop I was running -0,103/-0,113 V.
     
    4W4K3 likes this.
  5. october3

    october3 Notebook Enthusiast

    Reputations:
    5
    Messages:
    23
    Likes Received:
    6
    Trophy Points:
    6
    This is brilliant, great job by HP to listen and implement undervolting. Its working on my Omen 15 2020 with h10750, which has latest F06 bios

    *Note that I got an error message about SGX running at first preventing the omen gaming hub app working, and had to go into the Bios to switch it off
     
  6. neit_jnf

    neit_jnf Notebook Guru

    Reputations:
    6
    Messages:
    53
    Likes Received:
    18
    Trophy Points:
    16
    The intelligent only did -.090 on mine so i turned it off
    I run -.180 core -.130 cache with throttlestop
     
    october3 likes this.
  7. Guvernator

    Guvernator Notebook Enthusiast

    Reputations:
    5
    Messages:
    18
    Likes Received:
    7
    Trophy Points:
    6
    Picked up my Omen 17 with i7 10750 and RTX 2080 Super a few days ago and saw this post. I updated to the new command hub but it said it also needed to update the bios to enable undervolting. I hit the update button and after about 10 minutes the bios updated too and it was all ready to go. I tried intelligent at first which only gave me a - 0.070 undervolt. I then set it to custom and have it running at - 0.100v but I think it can do a bit more. Temps where hitting low 80's with occasional spikes into 86-87 before undervolting which is OK but I'd like to get that a bit lower so I'll have a bit more of a play over the next few days.
     
  8. october3

    october3 Notebook Enthusiast

    Reputations:
    5
    Messages:
    23
    Likes Received:
    6
    Trophy Points:
    6
    I found CPU temps decreased by doing a repaste of the cpu too

    *edit
     
    Last edited: Dec 4, 2020
  9. october3

    october3 Notebook Enthusiast

    Reputations:
    5
    Messages:
    23
    Likes Received:
    6
    Trophy Points:
    6
    Hey, I have done a few runs and testing in games, thought I would post settings here, just for reference for anyone with similar hardware

    (I have GPU voltage pinned at 725mV and no overclocks set in afterburner)

    For ref with everything running max I get 3100 in cinebench run, with the below it gives 2550 andtmax temp is only 86deg Cduring benchmark with fans on auto

    I leave the undervolting in gaming centre off, Auto Fans, performance mode and hybrid graphics
    Have set a mild undervolt in throttlestop -40mV and reduced the frequency multiplier to x37, the TS bench with this is 9.4secs against 8.4sec with everything maxed and the temp too high
    The maximum wattage given to cpu is like this is 50watts, which keeps the temps down

    I'm sure there is more to be tweaked but happy with this and running in games, except set graphics to discrete

    upload_2020-12-4_10-38-52.png

    upload_2020-12-4_10-39-7.png
     

    Attached Files:

    Last edited: Dec 10, 2020
  10. october3

    october3 Notebook Enthusiast

    Reputations:
    5
    Messages:
    23
    Likes Received:
    6
    Trophy Points:
    6
    I just noticed the HWinfo window I posted above was the wrong one, showing no voltage offset

    1 week later and still working good, increased the under volt to -60mv

    rock solid!
     
Loading...

Share This Page