OMEN 1070 Laptop 100C

Discussion in 'Gaming (Software and Graphics Cards)' started by collegekid28, Feb 17, 2017.

  1. Matthew Gary

    Matthew Gary Notebook Consultant

    Reputations:
    2
    Messages:
    131
    Likes Received:
    41
    Trophy Points:
    41
    Möbius what kind of tape did you use to seal up the fans?


    Sent from my iPhone using Tapatalk
     
  2. Matthew Gary

    Matthew Gary Notebook Consultant

    Reputations:
    2
    Messages:
    131
    Likes Received:
    41
    Trophy Points:
    41
    Disregard, just saw that you said foil tape. What kind of foil tape though? I'm thinking I might try this on my sager no8157.


    Sent from my iPhone using Tapatalk
     
  3. Templesa

    Templesa Notebook Deity

    Reputations:
    167
    Messages:
    789
    Likes Received:
    229
    Trophy Points:
    56
    Meh, FWIW, I got a cheap $1100 Omen with the 1060 6GB, i7, G-Sync 75hz, etc. and it runs fine. No problems, temps fantastic. You can bash HP, but occasionally they deliver. In the Clevo/MSi/Asus camp, I was paying more for less.
     
    karasahin likes this.
  4. Mobius 1

    Mobius 1 what is quality control?

    Reputations:
    2,663
    Messages:
    7,600
    Likes Received:
    4,731
    Trophy Points:
    431

    Foil tape, any kind works.

    Particular one used in this mod: http://www.homedepot.com/p/Nashua-T...ulti-Purpose-HVAC-Foil-Tape-1207792/100030120
     
  5. collegekid28

    collegekid28 Notebook Enthusiast

    Reputations:
    11
    Messages:
    38
    Likes Received:
    4
    Trophy Points:
    16
    Mobius 1 did you use coolsense with this laptop. I had a issue with "
    System Temperature (90D)" error. It happens when I play Fifa 17 which isn't that demanding of a game. On top of that I had turned turbo boost off to combat the high temp problems I had at the start of this thread. Which works great and I can game at 1080 max settings with everything I play. I can't for the life of me figure out why it was shutting down with the cpu only going to 2.8. I tried to read a bit on coolsense but got nothing really. So I turned it off. I turned turbo boost back on just to see if I would get thermal throttling and I didn't. Cpu runs at 85C and a boost of 3.7xx. I don't get it... Anyone care to explain?
     
  6. TBoneSan

    TBoneSan Laptop Fiend

    Reputations:
    4,205
    Messages:
    5,466
    Likes Received:
    5,543
    Trophy Points:
    681
    Have you tried overclocking the display?
     
  7. Templesa

    Templesa Notebook Deity

    Reputations:
    167
    Messages:
    789
    Likes Received:
    229
    Trophy Points:
    56
    I have not, but I'll give it a go.
    My external at home is a 27" G-Sync Predator that runs up to 144hz so never really needed to OC since 75hz on the go is pretty good.
     
  8. TBoneSan

    TBoneSan Laptop Fiend

    Reputations:
    4,205
    Messages:
    5,466
    Likes Received:
    5,543
    Trophy Points:
    681
    My old DM1 had a 75hz Gsync panel which I was lucky to get to 100hz - it was a nice little win. May the LED gods favor you my friend.
     
    Templesa likes this.
  9. Templesa

    Templesa Notebook Deity

    Reputations:
    167
    Messages:
    789
    Likes Received:
    229
    Trophy Points:
    56
    I attempted 110 and it did not like it. So far (Haven't been able to test with any games yet) 105 is working. So that's a nice little bump! Though I may lower it to around 90 just to be safe.
     
    TBoneSan likes this.
  10. TBoneSan

    TBoneSan Laptop Fiend

    Reputations:
    4,205
    Messages:
    5,466
    Likes Received:
    5,543
    Trophy Points:
    681
    Sweet man ... well done. I'd round it up to 100 and call it a day - she'll be right ;) That's a nice bump and I'd be pretty chuffed with that.
     
Loading...

Share This Page