**Official Sager NP9175 / Clevo P775TM Owner's Lounge!**

Discussion in 'Sager/Clevo Reviews & Owners' Lounges' started by Phoenix, Oct 6, 2017.

  1. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    1,541
    Messages:
    4,787
    Likes Received:
    2,598
    Trophy Points:
    231
    did you overclock anything? such as ram on xmp profile, cpu overclocked etc, set everything to default and see if it boots up fine and see if you can get windows installation goes through.
     
  2. Qadhi79

    Qadhi79 Notebook Enthusiast

    Reputations:
    25
    Messages:
    48
    Likes Received:
    49
    Trophy Points:
    26
    tried the termal pads first instead of thermal paste..the temperature again reached 91C but this time it was quick to reach these temps and took a while to cool down

    repasted with Thermal Grizzly Kryonaut and used the paper clip mod..finally the temperatures are not going past 85C after 30 minutes of full load..thats 6C decrease from the previous results.
     
  3. BeastsForever.TheDragon

    BeastsForever.TheDragon Notebook Evangelist

    Reputations:
    172
    Messages:
    562
    Likes Received:
    381
    Trophy Points:
    76
    Nope, did just "undervolted" 3-4 weeks ago, and thing has been still running nice since then,
    Could this possibly be a motherboard failure?

    Btw i cant do an rma,
    I bought the laptop from usa(avadirect) and now i live in india
     
  4. Jumpwired

    Jumpwired Notebook Consultant

    Reputations:
    26
    Messages:
    113
    Likes Received:
    63
    Trophy Points:
    41
    Thermal pads can't replace good thermal compound.
    Sounds like it worked, paperclip to the rescue.
     
  5. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    1,541
    Messages:
    4,787
    Likes Received:
    2,598
    Trophy Points:
    231
    have you made any changes to bios settings? try resetting your bios and do a cold restart see if problem still persist. if not proceed to install a fresh window and see if issue comes again. also what kind of error code were you getting during BSOD, and what error code for the window OS installation.

    but honestly google is your friend. https://answers.microsoft.com/en-us...h/54db0c8f-f9f0-4093-b2fe-ad378685686a?page=1

    i dont have windows 10 so this is your call, try deleting that file, did you recently have windows update on? did anything get updated at all? does your win 10 OS include that file, all sounds messed up to me but its MS with UEFI, where everything goes wrong.
     
    Last edited: Jan 12, 2018
  6. BeastsForever.TheDragon

    BeastsForever.TheDragon Notebook Evangelist

    Reputations:
    172
    Messages:
    562
    Likes Received:
    381
    Trophy Points:
    76
    Great!!!!
    My laptop now dosent even boot now, all i see is a scroller at top left corner and the leds go off! Along with the screen!
    This is like worst nightmare come true!

    @Mr. Fox @Papusan
     
  7. Jumpwired

    Jumpwired Notebook Consultant

    Reputations:
    26
    Messages:
    113
    Likes Received:
    63
    Trophy Points:
    41
    Thats sucks dude, hope you can figure something out. I personally had issues with BSOD caused by XMP1 and XMP2.

    This is the second P755TM on here with problems. For as much crap as AW got, I was expecting nothing but sunshine and daisies from Clevo. Loving the laptop, but these issues and ****ty GPU temps without modding isn't confidence inspiring.

    It seems like only the P870TM gets any love here.
     
  8. BeastsForever.TheDragon

    BeastsForever.TheDragon Notebook Evangelist

    Reputations:
    172
    Messages:
    562
    Likes Received:
    381
    Trophy Points:
    76
    Dropped it to local repair shop(they were shocked to see a desktop lga cpu in a laptop,,,ROFL)
    Yea thisis really uninspiring for a clevo user tho, also my good old dm3g died 4-5months ago!
     
    ole!!! likes this.
  9. BeastsForever.TheDragon

    BeastsForever.TheDragon Notebook Evangelist

    Reputations:
    172
    Messages:
    562
    Likes Received:
    381
    Trophy Points:
    76
    Lol, i am still 16!
     
  10. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    1,541
    Messages:
    4,787
    Likes Received:
    2,598
    Trophy Points:
    231
    did you reset your bios? try doing that first. basically we are giving you tips and tricks that might solve your problem without u having to go to repair shop because honestly, when comes to clevo laptops the forum users and good resellers support will know way more, the shop can't even compare.

    ontop of that, clevo laptop its hard to find parts because they dont sell them, so even if they want to try replace something and blind test, they dont have access to it.
     
Loading...

Share This Page